aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:19 +0000
commit5cb5c6d0fb3d3d8a3cfc9db32fb7c639900905ab (patch)
tree4478b4f0d44c734aa14e61c576b9eda4c7038902
parent1e68ff85db65fefa45f6935dfa1f1df809a7d13b (diff)
downloadports-5cb5c6d0fb3d3d8a3cfc9db32fb7c639900905ab.tar.gz
ports-5cb5c6d0fb3d3d8a3cfc9db32fb7c639900905ab.zip
devel/py-xstatic-tv4: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-xstatic-tv4/Makefile7
-rw-r--r--devel/py-xstatic-tv4/files/patch-setup.py11
2 files changed, 16 insertions, 2 deletions
diff --git a/devel/py-xstatic-tv4/Makefile b/devel/py-xstatic-tv4/Makefile
index 86aff8fe1a13..e9cf9fbcb71f 100644
--- a/devel/py-xstatic-tv4/Makefile
+++ b/devel/py-xstatic-tv4/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xstatic-tv4
PORTVERSION= 1.2.7.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,8 +15,11 @@ WWW= https://geraintluff.github.io/tv4/ \
LICENSE= MIT PD
LICENSE_COMB= dual
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/devel/py-xstatic-tv4/files/patch-setup.py b/devel/py-xstatic-tv4/files/patch-setup.py
new file mode 100644
index 000000000000..df2ff796f33d
--- /dev/null
+++ b/devel/py-xstatic-tv4/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2016-05-05 05:06:16 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ setup(
+ from setuptools import setup, find_packages
+
+ setup(
+- name=xs.PACKAGE_NAME,
++ name='xstatic-tv4',
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,