aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Beconne <jpbeconne@free.fr>2021-11-05 05:49:46 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-11-05 05:49:46 +0000
commit5d36955e8997f46a7987fab69c0a524b3b9d9751 (patch)
tree994825ce86e815f9acaedc00b053415ab9513808
parent2507b096e4fb31d83420dc9fe3681b5b73537d20 (diff)
downloadports-5d36955e8997f46a7987fab69c0a524b3b9d9751.tar.gz
ports-5d36955e8997f46a7987fab69c0a524b3b9d9751.zip
devel/R-cran-usethis: New Port: Automate Package and Project Setup
PR: 246839
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-usethis/Makefile35
-rw-r--r--devel/R-cran-usethis/distinfo3
-rw-r--r--devel/R-cran-usethis/pkg-descr5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3a1acb534d02..2a9d27eae978 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -120,6 +120,7 @@
SUBDIR += R-cran-waldo
SUBDIR += R-cran-whisker
SUBDIR += R-cran-withr
+ SUBDIR += R-cran-usethis
SUBDIR += R-cran-zeallot
SUBDIR += RStudio
SUBDIR += SpecTcl
diff --git a/devel/R-cran-usethis/Makefile b/devel/R-cran-usethis/Makefile
new file mode 100644
index 000000000000..4120868c176d
--- /dev/null
+++ b/devel/R-cran-usethis/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= usethis
+DISTVERSION= 2.0.1
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= jpbeconne@free.fr
+COMMENT= Automate Package and Project Setup
+
+LICENSE= GPLv3
+
+CRAN_DEPENDS= R-cran-clipr>=0.3.0:devel/R-cran-clipr \
+ R-cran-clisymbols>0:devel/R-cran-clisymbols \
+ R-cran-crayon>0:devel/R-cran-crayon \
+ R-cran-curl>=2.7:ftp/R-cran-curl \
+ R-cran-desc>=1.2.0:devel/R-cran-desc \
+ R-cran-fs>=1.3.0:sysutils/R-cran-fs \
+ R-cran-gert>=1.0.2:devel/R-cran-gert \
+ R-cran-gh>=1.2.0:www/R-cran-gh \
+ R-cran-glue>=1.3.0:devel/R-cran-glue \
+ R-cran-jsonlite>0:converters/R-cran-jsonlite \
+ R-cran-lifecycle>0:devel/R-cran-lifecycle \
+ R-cran-purrr>0:devel/R-cran-purrr \
+ R-cran-rappdirs>=0.3.3:devel/R-cran-rappdirs \
+ R-cran-rlang>0.4.10:devel/R-cran-rlang \
+ R-cran-rprojroot>=1.2:devel/R-cran-rprojroot \
+ R-cran-rstudioapi>0:devel/R-cran-rstudioapi \
+ R-cran-whisker>0:devel/R-cran-whisker \
+ R-cran-withr>=2.3.0:devel/R-cran-withr \
+ R-cran-yaml>0:textproc/R-cran-yaml
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-usethis/distinfo b/devel/R-cran-usethis/distinfo
new file mode 100644
index 000000000000..d4853a562048
--- /dev/null
+++ b/devel/R-cran-usethis/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623869185
+SHA256 (usethis_2.0.1.tar.gz) = ef269e7a3190791bc77ff1d5cb11f20cb594adedb334805f88db5451f3ffd6c8
+SIZE (usethis_2.0.1.tar.gz) = 306090
diff --git a/devel/R-cran-usethis/pkg-descr b/devel/R-cran-usethis/pkg-descr
new file mode 100644
index 000000000000..1e4917f93af7
--- /dev/null
+++ b/devel/R-cran-usethis/pkg-descr
@@ -0,0 +1,5 @@
+Automate package and project setup tasks that are otherwise performed
+manually. This includes setting up unit testing, test coverage, continuous
+integration, Git, 'GitHub', licenses, 'Rcpp', 'RStudio' projects, and more.
+
+WWW: https://CRAN.R-project.org/package=usethis