aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 23:57:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 23:57:54 +0000
commit5d49fc886eb0527b17c9f3c06301343c21730768 (patch)
tree9ddbbed215ebd954f2b46d45e835b52a68501521
parentd62edd548ee2d69a358b88a9d10e8cdb4eea0afb (diff)
devel/grpc: Add EXTRACT_AFTER_ARGS
PR: 278736 Reported by: diizzy
-rw-r--r--devel/grpc/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/grpc/Makefile b/devel/grpc/Makefile
index 9a31b48fcd62..8ac19259c151 100644
--- a/devel/grpc/Makefile
+++ b/devel/grpc/Makefile
@@ -52,8 +52,19 @@ PLIST_SUB= PORTVERSION=${PORTVERSION} \
CONFLICTS_INSTALL= grpc[0-9][0-9][0-9]
-post-patch:
# Clean up bundled libraries
+.if !defined(MAINTAINER_MODE)
+EXTRACT_AFTER_ARGS= --exclude ${DISTNAME}/third_party/abseil-cpp/ \
+ --exclude ${DISTNAME}/third_party/benchmark/ \
+ --exclude ${DISTNAME}/third_party/boringssl-with-bazel/ \
+ --exclude ${DISTNAME}/third_party/cares/ \
+ --exclude ${DISTNAME}/third_party/protobuf/ \
+ --exclude ${DISTNAME}/third_party/re2/ \
+ --exclude ${DISTNAME}/third_party/xxhash/ \
+ --exclude ${DISTNAME}/third_party/zlib/ \
+ --no-same-owner --no-same-permissions
+.else
+post-patch:
@${RM} -r ${WRKSRC}/third_party/abseil-cpp/
@${RM} -r ${WRKSRC}/third_party/benchmark/
@${RM} -r ${WRKSRC}/third_party/boringssl-with-bazel/
@@ -64,5 +75,6 @@ post-patch:
#@${RM} -r ${WRKSRC}/third_party/utf8_range/
@${RM} -r ${WRKSRC}/third_party/xxhash/
@${RM} -r ${WRKSRC}/third_party/zlib/
+.endif
.include <bsd.port.mk>