aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2022-12-05 13:46:04 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2022-12-05 13:47:27 +0000
commit5d9a5a6a2e7fe4dec6e679ad4c02e98aca158cae (patch)
tree650efc05bf40a7c3c815a10f34d8d8134692db0c
parente94cfe13757e0cd1fc20bf1e4f182881666935dd (diff)
downloadports-5d9a5a6a2e7fe4dec6e679ad4c02e98aca158cae.tar.gz
ports-5d9a5a6a2e7fe4dec6e679ad4c02e98aca158cae.zip
security/stunnel: Update to 5.67
PR: 268167 Submitted by: Daniel Engberg
-rw-r--r--security/stunnel/Makefile8
-rw-r--r--security/stunnel/distinfo6
-rw-r--r--security/stunnel/files/patch-src_client.c11
3 files changed, 6 insertions, 19 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 1243839959fd..305f8dc07aff 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -1,18 +1,16 @@
PORTNAME= stunnel
-DISTVERSION= 5.65
+DISTVERSION= 5.67
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= https://www.stunnel.org/downloads/archive/5.x/ \
https://ftp.nluug.nl/pub/networking/stunnel/archive/5.x/ \
- http://ftp.nluug.nl/pub/networking/stunnel/archive/5.x/
+ http://www.usenix.org.uk/mirrors/stunnel/archive/5.x/
MAINTAINER= zi@FreeBSD.org
COMMENT= SSL encryption wrapper for standard network daemons
WWW= https://www.stunnel.org/
-# FIXME: IMHO, there really ought to be a GPL-2+ option or some such.
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2+
BROKEN_SSL= libressl libressl-devel
BROKEN_SSL_REASON= missing upstream support
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index 404e9e9270b2..e395762d0358 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658088789
-SHA256 (stunnel-5.65.tar.gz) = 60c500063bd1feff2877f5726e38278c086f96c178f03f09d264a2012d6bf7fc
-SIZE (stunnel-5.65.tar.gz) = 872293
+TIMESTAMP = 1670228606
+SHA256 (stunnel-5.67.tar.gz) = 3086939ee6407516c59b0ba3fbf555338f9d52f459bcab6337c0f00e91ea8456
+SIZE (stunnel-5.67.tar.gz) = 881256
diff --git a/security/stunnel/files/patch-src_client.c b/security/stunnel/files/patch-src_client.c
deleted file mode 100644
index 181ffc5fa946..000000000000
--- a/security/stunnel/files/patch-src_client.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/client.c.orig 2022-07-17 20:37:11 UTC
-+++ src/client.c
-@@ -77,6 +77,8 @@ NOEXPORT int redirect(CLI *);
- NOEXPORT void print_bound_address(CLI *);
- NOEXPORT void reset(SOCKET, const char *);
-
-+extern char **environ;
-+
- /* allocate local data structure for the new thread */
- CLI *alloc_client_session(SERVICE_OPTIONS *opt, SOCKET rfd, SOCKET wfd) {
- static unsigned long long seq=0;