aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-28 00:54:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-28 00:55:21 +0000
commit5df0c8fefe7cecc404757f7e86c527dfd3eb80d0 (patch)
tree0c7283c40453317fde6d6aa08f1e39fb119b29f5
parentab3eb985eae1c73a8c2ecb62da7dbb596f8fbf6f (diff)
downloadports-5df0c8fefe7cecc404757f7e86c527dfd3eb80d0.tar.gz
ports-5df0c8fefe7cecc404757f7e86c527dfd3eb80d0.zip
misc/py-papermill: New port: Parameterize, execute, and analyze notebooks
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-papermill/Makefile43
-rw-r--r--misc/py-papermill/distinfo3
-rw-r--r--misc/py-papermill/pkg-descr6
4 files changed, 53 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 36fe481a027e..75f6fac4128c 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -412,6 +412,7 @@
SUBDIR += py-orange3-network
SUBDIR += py-orange3-timeseries
SUBDIR += py-palettable
+ SUBDIR += py-papermill
SUBDIR += py-pexpect
SUBDIR += py-powerline-status
SUBDIR += py-progressbar
diff --git a/misc/py-papermill/Makefile b/misc/py-papermill/Makefile
new file mode 100644
index 000000000000..9367ea05057f
--- /dev/null
+++ b/misc/py-papermill/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= papermill
+DISTVERSION= 2.4.0-15
+DISTVERSIONSUFFIX= -g54f6c03
+CATEGORIES= misc python
+#MASTER_SITES= CHEESESHOP using the latest revision
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Parameterize, execute, and analyze notebooks
+WWW= https://papermill.readthedocs.io/en/latest/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}entrypoints>0:devel/py-entrypoints@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbclient>=0.2.0:devel/py-nbclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>=5.1.2:devel/py-nbformat@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tenacity>=5.0.2:devel/py-tenacity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.32.2:misc/py-tqdm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}azure-datalake-store>=0.0.30:devel/py-azure-datalake-store@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-storage-blob>=12.1.0:devel/py-azure-storage-blob@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}moto>0:devel/py-moto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbclient>0:devel/py-nbclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>0:devel/py-nbformat@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-env>0:devel/py-pytest-env@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= nteract
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-papermill/distinfo b/misc/py-papermill/distinfo
new file mode 100644
index 000000000000..e0d933336c49
--- /dev/null
+++ b/misc/py-papermill/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672186578
+SHA256 (nteract-papermill-2.4.0-15-g54f6c03_GH0.tar.gz) = 26c50811facefef0cc7af3f3d6f49e37fe474d97679eac17967a67ce07e134b2
+SIZE (nteract-papermill-2.4.0-15-g54f6c03_GH0.tar.gz) = 1065931
diff --git a/misc/py-papermill/pkg-descr b/misc/py-papermill/pkg-descr
new file mode 100644
index 000000000000..83edf5bc2227
--- /dev/null
+++ b/misc/py-papermill/pkg-descr
@@ -0,0 +1,6 @@
+papermill is a tool for parameterizing, executing, and analyzing
+Jupyter Notebooks.
+
+Papermill lets you:
+* parameterize notebooks
+* execute notebooks