aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Beconne <jpbeconne@free.fr>2021-06-28 05:01:08 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-06-28 05:01:08 +0000
commit5e840630b3e1f75154dadfa1e8e003ac02de7c28 (patch)
tree2d1ed86ea3437bc349fa0a488dde8677cdbd1323
parent240ab2238c11da51b9a9a1492f81408a701362e1 (diff)
downloadports-5e840630b3e1f75154dadfa1e8e003ac02de7c28.tar.gz
ports-5e840630b3e1f75154dadfa1e8e003ac02de7c28.zip
security/R-cran-credentials: New port
Tools for Managing SSH and Git Credentials. PR: 256708 Approved by: lwhsu (mentor, implicit)
-rw-r--r--security/Makefile1
-rw-r--r--security/R-cran-credentials/Makefile21
-rw-r--r--security/R-cran-credentials/distinfo3
-rw-r--r--security/R-cran-credentials/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4e3c96124cc0..15d22cd1d391 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -7,6 +7,7 @@
SUBDIR += ADMsnmp
SUBDIR += R-cran-ROAuth
SUBDIR += R-cran-askpass
+ SUBDIR += R-cran-credentials
SUBDIR += R-cran-digest
SUBDIR += R-cran-gitcreds
SUBDIR += R-cran-openssl
diff --git a/security/R-cran-credentials/Makefile b/security/R-cran-credentials/Makefile
new file mode 100644
index 000000000000..0b9af6d4b967
--- /dev/null
+++ b/security/R-cran-credentials/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= credentials
+DISTVERSION= 1.3.0
+CATEGORIES= security
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= jpbeconne@free.fr
+COMMENT= Tools for Managing SSH and Git Credentials
+
+LICENSE= MIT
+
+CRAN_DEPENDS= R-cran-openssl>=1.3:security/R-cran-openssl \
+ R-cran-sys>=2.1:devel/R-cran-sys \
+ R-cran-curl>0:ftp/R-cran-curl \
+ R-cran-jsonlite>0:converters/R-cran-jsonlite \
+ R-cran-askpass>0:security/R-cran-askpass
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/security/R-cran-credentials/distinfo b/security/R-cran-credentials/distinfo
new file mode 100644
index 000000000000..2c72a4651546
--- /dev/null
+++ b/security/R-cran-credentials/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623957877
+SHA256 (credentials_1.3.0.tar.gz) = c119ec26fd97b977c3b0cd1eb8fad3c59b84df6262c3adbf5ee9f3d6c9903ff1
+SIZE (credentials_1.3.0.tar.gz) = 230082
diff --git a/security/R-cran-credentials/pkg-descr b/security/R-cran-credentials/pkg-descr
new file mode 100644
index 000000000000..278648988111
--- /dev/null
+++ b/security/R-cran-credentials/pkg-descr
@@ -0,0 +1,10 @@
+Setup and retrieve HTTPS and SSH credentials for use with 'git'
+and other services. For HTTPS remotes the package interfaces
+the 'git-credential' utility which 'git' uses to store HTTP
+usernames and passwords. For SSH remotes we provide convenient
+functions to find or generate appropriate SSH keys. The package
+both helps the user to setup a local git installation, and also
+provides a back-end for git/ssh client libraries to authenticate
+with existing user credentials.
+
+WWW: https://docs.ropensci.org/credentials