aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-30 15:42:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-05 15:10:41 +0000
commit5eaed4a582941272682ac381056a0280f9cff785 (patch)
tree17a110d79a55735ce3d254821b9fc7355f1556de
parenta18742b098f18b468f4eedb17f7404a716dba73e (diff)
games/freebee: add port
Free Bee is an enhanced Free Software clone of The New York Times game Spelling Bee. In this game, your goal is to find as many words as you can with the seven letters you are given. You don't have to use any letter except the middle letter and letters can be used more than once in a word. Finding a word that uses all seven letters yields bonus points! Every game has at least one such word, and many games have multiple. Earning enough points to reach the rank of Queen Bee wins the game! You can play the daily challenge like the original game or try your hand at a nearly infinite number of computer-generated random challenges. Unlike the original game, you are not restricted to only a single game per day! WWW: https://freebee.fun/ WWW: https://github.com/freebee-game/console-client
-rw-r--r--games/Makefile1
-rw-r--r--games/freebee/Makefile27
-rw-r--r--games/freebee/distinfo3
-rw-r--r--games/freebee/files/patch-Makefile47
-rw-r--r--games/freebee/pkg-descr19
-rw-r--r--games/freebee/pkg-plist3
6 files changed, 100 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 3368bbc095c0..9549c7870ec7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -278,6 +278,7 @@
SUBDIR += fortunate
SUBDIR += fotaq
SUBDIR += four-in-a-row
+ SUBDIR += freebee
SUBDIR += freeblocks
SUBDIR += freecell-solver
SUBDIR += freeciv
diff --git a/games/freebee/Makefile b/games/freebee/Makefile
new file mode 100644
index 000000000000..b080db8e4e90
--- /dev/null
+++ b/games/freebee/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= freebee
+DISTVERSIONPREFIX= ${PORTNAME}-
+DISTVERSION= 1.7
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Multi-platform ncurses-based console client for Free Bee
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USES= ncurses
+USE_GITHUB= yes
+GH_ACCOUNT= freebee-game
+GH_PROJECT= console-client
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/freebee/distinfo b/games/freebee/distinfo
new file mode 100644
index 000000000000..c942c9f53674
--- /dev/null
+++ b/games/freebee/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620327621
+SHA256 (freebee-game-console-client-freebee-1.7_GH0.tar.gz) = a239520a4f10f5206e81a219d1cc7d3056f668b7119934d074fb8c65999244c3
+SIZE (freebee-game-console-client-freebee-1.7_GH0.tar.gz) = 453839
diff --git a/games/freebee/files/patch-Makefile b/games/freebee/files/patch-Makefile
new file mode 100644
index 000000000000..2edc9d571b40
--- /dev/null
+++ b/games/freebee/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig 2020-07-28 01:02:14 UTC
++++ Makefile
+@@ -2,18 +2,18 @@
+
+ CC ?= cc
+ CFLAGS ?= -O2 -pipe
+-CFLAGS += -I/usr/local/include
++CFLAGS += -I${LOCALBASE}/include
+
+ # Remove if your system doesn't have
+ # arc4random_uniform(3) and/or strlcat(3)
+ # Same with pledge(2) and/or unveil(2)
+ CFLAGS += -DHAVE_ARC4RANDOM_UNIFORM -DHAVE_STRLCAT
+-CFLAGS += -DHAVE_PLEDGE -DHAVE_UNVEIL
++#CFLAGS += -DHAVE_PLEDGE -DHAVE_UNVEIL
+
+ # Uncomment if you don't want to install
+ # or if you plan to install the dictionary somewhere
+ # other than /usr/local/share/freebee/enable1.txt
+-#CFLAGS += -DDICTIONARY="\"enable1.txt\""
++CFLAGS += -DDICTIONARY="\"${SHAREDIR}/enable1.txt\""
+
+ PREFIX ?= /usr/local
+ BINDIR ?= ${PREFIX}/bin
+@@ -25,15 +25,15 @@ OBJS = anagram.o arc4random_uniform.o dir.o game.o mai
+ strlcat.o
+
+ all: ${OBJS}
+- ${CC} ${LDFLAGS} -o ${PROG} ${OBJS} -lncurses -L/usr/local/lib -lcurl
++ ${CC} ${LDFLAGS} -o ${PROG} ${OBJS} -lncurses -L${LOCALBASE}/lib -lcurl
+
+ install:
+- /usr/bin/install -d -m 755 ${BINDIR}
+- /usr/bin/install -d -m 755 ${MANDIR}
+- /usr/bin/install -d -m 755 ${SHAREDIR}
+- /usr/bin/install -c -s -m 555 freebee ${BINDIR}
+- /usr/bin/install -c -m 444 freebee.6 ${MANDIR}
+- /usr/bin/install -c -m 444 enable1.txt ${SHAREDIR}
++ /usr/bin/install -d -m 755 ${DESTDIR}${BINDIR}
++ /usr/bin/install -d -m 755 ${DESTDIR}${MANDIR}
++ /usr/bin/install -d -m 755 ${DESTDIR}${SHAREDIR}
++ /usr/bin/install -c -s -m 555 freebee ${DESTDIR}${BINDIR}
++ /usr/bin/install -c -m 444 freebee.6 ${DESTDIR}${MANDIR}
++ /usr/bin/install -c -m 444 enable1.txt ${DESTDIR}${SHAREDIR}
+
+ clean:
+ rm -f ${PROG} ${OBJS} ${PROG}.core
diff --git a/games/freebee/pkg-descr b/games/freebee/pkg-descr
new file mode 100644
index 000000000000..556a86bec2d8
--- /dev/null
+++ b/games/freebee/pkg-descr
@@ -0,0 +1,19 @@
+Free Bee is an enhanced Free Software clone of The New York Times
+game Spelling Bee.
+
+In this game, your goal is to find as many words as you can with
+the seven letters you are given. You don't have to use any letter
+except the middle letter and letters can be used more than once in
+a word. Finding a word that uses all seven letters yields bonus
+points! Every game has at least one such word, and many games have
+multiple.
+
+Earning enough points to reach the rank of Queen Bee wins the game!
+
+You can play the daily challenge like the original game or try your
+hand at a nearly infinite number of computer-generated random
+challenges. Unlike the original game, you are not restricted to
+only a single game per day!
+
+WWW: https://freebee.fun/
+WWW: https://github.com/freebee-game/console-client
diff --git a/games/freebee/pkg-plist b/games/freebee/pkg-plist
new file mode 100644
index 000000000000..0e9a24516aa1
--- /dev/null
+++ b/games/freebee/pkg-plist
@@ -0,0 +1,3 @@
+bin/freebee
+man/man6/freebee.6.gz
+%%DATADIR%%/enable1.txt