aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:00:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:00:32 +0000
commit5eebece563f0e17337928a176d4dc0fcd591b3bb (patch)
tree24aeb426b065d21e721b36fb669d03d6972b8076
parent085b284bdae0e4f392624f88309ef73b08fcffbb (diff)
downloadports-5eebece563f0e17337928a176d4dc0fcd591b3bb.tar.gz
ports-5eebece563f0e17337928a176d4dc0fcd591b3bb.zip
devel/py-testscenarios: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-testscenarios/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/py-testscenarios/Makefile b/devel/py-testscenarios/Makefile
index 7a81ee3a85f0..97bfa7167960 100644
--- a/devel/py-testscenarios/Makefile
+++ b/devel/py-testscenarios/Makefile
@@ -1,5 +1,6 @@
PORTNAME= testscenarios
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,12 +14,14 @@ LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/Apache-2.0
LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/BSD
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0:devel/py-pbr@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.11:devel/py-pbr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}testtools>=0:devel/py-testtools@${PY_FLAVOR}
NO_ARCH= yes
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
USES= python