aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-07-20 14:43:45 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-07-20 14:44:45 +0000
commit5f0856f00ae7b2bbc82c9da2e0497705b827079d (patch)
tree8d0e26fe05a88b18f55e80564c00231d3069d4e8
parent5564b3b420db29745d2d4981d1963200ddf53e35 (diff)
downloadports-5f0856f00ae7b2bbc82c9da2e0497705b827079d.tar.gz
ports-5f0856f00ae7b2bbc82c9da2e0497705b827079d.zip
net/libpaho-mqtt3: New port: Eclipse Paho C Client Library for the MQTT Protocol
Eclipse Paho C Client Library for the MQTT Protocol The Paho C client comprises four variant libraries, shared or static: paho-mqtt3a - asynchronous (MQTTAsync) paho-mqtt3as - asynchronous with SSL (MQTTAsync) paho-mqtt3c - "classic" / synchronous (MQTTClient) paho-mqtt3cs - "classic" / synchronous with SSL (MQTTClient) Which Paho C API to use, with some history, for context WWW: https://github.com/eclipse/paho.mqtt.c
-rw-r--r--net/Makefile1
-rw-r--r--net/libpaho-mqtt3/Makefile23
-rw-r--r--net/libpaho-mqtt3/distinfo3
-rw-r--r--net/libpaho-mqtt3/pkg-descr11
-rw-r--r--net/libpaho-mqtt3/pkg-plist53
5 files changed, 91 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d3aecc8c2a11..8ad763b67768 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -391,6 +391,7 @@
SUBDIR += libopennet
SUBDIR += liboping
SUBDIR += libosip2
+ SUBDIR += libpaho-mqtt3
SUBDIR += libpcap
SUBDIR += libpcapnav
SUBDIR += libpfctl
diff --git a/net/libpaho-mqtt3/Makefile b/net/libpaho-mqtt3/Makefile
new file mode 100644
index 000000000000..2a29d344fc13
--- /dev/null
+++ b/net/libpaho-mqtt3/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= libpaho-mqtt3
+PORTVERSION= 1.3.10
+DISTVERSIONPREFIX= v
+CATEGORIES= net devel
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Eclipse Paho C Client Library for the MQTT Protocol
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= eclipse
+GH_PROJECT= paho.mqtt.c
+
+CMAKE_ARGS+= -DPAHO_WITH_SSL=BOOL:TRUE
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/man1/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/libpaho-mqtt3/distinfo b/net/libpaho-mqtt3/distinfo
new file mode 100644
index 000000000000..6726b52e7a27
--- /dev/null
+++ b/net/libpaho-mqtt3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1658302121
+SHA256 (eclipse-paho.mqtt.c-v1.3.10_GH0.tar.gz) = c70db96e66adacae411d5d875fbb08bca6ff9945de3d215b3af93cbd22792db5
+SIZE (eclipse-paho.mqtt.c-v1.3.10_GH0.tar.gz) = 3615593
diff --git a/net/libpaho-mqtt3/pkg-descr b/net/libpaho-mqtt3/pkg-descr
new file mode 100644
index 000000000000..db0a23848b12
--- /dev/null
+++ b/net/libpaho-mqtt3/pkg-descr
@@ -0,0 +1,11 @@
+Eclipse Paho C Client Library for the MQTT Protocol
+
+The Paho C client comprises four variant libraries, shared or static:
+
+paho-mqtt3a - asynchronous (MQTTAsync)
+paho-mqtt3as - asynchronous with SSL (MQTTAsync)
+paho-mqtt3c - "classic" / synchronous (MQTTClient)
+paho-mqtt3cs - "classic" / synchronous with SSL (MQTTClient)
+Which Paho C API to use, with some history, for context
+
+WWW: https://github.com/eclipse/paho.mqtt.c
diff --git a/net/libpaho-mqtt3/pkg-plist b/net/libpaho-mqtt3/pkg-plist
new file mode 100644
index 000000000000..116d0e85401e
--- /dev/null
+++ b/net/libpaho-mqtt3/pkg-plist
@@ -0,0 +1,53 @@
+bin/MQTTAsync_publish
+bin/MQTTAsync_publish_time
+bin/MQTTAsync_subscribe
+bin/MQTTClient_publish
+bin/MQTTClient_publish_async
+bin/MQTTClient_subscribe
+bin/MQTTVersion
+bin/paho_c_pub
+bin/paho_c_sub
+bin/paho_cs_pub
+bin/paho_cs_sub
+include/MQTTAsync.h
+include/MQTTClient.h
+include/MQTTClientPersistence.h
+include/MQTTExportDeclarations.h
+include/MQTTProperties.h
+include/MQTTReasonCodes.h
+include/MQTTSubscribeOpts.h
+lib/cmake/eclipse-paho-mqtt-c/eclipse-paho-mqtt-cConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/eclipse-paho-mqtt-c/eclipse-paho-mqtt-cConfig.cmake
+lib/cmake/eclipse-paho-mqtt-c/eclipse-paho-mqtt-cConfigVersion.cmake
+lib/libpaho-mqtt3a.so
+lib/libpaho-mqtt3a.so.1
+lib/libpaho-mqtt3a.so.1.3.10
+lib/libpaho-mqtt3as.so
+lib/libpaho-mqtt3as.so.1
+lib/libpaho-mqtt3as.so.1.3.10
+lib/libpaho-mqtt3c.so
+lib/libpaho-mqtt3c.so.1
+lib/libpaho-mqtt3c.so.1.3.10
+lib/libpaho-mqtt3cs.so
+lib/libpaho-mqtt3cs.so.1
+lib/libpaho-mqtt3cs.so.1.3.10
+man/man1/paho_c_pub.1.gz
+man/man1/paho_c_sub.1.gz
+man/man1/paho_cs_pub.1.gz
+man/man1/paho_cs_sub.1.gz
+share/doc/Eclipse Paho C/CONTRIBUTING.md
+share/doc/Eclipse Paho C/README.md
+share/doc/Eclipse Paho C/edl-v10
+share/doc/Eclipse Paho C/epl-v20
+share/doc/Eclipse Paho C/notice.html
+share/doc/Eclipse Paho C/samples/MQTTAsync_publish.c
+share/doc/Eclipse Paho C/samples/MQTTAsync_publish_time.c
+share/doc/Eclipse Paho C/samples/MQTTAsync_subscribe.c
+share/doc/Eclipse Paho C/samples/MQTTClient_publish.c
+share/doc/Eclipse Paho C/samples/MQTTClient_publish_async.c
+share/doc/Eclipse Paho C/samples/MQTTClient_subscribe.c
+share/doc/Eclipse Paho C/samples/paho_c_pub.c
+share/doc/Eclipse Paho C/samples/paho_c_sub.c
+share/doc/Eclipse Paho C/samples/paho_cs_pub.c
+share/doc/Eclipse Paho C/samples/paho_cs_sub.c
+share/doc/Eclipse Paho C/samples/pubsub_opts.c