aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:56:06 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:56:06 +0000
commit5f199df4a699f4fdea81bb2b6583e28e2d6c848c (patch)
treed35e0be77edadc18a366315bf1488b085967f0c4
parent1443c051409b8984f3303cc59141572f4fae2349 (diff)
downloadports-5f199df4a699f4fdea81bb2b6583e28e2d6c848c.tar.gz
ports-5f199df4a699f4fdea81bb2b6583e28e2d6c848c.zip
devel/py-stack-data: Add py-stack-data 0.2.0
stack_data is a library that extracts data from stack frames and tracebacks, particularly to display more useful tracebacks than the default. It powers the tracebacks in IPython and futurecoder. WWW: https://github.com/alexmojaki/stack_data
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-stack-data/Makefile30
-rw-r--r--devel/py-stack-data/distinfo3
-rw-r--r--devel/py-stack-data/pkg-descr5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0b5f382e55c8..dfbe04d1830f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5286,6 +5286,7 @@
SUBDIR += py-squint
SUBDIR += py-sre-yield
SUBDIR += py-srsly
+ SUBDIR += py-stack-data
SUBDIR += py-stackexchange
SUBDIR += py-statgrab
SUBDIR += py-statsd
diff --git a/devel/py-stack-data/Makefile b/devel/py-stack-data/Makefile
new file mode 100644
index 000000000000..e7dcc774b747
--- /dev/null
+++ b/devel/py-stack-data/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= stack-data
+PORTVERSION= 0.2.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= stack_data-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extract data from python stack frames and tracebacks for informative displays
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.3:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asttokens>=0:devel/py-asttokens@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}executing>=0:devel/py-executing@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pure-eval>=0:devel/py-pure-eval@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}littleutils>=0:devel/py-littleutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typeguard>=0:devel/py-typeguard@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-stack-data/distinfo b/devel/py-stack-data/distinfo
new file mode 100644
index 000000000000..92f37e243d4b
--- /dev/null
+++ b/devel/py-stack-data/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651316575
+SHA256 (stack_data-0.2.0.tar.gz) = 45692d41bd633a9503a5195552df22b583caf16f0b27c4e58c98d88c8b648e12
+SIZE (stack_data-0.2.0.tar.gz) = 36618
diff --git a/devel/py-stack-data/pkg-descr b/devel/py-stack-data/pkg-descr
new file mode 100644
index 000000000000..8bf3bd11ca7b
--- /dev/null
+++ b/devel/py-stack-data/pkg-descr
@@ -0,0 +1,5 @@
+stack_data is a library that extracts data from stack frames and tracebacks,
+particularly to display more useful tracebacks than the default. It powers the
+tracebacks in IPython and futurecoder.
+
+WWW: https://github.com/alexmojaki/stack_data