aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2021-07-27 13:41:17 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-07-27 13:41:17 +0000
commit602e197ad85743f51781db3729075f997a2d4edf (patch)
treea798990c8376982b68c645e169435b3edbda04ee
parent4aaff74a075a3b186c04c54842c109d94e3e1e61 (diff)
downloadports-602e197ad85743f51781db3729075f997a2d4edf.tar.gz
ports-602e197ad85743f51781db3729075f997a2d4edf.zip
databases/py-pgxnclient: Add missing BUILD_DEPENDS
-rw-r--r--databases/py-pgxnclient/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/py-pgxnclient/Makefile b/databases/py-pgxnclient/Makefile
index 5a31ae937efa..555c32a303af 100644
--- a/databases/py-pgxnclient/Makefile
+++ b/databases/py-pgxnclient/Makefile
@@ -11,6 +11,10 @@ COMMENT= Command line tool to interact with the PostgreSQL Extension Network
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils optsuffix
SHEBANG_FILES= pgxnclient/libexec/pgxn-*