aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-04 02:03:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-04 02:40:27 +0000
commit610c83b9e4f5c92a92210c99985b9d38c5682f2b (patch)
treeef7bef5a2707342cd256497c63152875b0896bd4
parent16f9822faced6d49d01907cd1b92492770c53767 (diff)
downloadports-610c83b9e4f5c92a92210c99985b9d38c5682f2b.tar.gz
ports-610c83b9e4f5c92a92210c99985b9d38c5682f2b.zip
science/cif-tools: New port: Suite of programs to manipulate and examine mmCIF files
-rw-r--r--science/Makefile1
-rw-r--r--science/cif-tools/Makefile21
-rw-r--r--science/cif-tools/distinfo3
-rw-r--r--science/cif-tools/files/patch-src_mmCQL.cpp10
-rw-r--r--science/cif-tools/pkg-descr2
-rw-r--r--science/cif-tools/pkg-plist16
6 files changed, 53 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index e34cd23b5309..97d726fb641f 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -52,6 +52,7 @@
SUBDIR += chemtool-devel
SUBDIR += chimes-calculator
SUBDIR += chrono
+ SUBDIR += cif-tools
SUBDIR += clhep
SUBDIR += clipper
SUBDIR += code_saturne
diff --git a/science/cif-tools/Makefile b/science/cif-tools/Makefile
new file mode 100644
index 000000000000..6f366952ddba
--- /dev/null
+++ b/science/cif-tools/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= cif-tools
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.3
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Suite of programs to manipulate and examine mmCIF files
+WWW= https://github.com/PDB-REDO/cif-tools
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
+ libcifpp.so:science/libcifpp
+
+USES= cmake compiler:c++17-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= PDB-REDO
+
+.include <bsd.port.mk>
diff --git a/science/cif-tools/distinfo b/science/cif-tools/distinfo
new file mode 100644
index 000000000000..875de464c6d7
--- /dev/null
+++ b/science/cif-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664848416
+SHA256 (PDB-REDO-cif-tools-v1.0.3_GH0.tar.gz) = 06cfd420f63821729fc5bccfedec4f240ce88ba1b0d39844aae6fb0c2cdcb340
+SIZE (PDB-REDO-cif-tools-v1.0.3_GH0.tar.gz) = 28264
diff --git a/science/cif-tools/files/patch-src_mmCQL.cpp b/science/cif-tools/files/patch-src_mmCQL.cpp
new file mode 100644
index 000000000000..33087df8b984
--- /dev/null
+++ b/science/cif-tools/files/patch-src_mmCQL.cpp
@@ -0,0 +1,10 @@
+--- src/mmCQL.cpp.orig 2022-10-04 01:58:30 UTC
++++ src/mmCQL.cpp
+@@ -29,6 +29,7 @@
+ #include <fstream>
+ #include <filesystem>
+ #include <functional>
++#include <stack>
+ #include <unordered_set>
+
+ #include <boost/program_options.hpp>
diff --git a/science/cif-tools/pkg-descr b/science/cif-tools/pkg-descr
new file mode 100644
index 000000000000..b9290f3f0d89
--- /dev/null
+++ b/science/cif-tools/pkg-descr
@@ -0,0 +1,2 @@
+The cif-tools suite of programs are tools you can use to examine and manipulate
+mmCIF and PDB files.
diff --git a/science/cif-tools/pkg-plist b/science/cif-tools/pkg-plist
new file mode 100644
index 000000000000..5a17a0019703
--- /dev/null
+++ b/science/cif-tools/pkg-plist
@@ -0,0 +1,16 @@
+bin/cif-diff
+bin/cif-drop
+bin/cif-grep
+bin/cif-merge
+bin/cif-validate
+bin/cif2pdb
+bin/mmCQL
+bin/pdb2cif
+share/man/man1/cif-diff.1.gz
+share/man/man1/cif-drop.1.gz
+share/man/man1/cif-grep.1.gz
+share/man/man1/cif-merge.1.gz
+share/man/man1/cif-validate.1.gz
+share/man/man1/cif2pdb.1.gz
+share/man/man1/mmCQL.1.gz
+share/man/man1/pdb2cif.1.gz