aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-23 08:55:28 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-23 10:49:37 +0000
commit618a8e8a63556a64c4e407db9a744ffd4f1af0eb (patch)
tree8463d05a6cadff030193c8d768e667d56f381725
parent2334fd551268217aeee7046e92874d42cd05004c (diff)
downloadports-618a8e8a63556a64c4e407db9a744ffd4f1af0eb.tar.gz
ports-618a8e8a63556a64c4e407db9a744ffd4f1af0eb.zip
sysutils/ldap-account-manager: Update to 7.9
While here, pet linters PR: 262722 Reported by: basil@vpm.net.ua (maintainer)
-rw-r--r--sysutils/ldap-account-manager/Makefile37
-rw-r--r--sysutils/ldap-account-manager/distinfo6
-rw-r--r--sysutils/ldap-account-manager/pkg-message22
3 files changed, 46 insertions, 19 deletions
diff --git a/sysutils/ldap-account-manager/Makefile b/sysutils/ldap-account-manager/Makefile
index edab32d438ed..d11fb4675c3f 100644
--- a/sysutils/ldap-account-manager/Makefile
+++ b/sysutils/ldap-account-manager/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ldap-account-manager
-PORTVERSION= 7.3
+PORTVERSION= 7.9
CATEGORIES= sysutils www
MASTER_SITES= SF/${SHORTNAME}/LAM/${PORTVERSION}
@@ -9,33 +9,37 @@ COMMENT= Webfrontend for managing accounts stored in an OpenLDAP server
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= p5-Quota>=0:sysutils/p5-Quota \
- p5-perl-ldap>=0:net/p5-perl-ldap
+RUN_DEPENDS= p5-Quota>=0:sysutils/p5-Quota p5-perl-ldap>=0:net/p5-perl-ldap
USES= perl5 php:web tar:bzip2
-USE_PHP= curl gd gettext gmp hash iconv json ldap openssl pcre \
- session simplexml xml xmlreader xmlwriter zip
+USE_PHP= curl gd filter gettext gmp hash iconv json ldap mbstring openssl \
+ pcre session simplexml xml xmlreader xmlwriter zip
-NO_BUILD= yes
+WWWDIR= ${PREFIX}/www/${SHORTNAME}
NO_ARCH= yes
+NO_BUILD= yes
SHORTNAME= lam
-PORTDOCS= docs HISTORY README copyright
-LAMDATA= config graphics help lib locale sess style templates tmp VERSION index.html .htaccess
-WWWDIR= ${PREFIX}/www/${SHORTNAME}
-CONFIGS= config.cfg addressbook.conf samba3.conf unix.conf windows_samba4.conf
+PORTDOCS= docs COPYING HISTORY README copyright
+LAMDATA= config graphics help lib locale sess style templates tmp VERSION index.html pwa_worker.js .htaccess
WRITEABLES= config sess tmp
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE+=DOCS
+OPTIONS_DEFAULT=DOCS
+
+DOCS_DESC= Install documentation and dhcp.schema
+
+.include <bsd.port.options.mk>
do-install:
@${ECHO_CMD} '@preexec if [ -f %D/${WWWDIR_REL}/config/shells ]; then ${RM} %D/${WWWDIR_REL}/config/shells; fi' >> ${TMPPLIST}
-.for CONFIG in ${CONFIGS}
- @${ECHO_CMD} '@sample ${WWWDIR_REL}/config/${CONFIG}.sample' >> ${TMPPLIST}
- @${ECHO_CMD} '@postexec if [ -f %D/${WWWDIR_REL}/config/${CONFIG}_sample ]; then ${RM} %D/${WWWDIR_REL}/config/${CONFIG}_sample; fi' >> ${TMPPLIST}
-.endfor
+ @${ECHO_CMD} '@sample ${WWWDIR_REL}/config/addressbook.sample.conf ${WWWDIR_REL}/config/addressbook.conf' >> ${TMPPLIST}
+ @${ECHO_CMD} '@sample ${WWWDIR_REL}/config/config.cfg.sample ${WWWDIR_REL}/config/config.cfg' >> ${TMPPLIST}
+ @${ECHO_CMD} '@sample ${WWWDIR_REL}/config/samba3.sample.conf ${WWWDIR_REL}/config/samba3.conf' >> ${TMPPLIST}
+ @${ECHO_CMD} '@sample ${WWWDIR_REL}/config/unix.sample.conf ${WWWDIR_REL}/config/lam.conf' >> ${TMPPLIST}
+ @${ECHO_CMD} '@sample ${WWWDIR_REL}/config/windows_samba4.sample.conf ${WWWDIR_REL}/config/windows_samba4.conf' >> ${TMPPLIST}
.for I in ${LAMDATA}
- @${FIND} -s ${WRKSRC}/${I} -type f -not -name '*.sample' | ${SED} -e 's,^${WRKSRC},${WWWDIR_REL},' >> ${TMPPLIST}
+ @${FIND} -s ${WRKSRC}/${I} -type f -not -name 'config.cfg.sample' -not -name '*.sample.conf' | ${SED} -e 's,^${WRKSRC},${WWWDIR_REL},' >> ${TMPPLIST}
@${FIND} -ds ${WRKSRC}/${I} -type d | ${SED} -e 's,^${WRKSRC},@dir ${WWWDIR_REL},' >> ${TMPPLIST}
.endfor
@${ECHO_CMD} '@dir ${WWWDIR_REL}' >> ${TMPPLIST}
@@ -44,6 +48,7 @@ do-install:
@${ECHO_CMD} '@postexec ${CHOWN} -R ${WWWOWN} %D/${WWWDIR_REL}/${DIR}' >> ${TMPPLIST}
@${ECHO_CMD} '@postexec ${CHMOD} -R u+w %D/${WWWDIR_REL}/${DIR}' >> ${TMPPLIST}
.endfor
+ @${SED} -i '' 's|usr/bin/perl|usr/local/bin/perl|g' ${WRKSRC}/lib/lamdaemon.pl
@${ECHO_CMD} '@postexec ${CHOWN} ${WWWOWN} %D/${WWWDIR_REL}/${DIR}/lib/lamdaemon.pl' >> ${TMPPLIST}
@${ECHO_CMD} '@postexec ${CHMOD} u+x %D/${WWWDIR_REL}/${DIR}/lib/lamdaemon.pl' >> ${TMPPLIST}
diff --git a/sysutils/ldap-account-manager/distinfo b/sysutils/ldap-account-manager/distinfo
index 8417fe1eb11b..1cf8232347c3 100644
--- a/sysutils/ldap-account-manager/distinfo
+++ b/sysutils/ldap-account-manager/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1601512583
-SHA256 (ldap-account-manager-7.3.tar.bz2) = db6b9f5f1eeaa1915c562efdaee26c8fb1b0bf206d52dcce24fda428d290f4c4
-SIZE (ldap-account-manager-7.3.tar.bz2) = 22181406
+TIMESTAMP = 1647931232
+SHA256 (ldap-account-manager-7.9.tar.bz2) = 1bb368a788ca54df5bf5f8cf0c33c30a204811d621410c5b0ef98372f89bdb2f
+SIZE (ldap-account-manager-7.9.tar.bz2) = 27264502
diff --git a/sysutils/ldap-account-manager/pkg-message b/sysutils/ldap-account-manager/pkg-message
new file mode 100644
index 000000000000..72daeaa0e4f1
--- /dev/null
+++ b/sysutils/ldap-account-manager/pkg-message
@@ -0,0 +1,22 @@
+[
+{ type: install
+ message: <<EOM
+
+******************************************************************************
+
+You should add the following to your Apache configuration file:
+
+Alias /lam /usr/local/www/lam
+
+<Directory /usr/local/www/lam>
+ Options +FollowSymLinks
+ AllowOverride All
+ Require all granted
+ DirectoryIndex index.html
+</Directory>
+
+******************************************************************************
+
+EOM
+}
+]