aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-14 04:35:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-14 04:36:12 +0000
commit61dc3caeec62b43e14aedb7c32148b45830a8d26 (patch)
tree44414167678e06382d69120610a01b0eebe225f2
parentd6c9352b1e69c33ba0f4053fbd889f95b5e904bd (diff)
downloadports-61dc3caeec62b43e14aedb7c32148b45830a8d26.tar.gz
ports-61dc3caeec62b43e14aedb7c32148b45830a8d26.zip
databases/arrow: Update 4.0.1 -> 6.0.1
-rw-r--r--databases/arrow/Makefile15
-rw-r--r--databases/arrow/distinfo6
-rw-r--r--databases/arrow/files/patch-CMakeLists.txt12
-rw-r--r--databases/arrow/files/patch-cmake__modules_SetupCxxFlags.cmake4
-rw-r--r--databases/arrow/pkg-plist69
5 files changed, 70 insertions, 36 deletions
diff --git a/databases/arrow/Makefile b/databases/arrow/Makefile
index f01367bb29f7..d50f3b898cad 100644
--- a/databases/arrow/Makefile
+++ b/databases/arrow/Makefile
@@ -1,6 +1,5 @@
PORTNAME= arrow
-DISTVERSION= 4.0.1
-PORTREVISION= 4
+DISTVERSION= 6.0.1
CATEGORIES= databases
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${DISTVERSION} \
https://github.com/apache/orc/archive/rel/:orc
@@ -87,7 +86,8 @@ GANDIVA_CMAKE_BOOL= ARROW_GANDIVA
GANDIVA_BUILD_DEPENDS= ${LOCALBASE}/bin/clang12:devel/llvm12 # explicitly requires llvm-12
GANDIVA_LIB_DEPENDS= libgrpc.so:devel/grpc \
libprotobuf.so:devel/protobuf \
- libre2.so:devel/re2
+ libre2.so:devel/re2 \
+ libutf8proc.so:textproc/utf8proc
HDFS_DESC= Arrow HDFS bridge
HDFS_CMAKE_BOOL= ARROW_HDFS
@@ -126,7 +126,14 @@ ORC_BROKEN= fatal error: 'orc/OrcFile.hh' file not found: https://issues.apach
PLASMA_DESC= Plasma object store
PLASMA_CMAKE_BOOL= ARROW_PLASMA
-PLASMA_LIB_DEPENDS= libgflags.so:devel/gflags
+PLASMA_LIB_DEPENDS= libaws-c-auth.so:security/aws-c-auth \
+ libaws-c-compression.so:devel/aws-c-compression \
+ libaws-c-http.so:devel/aws-c-http \
+ libaws-c-mqtt.so:devel/aws-c-mqtt \
+ libaws-c-s3.so:devel/aws-c-s3 \
+ libaws-c-sdkutils.so:devel/aws-c-sdkutils \
+ libaws-crt-cpp.so:devel/aws-crt-cpp \
+ libgflags.so:devel/gflags
BUILD_UTILITIES_DESC= build Arrow commandline utilities
BUILD_UTILITIES_CMAKE_BOOL= ARROW_BUILD_UTILITIES
diff --git a/databases/arrow/distinfo b/databases/arrow/distinfo
index 00a29f73d3b4..0dc7e84a589f 100644
--- a/databases/arrow/distinfo
+++ b/databases/arrow/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1622656236
-SHA256 (apache-arrow-4.0.1.tar.gz) = 75ccbfa276b925c6b1c978a920ff2f30c4b0d3fdf8b51777915b6f69a211896e
-SIZE (apache-arrow-4.0.1.tar.gz) = 9048515
+TIMESTAMP = 1639427996
+SHA256 (apache-arrow-6.0.1.tar.gz) = 3786b3d2df954d078b3e68f98d2e5aecbaa3fa2accf075d7a3a13c187b9c5294
+SIZE (apache-arrow-6.0.1.tar.gz) = 9183616
SHA256 (release-1.6.6.tar.gz) = 9a92b3eaad1d8b88a18cee41058feb34eb43d919df363e0b74a0b857724e4ba0
SIZE (release-1.6.6.tar.gz) = 13939853
diff --git a/databases/arrow/files/patch-CMakeLists.txt b/databases/arrow/files/patch-CMakeLists.txt
index a5913686ab35..42e63905630f 100644
--- a/databases/arrow/files/patch-CMakeLists.txt
+++ b/databases/arrow/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2021-04-21 16:14:36 UTC
+--- CMakeLists.txt.orig 2021-11-10 02:07:56 UTC
+++ CMakeLists.txt
-@@ -98,7 +98,7 @@ set(ARROW_BINARY_DIR ${PROJECT_BINARY_DIR})
+@@ -100,7 +100,7 @@ set(ARROW_BINARY_DIR ${PROJECT_BINARY_DIR})
include(CMakePackageConfigHelpers)
include(CMakeParseArguments)
@@ -9,18 +9,16 @@
include(FindPackageHandleStandardArgs)
include(GNUInstallDirs)
-@@ -910,10 +910,10 @@ if(ARROW_BUILD_EXAMPLES)
+@@ -943,9 +943,9 @@ if(ARROW_BUILD_EXAMPLES)
add_subdirectory(examples/arrow)
endif()
-install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/../LICENSE.txt
- ${CMAKE_CURRENT_SOURCE_DIR}/../NOTICE.txt
-- ${CMAKE_CURRENT_SOURCE_DIR}/README.md
-- DESTINATION "${ARROW_DOC_DIR}")
+- ${CMAKE_CURRENT_SOURCE_DIR}/README.md DESTINATION "${ARROW_DOC_DIR}")
+#install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/../LICENSE.txt
+# ${CMAKE_CURRENT_SOURCE_DIR}/../NOTICE.txt
-+# ${CMAKE_CURRENT_SOURCE_DIR}/README.md
-+# DESTINATION "${ARROW_DOC_DIR}")
++# ${CMAKE_CURRENT_SOURCE_DIR}/README.md DESTINATION "${ARROW_DOC_DIR}")
#
# Validate and print out Arrow configuration options
diff --git a/databases/arrow/files/patch-cmake__modules_SetupCxxFlags.cmake b/databases/arrow/files/patch-cmake__modules_SetupCxxFlags.cmake
index 7c5034184e6e..224c1ecbf360 100644
--- a/databases/arrow/files/patch-cmake__modules_SetupCxxFlags.cmake
+++ b/databases/arrow/files/patch-cmake__modules_SetupCxxFlags.cmake
@@ -1,10 +1,10 @@
---- cmake_modules/SetupCxxFlags.cmake.orig 2021-04-21 16:14:36 UTC
+--- cmake_modules/SetupCxxFlags.cmake.orig 2021-11-10 02:07:56 UTC
+++ cmake_modules/SetupCxxFlags.cmake
@@ -28,7 +28,7 @@ if(NOT DEFINED ARROW_CPU_FLAG)
set(ARROW_CPU_FLAG "armv8")
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "armv7")
set(ARROW_CPU_FLAG "armv7")
-- elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "ppc")
+- elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "powerpc|ppc")
+ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "powerpc|powerpc64|ppc")
set(ARROW_CPU_FLAG "ppc")
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "s390x")
diff --git a/databases/arrow/pkg-plist b/databases/arrow/pkg-plist
index b0211c34cd21..1191c02bd8e0 100644
--- a/databases/arrow/pkg-plist
+++ b/databases/arrow/pkg-plist
@@ -35,6 +35,20 @@ include/arrow/compare.h
%%COMPUTE%%include/arrow/compute/api_vector.h
%%COMPUTE%%include/arrow/compute/cast.h
%%COMPUTE%%include/arrow/compute/exec.h
+%%COMPUTE%%include/arrow/compute/exec/exec_plan.h
+%%COMPUTE%%include/arrow/compute/exec/expression.h
+%%COMPUTE%%include/arrow/compute/exec/hash_join.h
+%%COMPUTE%%include/arrow/compute/exec/hash_join_dict.h
+%%COMPUTE%%include/arrow/compute/exec/key_compare.h
+%%COMPUTE%%include/arrow/compute/exec/key_encode.h
+%%COMPUTE%%include/arrow/compute/exec/key_hash.h
+%%COMPUTE%%include/arrow/compute/exec/key_map.h
+%%COMPUTE%%include/arrow/compute/exec/options.h
+%%COMPUTE%%include/arrow/compute/exec/order_by_impl.h
+%%COMPUTE%%include/arrow/compute/exec/schema_util.h
+%%COMPUTE%%include/arrow/compute/exec/task_util.h
+%%COMPUTE%%include/arrow/compute/exec/test_util.h
+%%COMPUTE%%include/arrow/compute/exec/util.h
%%COMPUTE%%include/arrow/compute/function.h
%%COMPUTE%%include/arrow/compute/kernel.h
%%COMPUTE%%include/arrow/compute/registry.h
@@ -45,6 +59,7 @@ include/arrow/config.h
%%CSV%%include/arrow/csv/column_builder.h
%%CSV%%include/arrow/csv/column_decoder.h
%%CSV%%include/arrow/csv/converter.h
+%%CSV%%include/arrow/csv/invalid_row.h
%%CSV%%include/arrow/csv/options.h
%%CSV%%include/arrow/csv/parser.h
%%CSV%%include/arrow/csv/reader.h
@@ -53,14 +68,16 @@ include/arrow/config.h
%%CSV%%include/arrow/csv/writer.h
%%DATASET%%include/arrow/dataset/api.h
%%DATASET%%include/arrow/dataset/dataset.h
+%%DATASET%%include/arrow/dataset/dataset_writer.h
%%DATASET%%include/arrow/dataset/discovery.h
-%%DATASET%%include/arrow/dataset/expression.h
%%DATASET%%include/arrow/dataset/file_base.h
%%DATASET%%include/arrow/dataset/file_csv.h
%%DATASET%%include/arrow/dataset/file_ipc.h
+%%DATASET%%include/arrow/dataset/file_orc.h
%%DATASET%%include/arrow/dataset/file_parquet.h
%%DATASET%%include/arrow/dataset/partition.h
%%DATASET%%include/arrow/dataset/pch.h
+%%DATASET%%include/arrow/dataset/plan.h
%%DATASET%%include/arrow/dataset/projector.h
%%DATASET%%include/arrow/dataset/scanner.h
%%DATASET%%include/arrow/dataset/test_util.h
@@ -71,6 +88,7 @@ include/arrow/device.h
include/arrow/extension_type.h
%%FILESYSTEM%%include/arrow/filesystem/api.h
%%FILESYSTEM%%include/arrow/filesystem/filesystem.h
+%%FILESYSTEM%%include/arrow/filesystem/gcsfs.h
%%FILESYSTEM%%include/arrow/filesystem/hdfs.h
%%FILESYSTEM%%include/arrow/filesystem/localfs.h
%%FILESYSTEM%%include/arrow/filesystem/mockfs.h
@@ -105,6 +123,7 @@ include/arrow/io/interfaces.h
include/arrow/io/memory.h
include/arrow/io/mman.h
include/arrow/io/slow.h
+include/arrow/io/stdio.h
include/arrow/io/test_common.h
include/arrow/io/transform.h
include/arrow/io/type_fwd.h
@@ -175,6 +194,8 @@ include/arrow/table.h
include/arrow/table_builder.h
include/arrow/tensor.h
include/arrow/tensor/converter.h
+include/arrow/testing/async_test_util.h
+include/arrow/testing/executor_util.h
include/arrow/testing/extension_type.h
include/arrow/testing/future_util.h
include/arrow/testing/generator.h
@@ -182,9 +203,10 @@ include/arrow/testing/gtest_common.h
include/arrow/testing/gtest_compat.h
include/arrow/testing/gtest_util.h
include/arrow/testing/json_integration.h
-include/arrow/testing/macros.h
+include/arrow/testing/matchers.h
include/arrow/testing/pch.h
include/arrow/testing/random.h
+include/arrow/testing/uniform_real.h
include/arrow/testing/util.h
include/arrow/testing/visibility.h
include/arrow/type.h
@@ -192,7 +214,9 @@ include/arrow/type_fwd.h
include/arrow/type_traits.h
include/arrow/util/algorithm.h
include/arrow/util/align_util.h
+include/arrow/util/aligned_storage.h
include/arrow/util/async_generator.h
+include/arrow/util/async_util.h
include/arrow/util/atomic_shared_ptr.h
include/arrow/util/base64.h
include/arrow/util/basic_decimal.h
@@ -210,10 +234,9 @@ include/arrow/util/bitmap_visit.h
include/arrow/util/bitmap_writer.h
include/arrow/util/bitset_stack.h
include/arrow/util/bpacking.h
+include/arrow/util/bpacking64_default.h
include/arrow/util/bpacking_avx2.h
-include/arrow/util/bpacking_avx2_generated.h
include/arrow/util/bpacking_avx512.h
-include/arrow/util/bpacking_avx512_generated.h
include/arrow/util/bpacking_default.h
include/arrow/util/bpacking_neon.h
include/arrow/util/bpacking_simd128_generated.h
@@ -223,11 +246,11 @@ include/arrow/util/byte_stream_split.h
include/arrow/util/cancel.h
include/arrow/util/checked_cast.h
include/arrow/util/compare.h
-include/arrow/util/compiler_util.h
include/arrow/util/compression.h
include/arrow/util/concurrent_map.h
include/arrow/util/config.h
include/arrow/util/converter.h
+include/arrow/util/counting_semaphore.h
include/arrow/util/cpu_info.h
include/arrow/util/decimal.h
include/arrow/util/delimiting.h
@@ -244,19 +267,23 @@ include/arrow/util/int_util.h
include/arrow/util/io_util.h
include/arrow/util/iterator.h
include/arrow/util/key_value_metadata.h
+include/arrow/util/launder.h
include/arrow/util/logging.h
include/arrow/util/macros.h
include/arrow/util/make_unique.h
include/arrow/util/map.h
+include/arrow/util/math_constants.h
include/arrow/util/memory.h
include/arrow/util/mutex.h
include/arrow/util/optional.h
include/arrow/util/parallel.h
+include/arrow/util/pcg_random.h
include/arrow/util/print.h
include/arrow/util/queue.h
include/arrow/util/range.h
include/arrow/util/rle_encoding.h
include/arrow/util/simd.h
+include/arrow/util/small_vector.h
include/arrow/util/sort.h
include/arrow/util/spaced.h
include/arrow/util/stopwatch.h
@@ -272,6 +299,7 @@ include/arrow/util/trie.h
include/arrow/util/type_fwd.h
include/arrow/util/type_traits.h
include/arrow/util/ubsan.h
+include/arrow/util/unreachable.h
include/arrow/util/uri.h
include/arrow/util/utf8.h
include/arrow/util/value_parsing.h
@@ -345,6 +373,7 @@ include/arrow/visitor_inline.h
%%GANDIVA%%include/gandiva/function_signature.h
%%GANDIVA%%include/gandiva/gandiva_aliases.h
%%GANDIVA%%include/gandiva/gdv_function_stubs.h
+%%GANDIVA%%include/gandiva/greedy_dual_size_cache.h
%%GANDIVA%%include/gandiva/hash_utils.h
%%GANDIVA%%include/gandiva/in_holder.h
%%GANDIVA%%include/gandiva/like_holder.h
@@ -353,7 +382,6 @@ include/arrow/visitor_inline.h
%%GANDIVA%%include/gandiva/llvm_includes.h
%%GANDIVA%%include/gandiva/llvm_types.h
%%GANDIVA%%include/gandiva/local_bitmaps_holder.h
-%%GANDIVA%%include/gandiva/lru_cache.h
%%GANDIVA%%include/gandiva/lvalue.h
%%GANDIVA%%include/gandiva/native_function.h
%%GANDIVA%%include/gandiva/node.h
@@ -362,6 +390,7 @@ include/arrow/visitor_inline.h
%%GANDIVA%%include/gandiva/projector.h
%%GANDIVA%%include/gandiva/random_generator_holder.h
%%GANDIVA%%include/gandiva/regex_util.h
+%%GANDIVA%%include/gandiva/replace_holder.h
%%GANDIVA%%include/gandiva/selection_vector.h
%%GANDIVA%%include/gandiva/selection_vector_impl.h
%%GANDIVA%%include/gandiva/simple_arena.h
@@ -483,14 +512,14 @@ lib/cmake/arrow/FindArrow.cmake
%%PLASMA%%lib/cmake/arrow/PlasmaTargets.cmake
lib/cmake/arrow/arrow-config.cmake
lib/libarrow.so
-lib/libarrow.so.400
-lib/libarrow.so.400.1.0
+lib/libarrow.so.600
+lib/libarrow.so.600.1.0
%%DATASET%%lib/libarrow_dataset.so
-%%DATASET%%lib/libarrow_dataset.so.400
-%%DATASET%%lib/libarrow_dataset.so.400.1.0
+%%DATASET%%lib/libarrow_dataset.so.600
+%%DATASET%%lib/libarrow_dataset.so.600.1.0
%%FLIGHT%%lib/libarrow_flight.so
-%%FLIGHT%%lib/libarrow_flight.so.400
-%%FLIGHT%%lib/libarrow_flight.so.400.1.0
+%%FLIGHT%%lib/libarrow_flight.so.600
+%%FLIGHT%%lib/libarrow_flight.so.600.1.0
%%PYTHON%%lib/libarrow_python%%PYTHON_SUFFIX%%.so
%%PYTHON%%lib/libarrow_python%%PYTHON_SUFFIX%%.so.400
%%PYTHON%%lib/libarrow_python%%PYTHON_SUFFIX%%.so.400.1.0
@@ -498,17 +527,17 @@ lib/libarrow.so.400.1.0
%%PYTHONFLIGHT%%lib/libarrow_python%%PYTHON_SUFFIX%%_flight.so.400
%%PYTHONFLIGHT%%lib/libarrow_python%%PYTHON_SUFFIX%%_flight.so.400.1.0
%%TESTING%%lib/libarrow_testing.so
-%%TESTING%%lib/libarrow_testing.so.400
-%%TESTING%%lib/libarrow_testing.so.400.1.0
+%%TESTING%%lib/libarrow_testing.so.600
+%%TESTING%%lib/libarrow_testing.so.600.1.0
%%GANDIVA%%lib/libgandiva.so
-%%GANDIVA%%lib/libgandiva.so.400
-%%GANDIVA%%lib/libgandiva.so.400.1.0
+%%GANDIVA%%lib/libgandiva.so.600
+%%GANDIVA%%lib/libgandiva.so.600.1.0
%%PARQUET%%lib/libparquet.so
-%%PARQUET%%lib/libparquet.so.400
-%%PARQUET%%lib/libparquet.so.400.1.0
+%%PARQUET%%lib/libparquet.so.600
+%%PARQUET%%lib/libparquet.so.600.1.0
%%PLASMA%%lib/libplasma.so
-%%PLASMA%%lib/libplasma.so.400
-%%PLASMA%%lib/libplasma.so.400.1.0
+%%PLASMA%%lib/libplasma.so.600
+%%PLASMA%%lib/libplasma.so.600.1.0
%%COMPUTE%%libdata/pkgconfig/arrow-compute.pc
%%CSV%%libdata/pkgconfig/arrow-csv.pc
%%DATASET%%libdata/pkgconfig/arrow-dataset.pc