aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:11:20 +0000
commit62045188694fb84c5d59009ed2be1f5203654adb (patch)
treec5450f9f7db233e6fda8576292e1bfaa3082e451
parent5088c7b2d177b08823a3fc9c024d3cd5c168b19e (diff)
downloadports-62045188694fb84c5d59009ed2be1f5203654adb.tar.gz
ports-62045188694fb84c5d59009ed2be1f5203654adb.zip
mail/dot-forward: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--mail/dot-forward/Makefile2
-rw-r--r--mail/dot-forward/files/patch-error.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/dot-forward/Makefile b/mail/dot-forward/Makefile
index cd696998476d..625502151402 100644
--- a/mail/dot-forward/Makefile
+++ b/mail/dot-forward/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dot-forward
PORTVERSION= 0.71
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://cr.yp.to/software/
diff --git a/mail/dot-forward/files/patch-error.h b/mail/dot-forward/files/patch-error.h
new file mode 100644
index 000000000000..e35ddb04802a
--- /dev/null
+++ b/mail/dot-forward/files/patch-error.h
@@ -0,0 +1,11 @@
+--- error.h.orig
++++ error.h
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;