aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-10-29 14:08:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-10-30 18:03:42 +0000
commit6234178b4288a78ac81158d235b5187dd0ae5801 (patch)
treeb020fa1459eb3713ef895ece6dbe29373a78ab64
parentfbe59a5cf195f160098f71ca1228a805b0ade931 (diff)
downloadports-6234178b4288a78ac81158d235b5187dd0ae5801.tar.gz
ports-6234178b4288a78ac81158d235b5187dd0ae5801.zip
x11-toolkits/como: unbreak build with clang 19
In file included from examples/minico/main.cpp:7: In file included from como/base/wayland/platform.h:15: como/render/wayland/platform.h:255:19: error: no member named 'addRepaintFull' in 'platform<Base>'; did you mean 'addRepaint'? 255 | this->addRepaintFull(); | ^~~~~~~~~~~~~~ | addRepaint como/render/wayland/platform.h:220:10: note: 'addRepaint' declared here 220 | void addRepaint(QRegion const& region) | ^ Reported by: pkg-fallout
-rw-r--r--x11-toolkits/como/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/x11-toolkits/como/Makefile b/x11-toolkits/como/Makefile
index 783a40fa7ad6..627dff44c54d 100644
--- a/x11-toolkits/como/Makefile
+++ b/x11-toolkits/como/Makefile
@@ -38,6 +38,7 @@ USE_QT= base declarative tools
USE_XORG= x11 xcb
GH_ACCOUNT= winft
SHEBANG_FILES= plugins/effects/*.py
+CMAKE_OFF= BUILD_EXAMPLES # https://github.com/winft/como/issues/29
PLIST_SUB= VERSION=${PORTVERSION}
LDFLAGS+= -Wl,--as-needed # fontconfig/freetype, GL, ICE/SM/Xext/Xi, pixman