aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-07-05 19:34:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-07-05 19:35:37 +0000
commit62afe15364d1a9321f67c81814c9b91935e40cb4 (patch)
treefef5ceb02bc2883515ea455e9a7412694328117b
parent61e5d47281e225aeed7eb84b85932dd293df8615 (diff)
downloadports-62afe15364d1a9321f67c81814c9b91935e40cb4.tar.gz
ports-62afe15364d1a9321f67c81814c9b91935e40cb4.zip
math/oink: New port: Modern parity game solvers written in C++
-rw-r--r--math/Makefile1
-rw-r--r--math/oink/Makefile26
-rw-r--r--math/oink/distinfo7
-rw-r--r--math/oink/pkg-descr5
-rw-r--r--math/oink/pkg-plist11
5 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 15715b11a4a8..0832b443b323 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -559,6 +559,7 @@
SUBDIR += octave-forge-zeromq
SUBDIR += octomap
SUBDIR += ogdf
+ SUBDIR += oink
SUBDIR += oleo
SUBDIR += onednn
SUBDIR += openblas
diff --git a/math/oink/Makefile b/math/oink/Makefile
new file mode 100644
index 000000000000..0acc7592419d
--- /dev/null
+++ b/math/oink/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= oink
+DISTVERSION= g20210704
+CATEGORIES= math
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+PATCHFILES= cd8c62bc1900ffee6d933fa31cbdd954560c286b.patch:-p1 # Fix build on FreeBSD
+PATCHFILES+= a5c10784a472c42bab5a4df0ef29799011bc30b1.patch:-p1 # Fix installed cmake file path
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Modern parity game solvers written in C++
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs
+
+USES= cmake:testing
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= trolando
+GH_TAGNAME= c1259fe
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>
diff --git a/math/oink/distinfo b/math/oink/distinfo
new file mode 100644
index 000000000000..00defc2aa940
--- /dev/null
+++ b/math/oink/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1625512740
+SHA256 (trolando-oink-g20210704-c1259fe_GH0.tar.gz) = 46f6b06f905ea94efadf2adce3923ed7df2775f9101e505eebe787b7b94e5549
+SIZE (trolando-oink-g20210704-c1259fe_GH0.tar.gz) = 178173
+SHA256 (cd8c62bc1900ffee6d933fa31cbdd954560c286b.patch) = eb88af6421600c8538f229369412289a46a87be3a6c4419642d02b4841453325
+SIZE (cd8c62bc1900ffee6d933fa31cbdd954560c286b.patch) = 764
+SHA256 (a5c10784a472c42bab5a4df0ef29799011bc30b1.patch) = 4b103ff0fe318e97ea370ce1c82b91ddbb998f5266d340306138b9a41487bea8
+SIZE (a5c10784a472c42bab5a4df0ef29799011bc30b1.patch) = 796
diff --git a/math/oink/pkg-descr b/math/oink/pkg-descr
new file mode 100644
index 000000000000..f38fea9e8c48
--- /dev/null
+++ b/math/oink/pkg-descr
@@ -0,0 +1,5 @@
+Oink is an modern implementation of parity game solvers written in C++. Oink
+aims to provide high-performance implementations of state-of-the-art algorithms
+representing different approaches to solving parity games.
+
+WWW: https://github.com/trolando/oink
diff --git a/math/oink/pkg-plist b/math/oink/pkg-plist
new file mode 100644
index 000000000000..8e85ca69aca5
--- /dev/null
+++ b/math/oink/pkg-plist
@@ -0,0 +1,11 @@
+bin/oink
+include/oink/bitset.hpp
+include/oink/error.hpp
+include/oink/game.hpp
+include/oink/oink.hpp
+include/oink/uintqueue.hpp
+lib/liboink.so
+lib/liboink.so.1
+lib/liboink.so.1.0.0
+lib/oink/cmake/OinkConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/oink/cmake/OinkConfig.cmake