aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-02-19 14:24:33 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-02-24 09:55:40 +0000
commit62bf703a41550ae4000a4d1258912309586a0a52 (patch)
treee3537c8694963dbe4ad366e2b73f2ffd2387bb91
parent2bedf96bada46ab7fa87581da4db47210b2a9eec (diff)
downloadports-62bf703a41550ae4000a4d1258912309586a0a52.tar.gz
ports-62bf703a41550ae4000a4d1258912309586a0a52.zip
math/wxmaxima: Make WxMaxima find its own documentation
Fix the resources directory, so that WxMaxima actually finds its own documentation (if installed).
-rw-r--r--math/wxmaxima/Makefile1
-rw-r--r--math/wxmaxima/files/patch-src_Dirstructure.cpp10
2 files changed, 11 insertions, 0 deletions
diff --git a/math/wxmaxima/Makefile b/math/wxmaxima/Makefile
index 24bc48de0693..3d7f3789f745 100644
--- a/math/wxmaxima/Makefile
+++ b/math/wxmaxima/Makefile
@@ -1,6 +1,7 @@
PORTNAME= wxmaxima
PORTVERSION= 23.02.0
DISTVERSIONPREFIX= Version-
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= salvadore@FreeBSD.org
diff --git a/math/wxmaxima/files/patch-src_Dirstructure.cpp b/math/wxmaxima/files/patch-src_Dirstructure.cpp
new file mode 100644
index 000000000000..42ab59c742be
--- /dev/null
+++ b/math/wxmaxima/files/patch-src_Dirstructure.cpp
@@ -0,0 +1,10 @@
+--- src/Dirstructure.cpp.orig 2023-02-19 14:20:34 UTC
++++ src/Dirstructure.cpp
+@@ -120,6 +120,7 @@ wxString Dirstructure::ResourcesDir() const {
+ exepath = exe.GetPath();
+ } else {
+ exepath = CMAKE_INSTALL_PREFIX;
++ exepath.Append("/share");
+ }
+ return exepath;
+ }