aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex S <iwtcex@gmail.com>2021-12-11 19:25:53 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-12-11 19:25:53 +0000
commit6344ed87cd08032ea97adf3982fea383e7f73436 (patch)
tree83877c1eb806a050d2c3b113e57757ede24cd004
parentc6d5ecc37e7f4fe8e9e8089aebb9f981ae0ca2ae (diff)
emulators/wine-devel: Use the right libgcc_s for 32-bit on amd64
Forward port 316c372c7d133c416ced0bd6b1f21fdd011117eb from the main wine port: In our situation, where we leverage 32-bit, i386 executables of Wine in an amd64 world running 64-bit executables of Wine, the rpath of $PREFIX/lib/gcc10 which Mk/bsd.gcc.mk sets for the former makes the dynamic linker attempt to load a 64-bit version of libgcc_s.so which happens to be at that location on amd64. Removing this rpath setting at compilation time would be comparatively more involved, so leverage LD_32_LIBMAP which we are already using in wine-wow64.sh to point to the system version of libgcc_s.so. This works since for C code both flavors of libgcc_s.so are fully compatible and Wine's C++ dependencies Wine (like openal-soft and various Mesa userspace graphics drivers) are actually compiled with clang. In other words we are only reverting to the version of the library they would normally load without rpath interference. Bump PORTREVISION so new packages with the tweaked script will be generated. PR: 259926 Reported by: nc Tested by: nc
-rw-r--r--emulators/wine-devel/Makefile1
-rw-r--r--emulators/wine-devel/files/wine-wow64.sh1
2 files changed, 2 insertions, 0 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 2d1b3a6f103b..57ebc56d8530 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= wine
DISTVERSION= 6.23
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
diff --git a/emulators/wine-devel/files/wine-wow64.sh b/emulators/wine-devel/files/wine-wow64.sh
index 3a3ea25bb4c5..d83d10db698e 100644
--- a/emulators/wine-devel/files/wine-wow64.sh
+++ b/emulators/wine-devel/files/wine-wow64.sh
@@ -33,6 +33,7 @@ do
done
export LD_32_LIBRARY_PATH_RPATH=y
export LD_32_LIBMAP="
+libgcc_s.so.1 /usr/lib32/libgcc_s.so.1
$LOCALBASE/lib/libvulkan_intel.so $I386_ROOT/$LOCALBASE/lib/libvulkan_intel.so
$LOCALBASE/lib/libvulkan_radeon.so $I386_ROOT/$LOCALBASE/lib/libvulkan_radeon.so
$LD_32_LIBMAP"