aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-10 01:15:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-10 04:17:30 +0000
commit64b885ada496a6088fa49fd551875e2f374593b4 (patch)
tree085c255bb0d53112819523e4bbe5209e1f1572b9
parent813d404c7d5cc2c5ce488919837e81d7d054e813 (diff)
downloadports-64b885ada496a6088fa49fd551875e2f374593b4.tar.gz
ports-64b885ada496a6088fa49fd551875e2f374593b4.zip
devel/py-xdoctest: New port: Python package for executing tests in documentation strings
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-xdoctest/Makefile27
-rw-r--r--devel/py-xdoctest/distinfo3
-rw-r--r--devel/py-xdoctest/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4e0082e43dd8..4c58f21a3ecb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5461,6 +5461,7 @@
SUBDIR += py-xcaplib
SUBDIR += py-xdg
SUBDIR += py-xdis
+ SUBDIR += py-xdoctest
SUBDIR += py-xerox
SUBDIR += py-xmltodict
SUBDIR += py-xstatic
diff --git a/devel/py-xdoctest/Makefile b/devel/py-xdoctest/Makefile
new file mode 100644
index 000000000000..a085465c30da
--- /dev/null
+++ b/devel/py-xdoctest/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= xdoctest
+DISTVERSION= 1.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP # has no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python package for executing tests in documentation strings
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>=2.0.15:devel/py-codecov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=2.0.15:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.25.1:www/py-requests@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist pytest # some tests fail, see https://github.com/Erotemic/xdoctest/issues/131
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-xdoctest/distinfo b/devel/py-xdoctest/distinfo
new file mode 100644
index 000000000000..86183f374139
--- /dev/null
+++ b/devel/py-xdoctest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660092630
+SHA256 (xdoctest-1.0.1.tar.gz) = 3b90a4b7894dda58c9c8dc673fb61fdceb90fdc838baf1cac475618c8e35975c
+SIZE (xdoctest-1.0.1.tar.gz) = 173949
diff --git a/devel/py-xdoctest/pkg-descr b/devel/py-xdoctest/pkg-descr
new file mode 100644
index 000000000000..b1a860b1e94b
--- /dev/null
+++ b/devel/py-xdoctest/pkg-descr
@@ -0,0 +1,3 @@
+Xdoctest is a Python package for executing tests in documentation strings.
+
+WWW: https://github.com/Erotemic/xdoctest