aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-04 14:18:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-10 17:09:54 +0000
commit64be746e535b0ca620460c95a819b81ac2159d01 (patch)
treebf93063c7e813a154b66b58552466ce27baabfbc
parentade17adf6f1f5671bbbd8cf62f14f38fe88f33f4 (diff)
downloadports-64be746e535b0ca620460c95a819b81ac2159d01.tar.gz
ports-64be746e535b0ca620460c95a819b81ac2159d01.zip
lang/python3[89]: remove LIBFFI option
Python now requires libffi from ports and does not build with LIBFFI disabled, so remove the option. PR: 256141 Reported by: majo-bugs.freebsd.org@cerny.sk Reviewed by: koobs (python) Approved by: koobs (python) MFH: 2020Q2 (bugfix)
-rw-r--r--lang/python38/Makefile19
-rw-r--r--lang/python39/Makefile19
2 files changed, 12 insertions, 26 deletions
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index be973fca11ac..83a6943299b3 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -13,6 +13,8 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
+LIB_DEPENDS= libffi.so:devel/libffi
+
USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
@@ -29,7 +31,8 @@ PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
-CONFIGURE_ARGS+= --enable-shared --without-ensurepip
+CONFIGURE_ARGS+= --enable-shared --without-ensurepip \
+ --with-system-ffi
CONFIGURE_ENV+= OPT="" DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS}" # Null out OPT to respect user CFLAGS and remove optimizations
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
@@ -48,13 +51,12 @@ PLIST_SUB= ABI=${ABIFLAGS} \
XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 LIBFFI LIBMPDEC NLS PYMALLOC
-OPTIONS_DEFAULT= LIBFFI LIBMPDEC PYMALLOC
+OPTIONS_DEFINE= DEBUG IPV6 LIBMPDEC NLS PYMALLOC
+OPTIONS_DEFAULT= LIBMPDEC PYMALLOC
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
OPTIONS_SUB= yes
-LIBFFI_DESC= Use libffi from ports instead of bundled version
LIBMPDEC_DESC= Use libmpdec from ports instead of bundled version
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
@@ -69,9 +71,6 @@ SIPHASH_CONFIGURE_ON= --with-hash-algorithm=siphash24
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
-LIBFFI_CONFIGURE_ON= --with-system-ffi
-LIBFFI_LIB_DEPENDS= libffi.so:devel/libffi
-
LIBMPDEC_CONFIGURE_ON= --with-system-libmpdec
LIBMPDEC_LIB_DEPENDS= libmpdec.so:math/mpdecimal
@@ -99,12 +98,6 @@ PLIST_FILES+= bin/python${PYTHON_VER}${ABIFLAGS} \
libdata/pkgconfig/python-${PYTHON_VER}${ABIFLAGS}-embed.pc
.endif
-# https://bugs.python.org/issue22521
-# https://bugs.python.org/issue23042
-.if ${ARCH} == i386 && !${PORT_OPTIONS:MLIBFFI}
-BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
-.endif
-
.if ${ARCH} == sparc64
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
diff --git a/lang/python39/Makefile b/lang/python39/Makefile
index 8a9b87d3c043..227b7085a135 100644
--- a/lang/python39/Makefile
+++ b/lang/python39/Makefile
@@ -13,6 +13,8 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
+LIB_DEPENDS= libffi.so:devel/libffi
+
USES= compiler:c11 cpe ncurses pathfix pkgconfig readline \
shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
@@ -30,7 +32,8 @@ PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
-CONFIGURE_ARGS+= --enable-shared --without-ensurepip
+CONFIGURE_ARGS+= --enable-shared --without-ensurepip \
+ --with-system-ffi
CONFIGURE_ENV+= OPT="" DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS}" # Null out OPT to respect user CFLAGS and remove optimizations
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
@@ -49,13 +52,12 @@ PLIST_SUB= ABI=${ABIFLAGS} \
XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 LIBFFI LIBMPDEC NLS PYMALLOC
-OPTIONS_DEFAULT= LIBFFI LIBMPDEC PYMALLOC
+OPTIONS_DEFINE= DEBUG IPV6 LIBMPDEC NLS PYMALLOC
+OPTIONS_DEFAULT= LIBMPDEC PYMALLOC
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
OPTIONS_SUB= yes
-LIBFFI_DESC= Use libffi from ports instead of bundled version
LIBMPDEC_DESC= Use libmpdec from ports instead of bundled version
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
@@ -70,9 +72,6 @@ SIPHASH_CONFIGURE_ON= --with-hash-algorithm=siphash24
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
-LIBFFI_CONFIGURE_ON= --with-system-ffi
-LIBFFI_LIB_DEPENDS= libffi.so:devel/libffi
-
LIBMPDEC_CONFIGURE_ON= --with-system-libmpdec
LIBMPDEC_LIB_DEPENDS= libmpdec.so:math/mpdecimal
@@ -100,12 +99,6 @@ PLIST_FILES+= bin/python${PYTHON_VER}${ABIFLAGS} \
libdata/pkgconfig/python-${PYTHON_VER}${ABIFLAGS}-embed.pc
.endif
-# https://bugs.python.org/issue22521
-# https://bugs.python.org/issue23042
-.if ${ARCH} == i386 && !${PORT_OPTIONS:MLIBFFI}
-BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
-.endif
-
.if ${ARCH} == sparc64
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif