aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-19 11:04:10 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-19 11:04:10 +0000
commit65d22e337b24d93b905df48fabce173fec80a430 (patch)
treebecf0feb97c05275732a578efdf9976c7c5d6561
parent93344cda77603560b6ba421778d92be03e70800b (diff)
downloadports-65d22e337b24d93b905df48fabce173fec80a430.tar.gz
ports-65d22e337b24d93b905df48fabce173fec80a430.zip
devel/oclgrind: fix build on riscv64
ld: error: testCCompiler.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
-rw-r--r--devel/oclgrind/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/oclgrind/Makefile b/devel/oclgrind/Makefile
index 26199bdbc7b0..24acd4a1ff1b 100644
--- a/devel/oclgrind/Makefile
+++ b/devel/oclgrind/Makefile
@@ -29,6 +29,7 @@ USE_LDCONFIG= yes
CC= clang${LLVM_VER}
CXX= clang++${LLVM_VER}
CPP= clang-cpp${LLVM_VER}
+CFLAGS_riscv64= -mno-relax
CMAKE_ARGS+= -DLLVM_DIR=${LOCALBASE}/llvm${LLVM_VER}/lib/cmake/llvm/