aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 14:45:34 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-27 11:42:13 +0000
commit660b856c0cd8f29ee3cd4b4e3a338f406e5cf5e4 (patch)
treebd0983a29eb6490fd12c91da46d44fa0c0ed546a
parent8946640b15d8498c0bacdb1139be4347fe080e21 (diff)
downloadports-660b856c0cd8f29ee3cd4b4e3a338f406e5cf5e4.tar.gz
ports-660b856c0cd8f29ee3cd4b4e3a338f406e5cf5e4.zip
misc/py-toil: switch to USES=pytest, add missing TEST_DEPENDS
More test depends are missing and are required to fix the tests, but they do not seem to be available in the Ports Collection yet Reported by: reprise Approved by: portmgr blanket
-rw-r--r--misc/py-toil/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/py-toil/Makefile b/misc/py-toil/Makefile
index f0e4d90a71ae..62fe30999d9f 100644
--- a/misc/py-toil/Makefile
+++ b/misc/py-toil/Makefile
@@ -18,15 +18,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}addict>=2.2.1:devel/py-addict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=2012:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=5:devel/py-yaml@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libcloud>=0.14.0:net/py-libcloud@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.6+ pytest
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
-do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
-
.include <bsd.port.mk>