aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-03-12 11:29:19 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-03-12 11:29:19 +0000
commit66aa1f8a5b9f8d075eb12f4a5cc31979900915de (patch)
treed261166771ab4bb6fd70eaf2df789019130cd143
parent679b008da4b5db599a1c20e4a7ebb7ad4d9b9fb3 (diff)
downloadports-66aa1f8a5b9f8d075eb12f4a5cc31979900915de.tar.gz
ports-66aa1f8a5b9f8d075eb12f4a5cc31979900915de.zip
devel/py-aioapns: New Port
aioapns is a library designed specifically for sending push-notifications to iOS devices via Apple Push Notification Service. aioapns provides an efficient client through asynchronous HTTP2 protocol for use with Python's asyncio framework. WWW: https://github.com/Fatal1ty/aioapns
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-aioapns/Makefile23
-rw-r--r--devel/py-aioapns/distinfo3
-rw-r--r--devel/py-aioapns/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6de751c538fb..4bcf0b1055d7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4137,6 +4137,7 @@
SUBDIR += py-adb
SUBDIR += py-addict
SUBDIR += py-aenum
+ SUBDIR += py-aioapns
SUBDIR += py-aiocontextvars
SUBDIR += py-aiofiles
SUBDIR += py-aioice
diff --git a/devel/py-aioapns/Makefile b/devel/py-aioapns/Makefile
new file mode 100644
index 000000000000..cca7602319bd
--- /dev/null
+++ b/devel/py-aioapns/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= aioapns
+PORTVERSION= 2.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bofh@FreeBSD.org
+
+COMMENT= Efficient APNs Client Library for Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h2>=4.0.0:www/py-h2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=17.5.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=2.0.0:www/py-pyjwt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-aioapns/distinfo b/devel/py-aioapns/distinfo
new file mode 100644
index 000000000000..1ddf57d987ab
--- /dev/null
+++ b/devel/py-aioapns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647083519
+SHA256 (aioapns-2.1.tar.gz) = 2ce526910bc2514a84b8105abe80508526ceafc0097c89f86bbbc501f8666c99
+SIZE (aioapns-2.1.tar.gz) = 13104
diff --git a/devel/py-aioapns/pkg-descr b/devel/py-aioapns/pkg-descr
new file mode 100644
index 000000000000..ab7f8dceffcf
--- /dev/null
+++ b/devel/py-aioapns/pkg-descr
@@ -0,0 +1,6 @@
+aioapns is a library designed specifically for sending
+push-notifications to iOS devices via Apple Push Notification Service.
+aioapns provides an efficient client through asynchronous HTTP2
+protocol for use with Python's asyncio framework.
+
+WWW: https://github.com/Fatal1ty/aioapns