aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:21:26 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:57:52 +0000
commit681db9df6bae3fcf0be032e3be44b0eaadd8a189 (patch)
treee6dcb7daa68ae0917b50c296e32a15f2703d0434
parent5ad6ea91650a0c5c58f33164c9decf75b6581980 (diff)
downloadports-681db9df6bae3fcf0be032e3be44b0eaadd8a189.tar.gz
ports-681db9df6bae3fcf0be032e3be44b0eaadd8a189.zip
converters/xdeview: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--converters/xdeview/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index 5b086633000a..b202f2a2d125 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -14,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libuu.so:converters/uulib
-USES= desthack tk
+USES= desthack localbase:ldflags tk
+
GNU_CONFIGURE= yes
# Explicitly disable Tcl otherwise the configure script picks-up
# crud from the $PATH like /usr/opt/Simili/tcl/.
@@ -23,17 +24,21 @@ ALL_TARGET= xdeview
INSTALL_TARGET= install-tcl
CPPFLAGS+= -I${TCL_INCLUDEDIR} -DHAVE_TCL \
- -I${TK_INCLUDEDIR} -DHAVE_TK \
- -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib \
- -lX11 -ltcl${TCL_VER:S/.//} \
+ -I${TK_INCLUDEDIR} -DHAVE_TK
+LDFLAGS+= -lX11 -ltcl${TCL_VER:S/.//} \
-ltk${TCL_VER:S/.//} -lm
-PORTDOCS= *
PLIST_FILES= bin/uuwish bin/xdeview man/man1/xdeview.1.gz
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/uuwish
${INSTALL_MAN} ${WRKSRC}/man/xdeview.1 ${STAGEDIR}${MANPREFIX}/man/man1