aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-21 09:55:09 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-21 09:55:09 +0000
commit6898985d09ae7214f7d5659f7d7812fdbd05057c (patch)
tree64d440db817a1b7f9e29919e4d991d0c540de9b7
parentfbf2866ff984d006b367f3230174063428fe1a68 (diff)
devel/py-uproot: Add py-uproot 5.3.10
Uproot is a library for reading and writing ROOT files in pure Python and NumPy. Unlike the standard C++ ROOT implementation, Uproot is only an I/O library, primarily intended to stream data into machine learning libraries in Python. Unlike PyROOT and root_numpy, Uproot does not depend on C++ ROOT. Instead, it uses Numpy to cast blocks of data from the ROOT file as Numpy arrays.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-uproot/Makefile34
-rw-r--r--devel/py-uproot/distinfo3
-rw-r--r--devel/py-uproot/pkg-descr6
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b838f028b544..af6dc72fcb6d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5932,6 +5932,7 @@
SUBDIR += py-unpaddedbase64
SUBDIR += py-untokenize
SUBDIR += py-update_checker
+ SUBDIR += py-uproot
SUBDIR += py-urlimport
SUBDIR += py-urwid
SUBDIR += py-urwid-readline
diff --git a/devel/py-uproot/Makefile b/devel/py-uproot/Makefile
new file mode 100644
index 000000000000..8448696d9ce3
--- /dev/null
+++ b/devel/py-uproot/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= uproot
+PORTVERSION= 5.3.10
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= ROOT I/O in pure Python and NumPy
+WWW= https://uproot.readthedocs.io/en/latest/ \
+ https://github.com/scikit-hep/uproot5
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-vcs>=0:devel/py-hatch-vcs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}awkward>=2.4.6:math/py-awkward@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cramjam>=2.5.0:archivers/py-cramjam@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fsspec>=0:devel/py-fsspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.1.0:devel/py-typing-extensions@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-uproot/distinfo b/devel/py-uproot/distinfo
new file mode 100644
index 000000000000..7edb84d7f65b
--- /dev/null
+++ b/devel/py-uproot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1721499004
+SHA256 (uproot-5.3.10.tar.gz) = b2f0cc2ccb7b11dca476bf1e513fa4a4b986eb560207c9b89c7b9610794c4ecb
+SIZE (uproot-5.3.10.tar.gz) = 927664
diff --git a/devel/py-uproot/pkg-descr b/devel/py-uproot/pkg-descr
new file mode 100644
index 000000000000..a3f5487ff9b7
--- /dev/null
+++ b/devel/py-uproot/pkg-descr
@@ -0,0 +1,6 @@
+Uproot is a library for reading and writing ROOT files in pure Python and NumPy.
+
+Unlike the standard C++ ROOT implementation, Uproot is only an I/O library,
+primarily intended to stream data into machine learning libraries in Python.
+Unlike PyROOT and root_numpy, Uproot does not depend on C++ ROOT. Instead, it
+uses Numpy to cast blocks of data from the ROOT file as Numpy arrays.