aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 03:39:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:04 +0000
commit6916df3fc01a63dce046c1c324310b099a6593a6 (patch)
treec06df6ab711eb27415a328e18253c11a7df4a44e
parenta104e33d54e5ee3683089203bb520769af9c33c5 (diff)
security/py-tinyaes: Add py-tinyaes 1.0.3
tinyaes is a few lines Cython wrapper for the tiny-AES-c library, a Small portable AES128/192/256 in C. The library offers a few modes, CTR mode is the only one currently wrapped. Given the C API works modifying a buffer in-place, the wrapper offers: - CTR_xcrypt_buffer(..) that works on all bytes convertible types, and encrypting a copy of the buffer, - CTR_xcrypt_buffer_inplace(..) that works on bytearrays only, modifying the buffer in-place. WWW: https://github.com/naufraghi/tinyaes-py
-rw-r--r--security/Makefile1
-rw-r--r--security/py-tinyaes/Makefile21
-rw-r--r--security/py-tinyaes/distinfo3
-rw-r--r--security/py-tinyaes/pkg-descr11
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b78c14522d4c..02a89b045220 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -977,6 +977,7 @@
SUBDIR += py-stix2
SUBDIR += py-stix2-patterns
SUBDIR += py-taxii2-client
+ SUBDIR += py-tinyaes
SUBDIR += py-tls-parser
SUBDIR += py-tlslite
SUBDIR += py-tlslite-ng
diff --git a/security/py-tinyaes/Makefile b/security/py-tinyaes/Makefile
new file mode 100644
index 000000000000..700008fb46cb
--- /dev/null
+++ b/security/py-tinyaes/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= tinyaes
+PORTVERSION= 1.0.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tiny-AES-c wrapper in Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent cython distutils
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/security/py-tinyaes/distinfo b/security/py-tinyaes/distinfo
new file mode 100644
index 000000000000..3748cd72611b
--- /dev/null
+++ b/security/py-tinyaes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1649423652
+SHA256 (tinyaes-1.0.3.tar.gz) = 4655f32282b13a3241a8087b984909855a99772a9c0d8dfcce740c76e5085ddc
+SIZE (tinyaes-1.0.3.tar.gz) = 42781
diff --git a/security/py-tinyaes/pkg-descr b/security/py-tinyaes/pkg-descr
new file mode 100644
index 000000000000..31e2a3bfd2b0
--- /dev/null
+++ b/security/py-tinyaes/pkg-descr
@@ -0,0 +1,11 @@
+tinyaes is a few lines Cython wrapper for the tiny-AES-c library, a Small
+portable AES128/192/256 in C.
+
+The library offers a few modes, CTR mode is the only one currently wrapped.
+Given the C API works modifying a buffer in-place, the wrapper offers:
+- CTR_xcrypt_buffer(..) that works on all bytes convertible types, and
+ encrypting a copy of the buffer,
+- CTR_xcrypt_buffer_inplace(..) that works on bytearrays only, modifying the
+ buffer in-place.
+
+WWW: https://github.com/naufraghi/tinyaes-py