aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-05-30 08:33:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-05-30 08:34:13 +0000
commit698e021dfe6b872f96b100040d9cdbe5d1c53188 (patch)
tree5a040f1aacdcabae13f5b93990535d06eddf371e
parente18e8104d4044b18f7d4d40046a4f56c3167febf (diff)
downloadports-698e021dfe6b872f96b100040d9cdbe5d1c53188.tar.gz
ports-698e021dfe6b872f96b100040d9cdbe5d1c53188.zip
misc/py-pytorch-lightning: New port: Lightweight PyTorch wrapper for ML researchers
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-pytorch-lightning/Makefile32
-rw-r--r--misc/py-pytorch-lightning/distinfo3
-rw-r--r--misc/py-pytorch-lightning/pkg-descr2
4 files changed, 38 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b95f3a87cd4c..f5e200fe93b0 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -453,6 +453,7 @@
SUBDIR += py-python-geohash
SUBDIR += py-python-utils
SUBDIR += py-pytorch
+ SUBDIR += py-pytorch-lightning
SUBDIR += py-qiskit-machine-learning
SUBDIR += py-scikit-fusion
SUBDIR += py-serverfiles
diff --git a/misc/py-pytorch-lightning/Makefile b/misc/py-pytorch-lightning/Makefile
new file mode 100644
index 000000000000..fb62c5da15c6
--- /dev/null
+++ b/misc/py-pytorch-lightning/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= pytorch-lightning
+DISTVERSION= 2.0.2
+CATEGORIES= misc python # machine-learning
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight PyTorch wrapper for ML researchers
+WWW= https://lightning.ai/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fsspec>=2021.06.0:devel/py-fsspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lightning-utilities>=0.7.0:misc/py-lightning-utilities@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.17.2:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=17.1:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytorch>=1.11.0:misc/py-pytorch@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}torchmetrics>=0.7.0:misc/py-torchmetrics@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.57.0:misc/py-tqdm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.0.0:devel/py-typing-extensions@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.4:devel/py-yaml@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.7+
+USE_PYTHON= pep517 autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-pytorch-lightning/distinfo b/misc/py-pytorch-lightning/distinfo
new file mode 100644
index 000000000000..72cc3a046b8b
--- /dev/null
+++ b/misc/py-pytorch-lightning/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685433955
+SHA256 (pytorch-lightning-2.0.2.tar.gz) = b37a3677a65cda920260de3899ea9dfdd221b0a2d838a0439e31bd927efa61f4
+SIZE (pytorch-lightning-2.0.2.tar.gz) = 538546
diff --git a/misc/py-pytorch-lightning/pkg-descr b/misc/py-pytorch-lightning/pkg-descr
new file mode 100644
index 000000000000..5b270c7841cd
--- /dev/null
+++ b/misc/py-pytorch-lightning/pkg-descr
@@ -0,0 +1,2 @@
+The Deep Learning framework to train, deploy, and ship AI products
+lightning fast.