aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:17:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:17:14 +0000
commit69e7cc657ce8df07352cb73e101410ac9ec5d9aa (patch)
treea576adc9e9f4a1773fa7aee3f85c81bff9f30347
parentb70c43106ac15b1a2059b9f9ad04f5ba79ce54b3 (diff)
www/rubygem-sinatra-contrib: Fix gemspec for rubygem-mustermann 3.0.0 update
- Bump PORTREVISION for package change
-rw-r--r--www/rubygem-sinatra-contrib/Makefile3
-rw-r--r--www/rubygem-sinatra-contrib/files/patch-gemspec11
2 files changed, 13 insertions, 1 deletions
diff --git a/www/rubygem-sinatra-contrib/Makefile b/www/rubygem-sinatra-contrib/Makefile
index 010557bf1f09..035c08af7de4 100644
--- a/www/rubygem-sinatra-contrib/Makefile
+++ b/www/rubygem-sinatra-contrib/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sinatra-contrib
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
@@ -11,7 +12,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-multi_json>=0:devel/rubygem-multi_json \
- rubygem-mustermann>=2.0<3:devel/rubygem-mustermann \
+ rubygem-mustermann>=2.0:devel/rubygem-mustermann \
rubygem-rack-protection>=${PORTVERSION}:www/rubygem-rack-protection \
rubygem-sinatra>=${PORTVERSION}:www/rubygem-sinatra \
rubygem-tilt>=2.0<3:devel/rubygem-tilt
diff --git a/www/rubygem-sinatra-contrib/files/patch-gemspec b/www/rubygem-sinatra-contrib/files/patch-gemspec
new file mode 100644
index 000000000000..7866079929ed
--- /dev/null
+++ b/www/rubygem-sinatra-contrib/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- sinatra-contrib.gemspec.orig 2022-09-11 06:41:41 UTC
++++ sinatra-contrib.gemspec
+@@ -25,7 +25,7 @@ Gem::Specification.new do |s|
+
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<sinatra>.freeze, ["= 2.2.2"])
+- s.add_runtime_dependency(%q<mustermann>.freeze, ["~> 2.0"])
++ s.add_runtime_dependency(%q<mustermann>.freeze, [">= 2.0"])
+ s.add_runtime_dependency(%q<tilt>.freeze, ["~> 2.0"])
+ s.add_runtime_dependency(%q<rack-protection>.freeze, ["= 2.2.2"])
+ s.add_runtime_dependency(%q<multi_json>.freeze, [">= 0"])