aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-07-09 22:05:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-07-09 22:05:57 +0000
commit6a3f6d3bb65d197af5c505a4aaf16b854b46a2a4 (patch)
tree561e40676a150614792a9255ee6ecd2cdb89963a
parentc6fb90638ab878679391de9bea7dd4b9605691a1 (diff)
multimedia/librist: Unbreak on 15
Code uses the c11 feature stdatomic.h while it uses --std=c99.
-rw-r--r--multimedia/librist/Makefile2
-rw-r--r--multimedia/librist/files/patch-meson.build23
2 files changed, 23 insertions, 2 deletions
diff --git a/multimedia/librist/Makefile b/multimedia/librist/Makefile
index 5425742c1340..15e58b2e2339 100644
--- a/multimedia/librist/Makefile
+++ b/multimedia/librist/Makefile
@@ -9,8 +9,6 @@ WWW= https://code.videolan.org/rist/librist
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_15= compilation fails, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=280210
-
LIB_DEPENDS= libcjson.so:devel/libcjson \
libmbedcrypto.so:security/mbedtls \
libmicrohttpd.so:www/libmicrohttpd
diff --git a/multimedia/librist/files/patch-meson.build b/multimedia/librist/files/patch-meson.build
new file mode 100644
index 000000000000..2c4a0ba547cf
--- /dev/null
+++ b/multimedia/librist/files/patch-meson.build
@@ -0,0 +1,23 @@
+- workaround for https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=280210
+- code uses the c11 feature stdatomic.h while it uses --std=c99
+
+--- meson.build.orig 2024-07-09 22:00:05 UTC
++++ meson.build
+@@ -5,7 +5,7 @@ project('libRIST', 'c',
+
+ project('libRIST', 'c',
+ version: '0.2.10',
+- default_options: ['c_std=c99', 'warning_level=3', 'libdir=lib'],
++ default_options: ['c_std=c11', 'warning_level=3', 'libdir=lib'],
+ meson_version: '>= 0.51.0')
+
+ cc = meson.get_compiler('c')
+@@ -374,7 +374,7 @@ if get_option('static_analyze')
+ if get_option('static_analyze')
+ run_target('cppcheck', command : ['cppcheck',
+ '--quiet',
+- '--std=c99',
++ '--std=c11',
+ '--suppressions-list=' + join_paths(meson.source_root(), 'common/configs/cppcheck-suppressions.txt'),
+ '--project=' + join_paths(meson.build_root(),
+ 'compile_commands.json')])