aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-08-01 13:24:04 +0000
committerRene Ladan <rene@FreeBSD.org>2022-08-01 13:24:04 +0000
commit6a5c7cc019211fe0be7ea05765666a4610b6b6d6 (patch)
treed5a216f9966364ebe87188aa8b19728105cd34d8
parentbf8555d09ed58dedb22d65964002b8113a2b781f (diff)
downloadports-6a5c7cc.tar.gz
ports-6a5c7cc.zip
cleanup: Remove expired ports:
2022-08-01 editors/codelite: Has been broken for over a year.
-rw-r--r--MOVED1
-rw-r--r--editors/Makefile1
-rw-r--r--editors/codelite/Makefile92
-rw-r--r--editors/codelite/distinfo3
-rw-r--r--editors/codelite/files/patch-DatabaseExplorer_MySqlDbAdapter.cpp11
-rw-r--r--editors/codelite/files/patch-DatabaseExplorer_PostgreSqlDbAdapter.cpp11
-rw-r--r--editors/codelite/files/patch-DatabaseExplorer_SqliteDbAdapter.cpp11
-rw-r--r--editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt14
-rw-r--r--editors/codelite/pkg-descr7
-rw-r--r--editors/codelite/pkg-plist301
10 files changed, 1 insertions, 451 deletions
diff --git a/MOVED b/MOVED
index 58e915fda88e..728f7c33e5d1 100644
--- a/MOVED
+++ b/MOVED
@@ -17527,3 +17527,4 @@ deskutils/gnome-system-log||2022-08-01|Has expired: Did not survive gnome 3
deskutils/gnome-documents||2022-08-01|Has expired: Archived upstream
deskutils/gnome-search-tool||2022-08-01|Has expired: Did not survive gnome3
security/nextcloud-twofactor_u2f|security/nextcloud-twofactor_webauthn|2022-08-01|Has expired: Upstream deprecated this port in favor of twofactor_webauthn. Check https://github.com/nextcloud/twofactor_webauthn#migration-from-two-factor-u2f for migration instructions
+editors/codelite||2022-08-01|Has expired: Has been broken for over a year.
diff --git a/editors/Makefile b/editors/Makefile
index 300a6613f01a..8b37bb92b234 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -17,7 +17,6 @@
SUBDIR += calligra
SUBDIR += calligraplan
SUBDIR += chexedit
- SUBDIR += codelite
SUBDIR += cooledit
SUBDIR += cpeditor
SUBDIR += cream
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
deleted file mode 100644
index c6e2be624f9e..000000000000
--- a/editors/codelite/Makefile
+++ /dev/null
@@ -1,92 +0,0 @@
-PORTNAME= codelite
-PORTVERSION= 12.0
-PORTREVISION= 4
-CATEGORIES= editors devel
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Open Source IDE for C/C++
-
-LICENSE= GPLv2+
-
-BROKEN= outdated, doesn't build with Pango 1.46.2 or newer - PR 249879
-DEPRECATED= Has been broken for over a year.
-EXPIRATION_DATE= 2022-08-01
-
-RUN_DEPENDS= xterm:x11/xterm
-LIB_DEPENDS+= libhunspell-1.7.so:textproc/hunspell
-
-#BROKEN_armv6= fails to configure: has leading or trailing whitespace. This is now an error according to policy CMP0004
-
-USE_GITHUB= yes
-GH_ACCOUNT= eranif
-
-USES= cmake:noninja compiler:c++11-lib dos2unix gettext gnome pathfix \
- pkgconfig shebangfix sqlite
-USE_GNOME+= cairo gtk20
-DOS2UNIX_GLOB= *.cpp *.txt
-SHEBANG_FILES= Runtime/codelite_xterm
-bash_CMD= /bin/sh
-USE_WX= 3.0
-CMAKE_ARGS= -DPREFIX:STRING="${PREFIX}" \
- -DIS_FREEBSD:STRING=1 \
- -DCL_WX_CONFIG:STRING="${WX_CONFIG:T}"
-USE_LDCONFIG= ${PREFIX}/lib/codelite
-
-OPTIONS_DEFINE= CSCOPE SFTP
-OPTIONS_RADIO= CLANG
-OPTIONS_SUB= yes
-
-CSCOPE_DESC= CScope integration
-CSCOPE_RUN_DEPENDS= cscope:devel/cscope
-SFTP_DESC= Secure FTP support via libssh
-SFTP_LIB_DEPENDS= libssh.so:security/libssh
-SFTP_CMAKE_OFF= -DENABLE_SFTP:STRING=0
-SFTP_USES= localbase
-
-CLANG_DESC= Clang code-completion
-
-.for v in 40 50 60
-OPTIONS_RADIO_CLANG+= CLANG$v
-CLANG$v_DESC= Clang ${v:C/(.)(.)/\1.\2.x/}
-CLANG$v_BUILD_DEPENDS= llvm$v>0:devel/llvm$v
-CLANG$v_RUN_DEPENDS= llvm$v>0:devel/llvm$v
-
-post-patch-CLANG$v-on:
- @${REINPLACE_CMD} -e \
- 's|/usr/lib/llvm-.*/|${LOCALBASE}/llvm$v/|' \
- ${WRKSRC}/cmake/Modules/FindLibClang.cmake \
- ${WRKSRC}/cmake/Modules/FindLibLLDB.cmake
-.endfor
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCLANG*}
-CMAKE_ARGS+= -DENABLE_LLDB:STRING=1 -DENABLE_CLANG:STRING=1
-.else
-CMAKE_ARGS+= -DENABLE_LLDB:STRING=0 -DENABLE_CLANG:STRING=0
-.endif
-
-post-patch:
-# Use the correct wx-config
- @${REINPLACE_CMD} -e \
- '/ IS_FREEBSD/s|^|#| ; \
- / CL_WX_CONFIG/s|^|#| ; \
- / -Wno-/s|^|#| ; \
- / -O2/s|^|#| ; \
- s|"-s"|""|' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e \
- 's|"-lkvm"|"-lkvm -lutil"| ; \
- s|share/man|man|' \
- ${WRKSRC}/LiteEditor/CMakeLists.txt
- @${REINPLACE_CMD} -e \
- 's|"-lutil"|"-lkvm -lutil"|' \
- ${WRKSRC}/codelite_terminal/CMakeLists.txt
- @${REINPLACE_CMD} -e \
- '/ADDITIONAL_LIBRARIES/s|""|"-lexecinfo"|' \
- ${WRKSRC}/sdk/codelite_cppcheck/CMakeLists.txt
- @${REINPLACE_CMD} -e \
- 's|/bin/grep|/usr/bin/grep|' \
- ${WRKSRC}/cmake/Modules/FindLibClang.cmake
-
-.include <bsd.port.mk>
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
deleted file mode 100644
index 0b8f27d3862f..000000000000
--- a/editors/codelite/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1545674061
-SHA256 (eranif-codelite-12.0_GH0.tar.gz) = e8912e3e0aea8890b5c65631ad94d58ddc587812c7ac6ec398e37aaa4b7005b4
-SIZE (eranif-codelite-12.0_GH0.tar.gz) = 111899973
diff --git a/editors/codelite/files/patch-DatabaseExplorer_MySqlDbAdapter.cpp b/editors/codelite/files/patch-DatabaseExplorer_MySqlDbAdapter.cpp
deleted file mode 100644
index 9f3838fe8e96..000000000000
--- a/editors/codelite/files/patch-DatabaseExplorer_MySqlDbAdapter.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- DatabaseExplorer/MySqlDbAdapter.cpp.orig 2020-08-28 17:23:13 UTC
-+++ DatabaseExplorer/MySqlDbAdapter.cpp
-@@ -210,7 +210,7 @@ bool MySqlDbAdapter::GetColumns(Table* pTab)
- {
- DatabaseLayerPtr dbLayer = this->GetDatabaseLayer(wxT(""));
-
-- if (!dbLayer->IsOpen()) return NULL;
-+ if (!dbLayer->IsOpen()) return false;
- // loading columns
- //TODO:SQL:
- DatabaseResultSet *database = dbLayer->RunQueryWithResults(wxString::Format(wxT("SHOW COLUMNS IN `%s`.`%s`"),pTab->GetParentName().c_str(),pTab->GetName().c_str()));
diff --git a/editors/codelite/files/patch-DatabaseExplorer_PostgreSqlDbAdapter.cpp b/editors/codelite/files/patch-DatabaseExplorer_PostgreSqlDbAdapter.cpp
deleted file mode 100644
index 9e2d570a76c6..000000000000
--- a/editors/codelite/files/patch-DatabaseExplorer_PostgreSqlDbAdapter.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- DatabaseExplorer/PostgreSqlDbAdapter.cpp.orig 2020-08-28 17:27:12 UTC
-+++ DatabaseExplorer/PostgreSqlDbAdapter.cpp
-@@ -307,7 +307,7 @@ bool PostgreSqlDbAdapter::GetColumns(Table* pTab) {
- // SetDatabase(pTab->GetParentName());
- DatabaseLayerPtr dbLayer = this->GetDatabaseLayer(pTab->GetParentName());
-
-- if (!dbLayer->IsOpen()) return NULL;
-+ if (!dbLayer->IsOpen()) return false;
- // loading columns
- //TODO:SQL:
- //DatabaseResultSet *database = dbLayer->RunQueryWithResults(wxString::Format(wxT("SHOW COLUMNS IN `%s`.`%s`"),pTab->getParentName().c_str(),pTab->getName().c_str()));
diff --git a/editors/codelite/files/patch-DatabaseExplorer_SqliteDbAdapter.cpp b/editors/codelite/files/patch-DatabaseExplorer_SqliteDbAdapter.cpp
deleted file mode 100644
index 1b908a8b4821..000000000000
--- a/editors/codelite/files/patch-DatabaseExplorer_SqliteDbAdapter.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- DatabaseExplorer/SqliteDbAdapter.cpp.orig 2020-08-28 17:30:30 UTC
-+++ DatabaseExplorer/SqliteDbAdapter.cpp
-@@ -122,7 +122,7 @@ bool SQLiteDbAdapter::GetColumns(Table* pTab) {
- int i = 0;
- DatabaseLayerPtr dbLayer = this->GetDatabaseLayer(wxT(""));
- if (dbLayer) {
-- if (!dbLayer->IsOpen()) return NULL;
-+ if (!dbLayer->IsOpen()) return false;
- // loading columns
- //TODO:SQL:
- DatabaseResultSet *database = dbLayer->RunQueryWithResults(wxString::Format(wxT("PRAGMA table_info('%s')"),pTab->GetName().c_str()));
diff --git a/editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt b/editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt
deleted file mode 100644
index 33ec9aaf736d..000000000000
--- a/editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- sdk/codelite_cppcheck/CMakeLists.txt.orig 2018-01-17 21:37:24 UTC
-+++ sdk/codelite_cppcheck/CMakeLists.txt
-@@ -5,8 +5,10 @@ cmake_minimum_required(VERSION 2.6.2)
- # visual studio, and in our makefiles.
- project(codelitegcc)
-
-+set (CMAKE_INCLUDE_DIRECTORIES ON)
-+
- # Include paths
--include_directories("${CL_SRC_ROOT}/sdk/codelite_cppcheck/lib" "${CL_SRC_ROOT}/sdk/codelite_cppcheck/cli")
-+include_directories(BEFORE "${CL_SRC_ROOT}/sdk/codelite_cppcheck/lib" "${CL_SRC_ROOT}/sdk/codelite_cppcheck/cli")
-
- set( ADDITIONAL_LIBRARIES "" )
-
diff --git a/editors/codelite/pkg-descr b/editors/codelite/pkg-descr
deleted file mode 100644
index e12b6ae8e4ae..000000000000
--- a/editors/codelite/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-CodeLite is a powerful open-source, cross platform code editor for the
-C/C++ programming languages.
-
-CodeLite uses a sophisticated, yet intuitive interface which allows
-user to easy create and build complex projects.
-
-WWW: https://codelite.org/
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
deleted file mode 100644
index 7e858c855bbc..000000000000
--- a/editors/codelite/pkg-plist
+++ /dev/null
@@ -1,301 +0,0 @@
-bin/codelite
-bin/codelite-cc
-bin/codelite-echo
-bin/codelite-make
-bin/codelite-terminal
-bin/codelite_cppcheck
-bin/codelite_exec
-bin/codelite_fix_files
-bin/codelite_indexer
-bin/codelite_kill_children
-bin/codelite_xterm
-lib/codelite/AutoSave.so
-lib/codelite/CMakePlugin.so
-lib/codelite/CallGraph.so
-lib/codelite/CodeFormatter.so
-lib/codelite/CodeLiteDiff.so
-lib/codelite/ContinuousBuild.so
-lib/codelite/Copyright.so
-lib/codelite/DatabaseExplorer.so
-lib/codelite/EditorConfigPlugin.so
-lib/codelite/ExternalTools.so
-lib/codelite/HelpPlugin.so
-lib/codelite/MemCheck.so
-lib/codelite/Outline.so
-lib/codelite/PHPLint.so
-lib/codelite/PHPRefactoring.so
-lib/codelite/QMakePlugin.so
-%%SFTP%%lib/codelite/SFTP.so
-lib/codelite/SmartCompletion.so
-lib/codelite/SnipWiz.so
-lib/codelite/SpellCheck.so
-lib/codelite/Subversion.so
-lib/codelite/Tail.so
-lib/codelite/Tweaks.so
-lib/codelite/UnitTestsPP.so
-lib/codelite/WebTools.so
-lib/codelite/Wizards.so
-lib/codelite/WordCompletion.so
-lib/codelite/ZoomNavigator.so
-lib/codelite/abbreviation.so
-lib/codelite/codelite_vim.so
-lib/codelite/codelitephp.so
-lib/codelite/cppchecker.so
-lib/codelite/cscope.so
-lib/codelite/debuggers/DebuggerGDB.so
-lib/codelite/git.so
-lib/codelite/libdatabaselayersqlite.so
-lib/codelite/liblibcodelite.so
-lib/codelite/libplugin.so
-lib/codelite/libwxshapeframework.so
-lib/codelite/libwxsqlite3.so
-lib/codelite/wxFormBuilder.so
-share/man/man1/codelite.1.gz
-share/man/man1/codelite-make.1.gz
-share/man/man1/codelite_fix_files.1.gz
-share/applications/codelite.desktop
-%%DATADIR%%/LICENSE
-%%DATADIR%%/PHP.zip
-%%DATADIR%%/astyle.sample
-%%DATADIR%%/codelite-bitmaps.zip
-%%DATADIR%%/codelite-icons-dark.zip
-%%DATADIR%%/codelite-icons-fresh-farm.zip
-%%DATADIR%%/codelite-icons.zip
-%%DATADIR%%/config/accelerators.conf.default
-%%DATADIR%%/config/build_settings.xml.default
-%%DATADIR%%/config/cfg/avr.cfg
-%%DATADIR%%/config/cfg/cppcheck-cfg.rng
-%%DATADIR%%/config/cfg/gnu.cfg
-%%DATADIR%%/config/cfg/gtk.cfg
-%%DATADIR%%/config/cfg/microsoft_sal.cfg
-%%DATADIR%%/config/cfg/posix.cfg
-%%DATADIR%%/config/cfg/qt.cfg
-%%DATADIR%%/config/cfg/sdl.cfg
-%%DATADIR%%/config/cfg/sfml.cfg
-%%DATADIR%%/config/cfg/std.cfg
-%%DATADIR%%/config/cfg/windows.cfg
-%%DATADIR%%/config/cfg/wxwidgets.cfg
-%%DATADIR%%/config/codelite.xml.default
-%%DATADIR%%/config/debuggers.xml.default
-%%DATADIR%%/dics/en_GB.aff
-%%DATADIR%%/dics/en_GB.dic
-%%DATADIR%%/dics/en_US.aff
-%%DATADIR%%/dics/en_US.dic
-%%DATADIR%%/gdb_printers/boost/__init__.py
-%%DATADIR%%/gdb_printers/boost/printers.py
-%%DATADIR%%/gdb_printers/helper.py
-%%DATADIR%%/gdb_printers/libstdcxx/__init__.py
-%%DATADIR%%/gdb_printers/libstdcxx/v6/__init__.py
-%%DATADIR%%/gdb_printers/libstdcxx/v6/printers.py
-%%DATADIR%%/gdb_printers/qt4.py
-%%DATADIR%%/gdb_printers/wx.py
-%%DATADIR%%/images/common_tasks.png
-%%DATADIR%%/images/help_earth.png
-%%DATADIR%%/images/plugin_not_ok.png
-%%DATADIR%%/images/plugin_ok.png
-%%DATADIR%%/images/recent_files.png
-%%DATADIR%%/images/recent_workspaces.png
-%%DATADIR%%/images/splashscreen.png
-%%DATADIR%%/images/splashscreen@2x.png
-%%DATADIR%%/javascript.zip
-%%DATADIR%%/jsctags.zip
-%%DATADIR%%/lexers/lexers.json
-%%DATADIR%%/php.sample
-%%DATADIR%%/phprefactor.phar
-%%DATADIR%%/rc/menu.xrc
-%%DATADIR%%/resources/abbrev.png
-%%DATADIR%%/resources/compfile.png
-%%DATADIR%%/resources/connect_no.png
-%%DATADIR%%/resources/cppcheck.png
-%%DATADIR%%/resources/qt16_new.png
-%%DATADIR%%/resources/qt16_preferences.png
-%%DATADIR%%/resources/qt24_new.png
-%%DATADIR%%/resources/qt24_preferences.png
-%%DATADIR%%/resources/svn_diff.png
-%%DATADIR%%/resources/svn_settings.png
-%%DATADIR%%/resources/svn_ssh.png
-%%DATADIR%%/resources/wxfb_conflict.png
-%%DATADIR%%/resources/wxfb_modified.png
-%%DATADIR%%/resources/wxfb_ok.png
-%%DATADIR%%/templates/codedesigner/CDTemplate.cdp
-%%DATADIR%%/templates/codedesigner/HSCHTemplate.cdp
-%%DATADIR%%/templates/codedesigner/HSCHTemplateWithMain.cdp
-%%DATADIR%%/templates/codedesigner/SCHTemplate.cdp
-%%DATADIR%%/templates/codedesigner/SCHTemplateWithMain.cdp
-%%DATADIR%%/templates/databaselayer/dataClass.ctmp
-%%DATADIR%%/templates/databaselayer/dataClass.htmp
-%%DATADIR%%/templates/databaselayer/dataClass_dba.ctmp
-%%DATADIR%%/templates/databaselayer/dataClass_dba.htmp
-%%DATADIR%%/templates/databaselayer/dataClass_dbl.ctmp
-%%DATADIR%%/templates/databaselayer/dataClass_dbl.htmp
-%%DATADIR%%/templates/databaselayer/dataClass_wxdba.ctmp
-%%DATADIR%%/templates/databaselayer/dataClass_wxdba.htmp
-%%DATADIR%%/templates/databaselayer/viewClass.ctmp
-%%DATADIR%%/templates/databaselayer/viewClass.htmp
-%%DATADIR%%/templates/databaselayer/viewClass_dba.ctmp
-%%DATADIR%%/templates/databaselayer/viewClass_dba.htmp
-%%DATADIR%%/templates/databaselayer/viewClass_dbl.ctmp
-%%DATADIR%%/templates/databaselayer/viewClass_dbl.htmp
-%%DATADIR%%/templates/databaselayer/viewClass_wxdba.ctmp
-%%DATADIR%%/templates/databaselayer/viewClass_wxdba.htmp
-%%DATADIR%%/templates/formbuilder/DialogTemplate.fbp
-%%DATADIR%%/templates/formbuilder/DialogTemplateWithButtons.fbp
-%%DATADIR%%/templates/formbuilder/FrameTemplate.fbp
-%%DATADIR%%/templates/formbuilder/PanelTemplate.fbp
-%%DATADIR%%/templates/gizmos/CMakeLists.txt.plugin.wizard
-%%DATADIR%%/templates/gizmos/app.cpp.wizard
-%%DATADIR%%/templates/gizmos/app.h.wizard
-%%DATADIR%%/templates/gizmos/gui-dialog.cpp.wizard
-%%DATADIR%%/templates/gizmos/gui-dialog.fbp.wizard
-%%DATADIR%%/templates/gizmos/gui-dialog.h.wizard
-%%DATADIR%%/templates/gizmos/gui-frame.cpp.wizard
-%%DATADIR%%/templates/gizmos/gui-frame.fbp.wizard
-%%DATADIR%%/templates/gizmos/gui-frame.h.wizard
-%%DATADIR%%/templates/gizmos/liteeditor-plugin.project.wizard
-%%DATADIR%%/templates/gizmos/main-dialog.cpp.wizard
-%%DATADIR%%/templates/gizmos/main-dialog.h.wizard
-%%DATADIR%%/templates/gizmos/main-frame.cpp.wizard
-%%DATADIR%%/templates/gizmos/main-frame.h.wizard
-%%DATADIR%%/templates/gizmos/main.cpp.wizard
-%%DATADIR%%/templates/gizmos/mainframe.cpp.wizard
-%%DATADIR%%/templates/gizmos/mainframe.h.wizard
-%%DATADIR%%/templates/gizmos/plugin.cpp.wizard
-%%DATADIR%%/templates/gizmos/plugin.h.wizard
-%%DATADIR%%/templates/gizmos/resources.rc.wizard
-%%DATADIR%%/templates/gizmos/wx_pch.h.wizard
-%%DATADIR%%/templates/gizmos/wxmain.project.wizard
-%%DATADIR%%/templates/gizmos/wxproject-fb.project.wizard
-%%DATADIR%%/templates/gizmos/wxproject.project.wizard
-%%DATADIR%%/templates/projects/CMake_Executable/CMakeLists.txt
-%%DATADIR%%/templates/projects/CMake_Executable/CMake_Executable.project
-%%DATADIR%%/templates/projects/CMake_Executable/icon.png
-%%DATADIR%%/templates/projects/CMake_Executable/main.cpp
-%%DATADIR%%/templates/projects/ConsoleClang++/ConsoleClang++.project
-%%DATADIR%%/templates/projects/ConsoleClang++/main.cpp
-%%DATADIR%%/templates/projects/ConsoleClang/ConsoleClang.project
-%%DATADIR%%/templates/projects/ConsoleClang/main.c
-%%DATADIR%%/templates/projects/UnitTest++/UnitTest++.project
-%%DATADIR%%/templates/projects/UnitTest++/icon.png
-%%DATADIR%%/templates/projects/UnitTest++/main.cpp
-%%DATADIR%%/templates/projects/c_gtk24_template/c_gtk24_template.project
-%%DATADIR%%/templates/projects/c_gtk24_template/icon.png
-%%DATADIR%%/templates/projects/c_gtk24_template/main.c
-%%DATADIR%%/templates/projects/c_gtk3_template/c_gtk3_template.project
-%%DATADIR%%/templates/projects/c_gtk3_template/icon.png
-%%DATADIR%%/templates/projects/c_gtk3_template/main.c
-%%DATADIR%%/templates/projects/cobra-executableU/build-file
-%%DATADIR%%/templates/projects/cobra-executableU/cobra-executableU.project
-%%DATADIR%%/templates/projects/cobra-libraryU/cobra-library.project
-%%DATADIR%%/templates/projects/cobra-libraryU/lib-build-files
-%%DATADIR%%/templates/projects/cobra-staticU/build-file
-%%DATADIR%%/templates/projects/cobra-staticU/cobra-staticU.project
-%%DATADIR%%/templates/projects/cpp_gtkmm24_template/cpp_gtkmm24_template.project
-%%DATADIR%%/templates/projects/cpp_gtkmm24_template/icon.png
-%%DATADIR%%/templates/projects/cpp_gtkmm24_template/main.cpp
-%%DATADIR%%/templates/projects/cpp_gtkmm24_template/mainwindow.cpp
-%%DATADIR%%/templates/projects/cpp_gtkmm24_template/mainwindow.h
-%%DATADIR%%/templates/projects/cpp_gtkmm3_template/cpp_gtkmm3_template.project
-%%DATADIR%%/templates/projects/cpp_gtkmm3_template/icon.png
-%%DATADIR%%/templates/projects/cpp_gtkmm3_template/main.cpp
-%%DATADIR%%/templates/projects/cpp_gtkmm3_template/mainwindow.cpp
-%%DATADIR%%/templates/projects/cpp_gtkmm3_template/mainwindow.h
-%%DATADIR%%/templates/projects/custom-makefile/custom-makefile.project
-%%DATADIR%%/templates/projects/custom-makefile/icon.png
-%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project
-%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project.windows
-%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/icon.png
-%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project
-%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project.windows
-%%DATADIR%%/templates/projects/dynamic-library/icon.png
-%%DATADIR%%/templates/projects/executable-cobra/executable-cobra.project
-%%DATADIR%%/templates/projects/executable-cobra/main.cobra
-%%DATADIR%%/templates/projects/executable-console-wx-enabled/executable-console-wx-enabled.project
-%%DATADIR%%/templates/projects/executable-console-wx-enabled/icon.png
-%%DATADIR%%/templates/projects/executable-console-wx-enabled/main.cpp
-%%DATADIR%%/templates/projects/executable-gcc/executable-gcc.project
-%%DATADIR%%/templates/projects/executable-gcc/icon.png
-%%DATADIR%%/templates/projects/executable-gcc/main.c
-%%DATADIR%%/templates/projects/executable-qt-enabled/executable-qt-enabled.project
-%%DATADIR%%/templates/projects/executable-qt-enabled/icon.png
-%%DATADIR%%/templates/projects/executable-qt-enabled/main.cpp
-%%DATADIR%%/templates/projects/executable-qt-qmake-enabled/executable-qt-qmake-enabled.project
-%%DATADIR%%/templates/projects/executable-qt-qmake-enabled/icon.png
-%%DATADIR%%/templates/projects/executable-qt-qmake-enabled/main.cpp
-%%DATADIR%%/templates/projects/executable-wx-dialog/executable-wx-dialog.project
-%%DATADIR%%/templates/projects/executable-wx-dialog/gui.cpp
-%%DATADIR%%/templates/projects/executable-wx-dialog/gui.fbp
-%%DATADIR%%/templates/projects/executable-wx-dialog/gui.h
-%%DATADIR%%/templates/projects/executable-wx-dialog/icon.png
-%%DATADIR%%/templates/projects/executable-wx-dialog/main.cpp
-%%DATADIR%%/templates/projects/executable-wx-dialog/main.h
-%%DATADIR%%/templates/projects/executable-wx-dialog/win_resources.rc
-%%DATADIR%%/templates/projects/executable-wx-enabled/executable-wx-enabled.project
-%%DATADIR%%/templates/projects/executable-wx-enabled/icon.png
-%%DATADIR%%/templates/projects/executable-wx-enabled/main.cpp
-%%DATADIR%%/templates/projects/executable-wx-frame/executable-wx-frame.project
-%%DATADIR%%/templates/projects/executable-wx-frame/gui.cpp
-%%DATADIR%%/templates/projects/executable-wx-frame/gui.fbp
-%%DATADIR%%/templates/projects/executable-wx-frame/gui.h
-%%DATADIR%%/templates/projects/executable-wx-frame/icon.png
-%%DATADIR%%/templates/projects/executable-wx-frame/main.cpp
-%%DATADIR%%/templates/projects/executable-wx-frame/main.h
-%%DATADIR%%/templates/projects/executable-wx-frame/win_resources.rc
-%%DATADIR%%/templates/projects/executable-wx-xrc/executable-wx-xrc.project
-%%DATADIR%%/templates/projects/executable-wx-xrc/gui.wxcp
-%%DATADIR%%/templates/projects/executable-wx-xrc/gui.xrc
-%%DATADIR%%/templates/projects/executable-wx-xrc/icon.png
-%%DATADIR%%/templates/projects/executable-wx-xrc/main.cpp
-%%DATADIR%%/templates/projects/executable-wx-xrc/main.h
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/MainDialog.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/MainDialog.h
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/icon.png
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/main.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/win_resources.rc
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/wxCrafter_MainDialog.project
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/wxcrafter.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/wxcrafter.h
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/wxcrafter.wxcp
-%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/wxcrafter_bitmaps.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/MainFrame.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/MainFrame.h
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/icon.png
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/main.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/win_resources.rc
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/wxCrafter_MainFrame.project
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/wxcrafter.cpp
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/wxcrafter.h
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/wxcrafter.wxcp
-%%DATADIR%%/templates/projects/executable-wxcrafter-frame/wxcrafter_bitmaps.cpp
-%%DATADIR%%/templates/projects/executable/executable.project
-%%DATADIR%%/templates/projects/executable/icon.png
-%%DATADIR%%/templates/projects/executable/main.cpp
-%%DATADIR%%/templates/projects/non-code-project/icon.png
-%%DATADIR%%/templates/projects/non-code-project/non-code.project
-%%DATADIR%%/templates/projects/static-library-wx-enabled/icon.png
-%%DATADIR%%/templates/projects/static-library-wx-enabled/main.cpp
-%%DATADIR%%/templates/projects/static-library-wx-enabled/static-library-wx-enabled.project
-%%DATADIR%%/templates/projects/static-library/icon.png
-%%DATADIR%%/templates/projects/static-library/static-library.project
-%%DATADIR%%/templates/projects/vc-dynamic-library/icon.png
-%%DATADIR%%/templates/projects/vc-dynamic-library/vc-dynamic-library.project
-%%DATADIR%%/templates/projects/vc-executable/icon.png
-%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
-%%DATADIR%%/templates/projects/vc-static-lib/icon.png
-%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
-%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/icon.png
-%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/main_app.cpp
-%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/main_app.h
-%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/wxWidgets_ConsoleApp.project
-%%DATADIR%%/templates/qmake/qmake.project
-%%DATADIR%%/unittest++1.3.tar.gz
-share/icons/hicolor/128x128/apps/codelite.png
-share/icons/hicolor/128x128@2x/apps/codelite.png
-share/icons/hicolor/256x256/apps/codelite.png
-share/icons/hicolor/256x256@2x/apps/codelite.png
-share/icons/hicolor/32x32/apps/codelite.png
-share/icons/hicolor/32x32@2x/apps/codelite.png
-share/icons/hicolor/64x64/apps/codelite.png
-share/icons/hicolor/64x64@2x/apps/codelite.png
-share/locale/cs/LC_MESSAGES/codelite.mo
-share/locale/ru_RU/LC_MESSAGES/codelite.mo
-share/locale/zh_CN/LC_MESSAGES/codelite.mo