aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-28 09:45:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-12 15:18:42 +0000
commit6a8294720bc3ab107a117cc962563c7e42ce9179 (patch)
tree97e76d17ac5fef8ae8fcfe5808db13017cc1cff8
parentee9e5cfd9328ecd7cc0aec2db0c0e8c086ade442 (diff)
downloadports-6a8294720bc3ab107a117cc962563c7e42ce9179.tar.gz
ports-6a8294720bc3ab107a117cc962563c7e42ce9179.zip
devel/intel-graphics-compiler: update to 1.0.6909
-rw-r--r--devel/intel-graphics-compiler/Makefile6
-rw-r--r--devel/intel-graphics-compiler/distinfo10
-rw-r--r--devel/intel-graphics-compiler/files/patch-llvm1117
-rw-r--r--devel/intel-graphics-compiler/files/patch-unix47
4 files changed, 40 insertions, 40 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index 3e9eb411afaf..06b1c2298910 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -1,6 +1,6 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
-DISTVERSION= 1.0.6812
+DISTVERSION= 1.0.6909
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
@@ -18,7 +18,7 @@ USES= bison cmake compiler:c++17-lang python:build
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= intel
-GH_TUPLE= intel:vc-intrinsics:e657f3b:vcintrin/../vc-intrinsics
+GH_TUPLE= intel:vc-intrinsics:069ced1:vcintrin/../vc-intrinsics
CMAKE_OFF= INSTALL_SPIRVDLL
CFLAGS+= -Wno-macro-redefined # __fastcall
PLIST_SUB= ARCH_SUFX=${ARCH:S/i386/32/:S/amd//:S/x86_//}
@@ -32,7 +32,7 @@ post-patch:
${WRKSRC}/IGC/BiFModule/linux/CMakeLists.txt
# devel/llvm* have different naming from upstream under PATH
@${REINPLACE_CMD} -e '/clang-\$$/s//clang$$/' \
- ${WRKSRC}/IGC/cmake/find_opencl_clang.cmake
+ ${WRKSRC}/IGC/cmake/igc_find_opencl_clang.cmake
# No need to abort on every benign warning enabled by default
@${REINPLACE_CMD} -e 's/"-Werror"//; /-Werror/d' \
${WRKSRC}/IGC/CMakeLists.txt
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index e9dd0f6d5ccd..c481c7a41a12 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1616406924
-SHA256 (intel-intel-graphics-compiler-igc-1.0.6812_GH0.tar.gz) = 9685886963b516c8cbb8af1950389b86c0f4ee5c299dd06563a33cf7ade379f4
-SIZE (intel-intel-graphics-compiler-igc-1.0.6812_GH0.tar.gz) = 7377445
-SHA256 (intel-vc-intrinsics-e657f3b_GH0.tar.gz) = ba5192a940158bac0979a4fc567ba3442815dfade2f38e2467ccc226d9a104dc
-SIZE (intel-vc-intrinsics-e657f3b_GH0.tar.gz) = 124133
+TIMESTAMP = 1616924711
+SHA256 (intel-intel-graphics-compiler-igc-1.0.6909_GH0.tar.gz) = 6d387b22c3aba036e66562396a6e717cfd5d11c5758442e87aa567ab9d9576dc
+SIZE (intel-intel-graphics-compiler-igc-1.0.6909_GH0.tar.gz) = 7446677
+SHA256 (intel-vc-intrinsics-069ced1_GH0.tar.gz) = f64cae99ad5a7c31c7ee7403d139be2654b4c6b08e21dd8db3feef939463652f
+SIZE (intel-vc-intrinsics-069ced1_GH0.tar.gz) = 124312
diff --git a/devel/intel-graphics-compiler/files/patch-llvm11 b/devel/intel-graphics-compiler/files/patch-llvm11
index 0607d49ebf71..6ff712a80272 100644
--- a/devel/intel-graphics-compiler/files/patch-llvm11
+++ b/devel/intel-graphics-compiler/files/patch-llvm11
@@ -20,6 +20,9 @@ IGC/Compiler/Optimizer/OpenCLPasses/WIFuncs/WIFuncResolution.cpp:308:27: error:
Size *= DataType->getVectorNumElements();
~~~~~~~~ ^
+IGC/VectorCompiler/lib/GenXCodeGen/GenXDebugInfo.cpp:528:33: error: no viable conversion from 'llvm::StringRef' to 'const std::string' (aka 'const basic_string<char, char_traits<char>, allocator<char>>')
+ auto *VF = VB.GetVISAKernel(F->getName());
+ ^~~~~~~~~~~~
IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp:2203:5: error: no matching function for call to 'RecursivelyDeleteTriviallyDeadInstructions'
RecursivelyDeleteTriviallyDeadInstructions(ToErase);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
@@ -82,6 +85,20 @@ void RecursivelyDeleteTriviallyDeadInstructions(
}
unsigned int AlignedOffset = (Offset / ElemByteSize) * ElemByteSize;
unsigned int LoadByteSize = (Offset == AlignedOffset) ? Size : Size * 2;
+--- IGC/VectorCompiler/lib/GenXCodeGen/GenXDebugInfo.cpp.orig 2021-03-28 09:45:11 UTC
++++ IGC/VectorCompiler/lib/GenXCodeGen/GenXDebugInfo.cpp
+@@ -525,7 +525,11 @@ void GenXDebugInfo::processFunctionGroup(GenXModule &G
+ for (auto *F : IndirectlyCalledFunctions) {
+ LLVM_DEBUG(dbgs() << " F: " << F->getName() << " called indirectly!\n");
+ // Each indirectly-called function is compiled into a separate vISA kernel
++#if LLVM_VERSION_MAJOR < 11
+ auto *VF = VB.GetVISAKernel(F->getName());
++#else
++ auto *VF = VB.GetVISAKernel(F->getName().str());
++#endif
+ processKernel(ProgramInfo{{BuildFunctionInfo(VF, F)}});
+ }
+ std::vector<ProgramInfo::FunctionInfo> PrimaryFIs;
--- IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp.orig 2021-02-15 09:29:30 UTC
+++ IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp
@@ -2194,7 +2194,11 @@ bool GenXPatternMatch::simplifySelect(Function *F) {
diff --git a/devel/intel-graphics-compiler/files/patch-unix b/devel/intel-graphics-compiler/files/patch-unix
index c7eeaec1f03f..d6dbb2e61eb2 100644
--- a/devel/intel-graphics-compiler/files/patch-unix
+++ b/devel/intel-graphics-compiler/files/patch-unix
@@ -6,35 +6,29 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
Please specify one, e.g. Windows32, Linux64, Android32, ...
---- IGC/CMakeLists.txt.orig 2019-11-27 01:05:20 UTC
-+++ IGC/CMakeLists.txt
-@@ -834,11 +834,11 @@ function(igc_arch_detect targetArchVarName hostArchVar
+--- IGC/cmake/igc_arch_utils.cmake.orig 2021-03-28 09:45:11 UTC
++++ IGC/cmake/igc_arch_utils.cmake
+@@ -48,7 +48,7 @@ function(igc_arch_detect targetArchVarName hostArchVar
set(_targetArchitecture "Windows32")
endif()
# Use system processor set by toolchain or CMake.
-- elseif(ANDROID OR (CMAKE_SYSTEM_NAME MATCHES "Linux")
-+ elseif(ANDROID OR (UNIX AND NOT APPLE)
- )
+- elseif(ANDROID OR (CMAKE_SYSTEM_NAME MATCHES "Linux"))
++ elseif(ANDROID OR (UNIX AND NOT APPLE))
if(ANDROID)
set(_targetArchOS "Android")
-- elseif(CMAKE_SYSTEM_NAME MATCHES "Linux")
-+ elseif(UNIX AND NOT APPLE)
- set(_targetArchOS "Linux")
- endif()
-
-@@ -865,9 +865,9 @@ function(igc_arch_detect targetArchVarName hostArchVar
+ else()
+@@ -78,7 +78,7 @@ function(igc_arch_detect targetArchVarName hostArchVar
set(_hostArchitecture "Windows32")
endif()
# Use 'uname -m' to detect kernel architecture.
-- elseif((CMAKE_HOST_SYSTEM_NAME MATCHES "Linux")
-+ elseif((UNIX AND NOT APPLE)
- )
-- if(CMAKE_HOST_SYSTEM_NAME MATCHES "Linux")
-+ if(UNIX AND NOT APPLE)
- set(_hostArchOS "Linux")
- endif()
-
-@@ -2171,7 +2171,7 @@ endif()
+- elseif(CMAKE_HOST_SYSTEM_NAME MATCHES "Linux")
++ elseif(UNIX AND NOT APPLE)
+ set(_hostArchOS "Linux")
+ set(_osArchitecture "x86_64")
+ execute_process(
+--- IGC/CMakeLists.txt.orig 2021-03-28 09:45:11 UTC
++++ IGC/CMakeLists.txt
+@@ -429,7 +429,7 @@ endif()
# NOTE: LLVM_ON_UNIX is also true for Android (CMAKE_SYSTEM_NAME specified by Android toolchain file is also "Linux",
# but we should make sure so there is no errors in our assumptions).
@@ -148,17 +142,6 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
#include "os_inc.h"
#endif
---- IGC/AdaptorOCL/DriverInfoOCL.hpp.orig 2020-02-22 05:52:18 UTC
-+++ IGC/AdaptorOCL/DriverInfoOCL.hpp
-@@ -71,7 +71,7 @@ namespace TC
- bool supportsStatelessSpacePrivateMemory() const override { return true; }
-
- bool NeedFP64(PRODUCT_FAMILY productFamily) const override {
--#if defined(__linux__)
-+#if !defined(__APPLE__) && !defined(_WIN32)
- if (IGC_IS_FLAG_ENABLED(EnableDPEmulation)) {
- return true;
- }
--- IGC/GenISAIntrinsics/GenIntrinsics.h.orig 2020-02-10 06:06:31 UTC
+++ IGC/GenISAIntrinsics/GenIntrinsics.h
@@ -67,7 +67,7 @@ namespace GenISAIntrinsic {