aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-05 17:45:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-05 18:09:28 +0000
commit6b5008371a7c98c09780203bfc4d0e1e49b5b9a1 (patch)
treedc560f419e9d4f4b3564a5fe2cc2d456a783e0ba
parent31885c74549583faf06b5ccdb24dde7da7f07bd4 (diff)
downloadports-6b5008371a7c98c09780203bfc4d0e1e49b5b9a1.tar.gz
ports-6b5008371a7c98c09780203bfc4d0e1e49b5b9a1.zip
devel/nox: New port: Flexible test automation
-rw-r--r--devel/Makefile1
-rw-r--r--devel/nox/Makefile29
-rw-r--r--devel/nox/distinfo3
-rw-r--r--devel/nox/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 06b0f2407e0e..e1d1e785f8bf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1616,6 +1616,7 @@
SUBDIR += node-thrift
SUBDIR += notcurses
SUBDIR += notify-sharp
+ SUBDIR += nox
SUBDIR += npth
SUBDIR += nsgenbind
SUBDIR += nspr
diff --git a/devel/nox/Makefile b/devel/nox/Makefile
new file mode 100644
index 000000000000..fbb5c33c813b
--- /dev/null
+++ b/devel/nox/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= nox
+PORTVERSION= 2022.11.21
+CATEGORIES= devel python
+#MASTER_SITES= PYPI # no tests
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Flexible test automation
+WWW= https://nox.thea.codes/en/stable/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argcomplete>=1.9.4<3.0:devel/py-argcomplete@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorlog>=2.6.1<7.0.0:devel/py-colorlog@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.9:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}virtualenv>=14:devel/py-virtualenv@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.8+
+USE_PYTHON= pep517 autoplist pytest # tests fail to run, see https://github.com/wntrblm/nox/issues/689
+
+USE_GITHUB= yes
+GH_ACCOUNT= wntrblm
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/nox/distinfo b/devel/nox/distinfo
new file mode 100644
index 000000000000..22220ec3434d
--- /dev/null
+++ b/devel/nox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1675617801
+SHA256 (wntrblm-nox-2022.11.21_GH0.tar.gz) = dbff1ce37b5bb0ead4e1ed3e4a2a2527e0dd15e72c9826437c08b73cc3b14a45
+SIZE (wntrblm-nox-2022.11.21_GH0.tar.gz) = 3983862
diff --git a/devel/nox/pkg-descr b/devel/nox/pkg-descr
new file mode 100644
index 000000000000..b1a6aec9d239
--- /dev/null
+++ b/devel/nox/pkg-descr
@@ -0,0 +1,3 @@
+nox is a command-line tool that automates testing in multiple Python
+environments, similar to tox. Unlike tox, Nox uses a standard Python
+file for configuration.