aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-04-28 17:27:20 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-04-28 17:27:42 +0000
commit6c9ae172cae14ef1fabbf403a244d8e108af875f (patch)
treee95e592acd8ace47246840d64b1af63307eeb0b5
parent0cfd6d9e47f71c653fa28dd7bb73fbc53dfb22b9 (diff)
New port: net-mgmt/py-opn-cli: OPNsense CLI written in Python
PR: 255453 Submitted by: Frank Wall <fw@moov.de>
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-opn-cli/Makefile24
-rw-r--r--net-mgmt/py-opn-cli/distinfo3
-rw-r--r--net-mgmt/py-opn-cli/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 38b625291ea7..7e9d618e11d5 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -306,6 +306,7 @@
SUBDIR += py-napalm-logs
SUBDIR += py-ncclient
SUBDIR += py-nxapi-plumbing
+ SUBDIR += py-opn-cli
SUBDIR += py-pdagent
SUBDIR += py-pdagent-integrations
SUBDIR += py-prometheus-client
diff --git a/net-mgmt/py-opn-cli/Makefile b/net-mgmt/py-opn-cli/Makefile
new file mode 100644
index 000000000000..40e66891ec5e
--- /dev/null
+++ b/net-mgmt/py-opn-cli/Makefile
@@ -0,0 +1,24 @@
+# Created by: Frank Wall <fw@moov.de>
+
+PORTNAME= opn-cli
+PORTVERSION= 0.3.0
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= fw@moov.de
+COMMENT= OPNsense CLI written in Python
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=7.0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.20:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR}
+
+USES= python:3.6+
+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-opn-cli/distinfo b/net-mgmt/py-opn-cli/distinfo
new file mode 100644
index 000000000000..b2c2eee1b6fe
--- /dev/null
+++ b/net-mgmt/py-opn-cli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619600457
+SHA256 (opn-cli-0.3.0.tar.gz) = 99b3319d8f22e838ca354bdf9f2a17c27312eae171fc1137ab547896f213b8f9
+SIZE (opn-cli-0.3.0.tar.gz) = 9908
diff --git a/net-mgmt/py-opn-cli/pkg-descr b/net-mgmt/py-opn-cli/pkg-descr
new file mode 100644
index 000000000000..d3e51f2da9b5
--- /dev/null
+++ b/net-mgmt/py-opn-cli/pkg-descr
@@ -0,0 +1,3 @@
+A CLI Interface to communicate with OPNsense firewalls using API requests.
+
+WWW: https://github.com/andeman/opn-cli