aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-06-28 07:04:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-06-28 07:04:38 +0000
commit6d047868ed3063e5c09dfcf302fbc0b65261253c (patch)
tree484859c10cc485c5ae9729b45d77a48c123bc81a
parent191c41f4f5b363d5a9b012dd7fda09ebc060c463 (diff)
devel/commitizen: new port had been added (+)
Commitizen is release management tool designed for teams. It assumes your team uses a standard way of committing rules and from that foundation it can bump your project's version, create the changelog, and update files. WWW: https://commitizen-tools.github.io/commitizen/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/commitizen/Makefile34
-rw-r--r--devel/commitizen/distinfo3
-rw-r--r--devel/commitizen/pkg-descr11
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d4ef9bb42e60..4e325bef4b1d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -454,6 +454,7 @@
SUBDIR += colorgcc
SUBDIR += colormake
SUBDIR += commit-patch
+ SUBDIR += commitizen
SUBDIR += commoncpp
SUBDIR += compiler-rt
SUBDIR += compiz-bcop
diff --git a/devel/commitizen/Makefile b/devel/commitizen/Makefile
new file mode 100644
index 000000000000..01e41226e777
--- /dev/null
+++ b/devel/commitizen/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= commitizen
+PORTVERSION= 3.27.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Commitizen client tool written in Python
+WWW= https://commitizen-tools.github.io/commitizen/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_BDEPS= poetry-core>0:devel/py-poetry-core
+PY_RDEPS= Jinja2>=2.10.3:devel/py-Jinja2 \
+ argcomplete>=1.12.1:devel/py-argcomplete \
+ charset-normalizer>=2.1.0:textproc/py-charset-normalizer \
+ colorama>=0.4.1:devel/py-colorama \
+ decli>=0.6.0:devel/py-decli \
+ importlib-metadata>=4.13:devel/py-importlib-metadata \
+ packaging>=19:devel/py-packaging \
+ prompt-toolkit>0:devel/py-prompt-toolkit \
+ questionary>=1.9:devel/py-questionary \
+ termcolor>=1.1:devel/py-termcolor \
+ tomlkit>=0.5.3:textproc/py-tomlkit \
+ yaml>=3.08:devel/py-yaml
+BUILD_DEPENDS= ${PY_BDEPS:S,^,${PYTHON_PKGNAMEPREFIX},:S,$,@${PY_FLAVOR},}
+RUN_DEPENDS= ${PY_RDEPS:S,^,${PYTHON_PKGNAMEPREFIX},:S,$,@${PY_FLAVOR},}
+
+USES= python
+USE_PYTHON= autoplist pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/commitizen/distinfo b/devel/commitizen/distinfo
new file mode 100644
index 000000000000..08e4770f9857
--- /dev/null
+++ b/devel/commitizen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1716347208
+SHA256 (commitizen-3.27.0.tar.gz) = 5874d0c7e8e1be3b75b1b0a2269cffe3dd5c843b860d84b0bdbb9ea86e3474b8
+SIZE (commitizen-3.27.0.tar.gz) = 49736
diff --git a/devel/commitizen/pkg-descr b/devel/commitizen/pkg-descr
new file mode 100644
index 000000000000..822678aba273
--- /dev/null
+++ b/devel/commitizen/pkg-descr
@@ -0,0 +1,11 @@
+Commitizen is release management tool designed for teams.
+
+Commitizen assumes your team uses a standard way of committing rules and
+from that foundation, it can bump your project's version, create the
+changelog, and update files.
+
+By default, commitizen uses conventional commits, but you can build your
+own set of rules, and publish them.
+
+Using a standardized set of rules to write commits, makes commits easier
+to read, and enforces writing descriptive commits.