aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-03 07:00:47 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-03 07:02:07 +0000
commit6db35e2e57bdeb361f5898c296c25991fd5021a7 (patch)
tree7af0a4b0c5df328bec6e784a752065053258122f
parent05a9d8c83979f8457715c6e498b877624d5825bc (diff)
downloadports-6db35e2e57bdeb361f5898c296c25991fd5021a7.tar.gz
ports-6db35e2e57bdeb361f5898c296c25991fd5021a7.zip
science/py-dftd4: New port: Python API of the DFT-D4 project
-rw-r--r--science/Makefile1
-rw-r--r--science/py-dftd4/Makefile27
-rw-r--r--science/py-dftd4/distinfo3
-rw-r--r--science/py-dftd4/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 0a3c26bb4dd5..7694032d6482 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -314,6 +314,7 @@
SUBDIR += py-cirq-rigetti
SUBDIR += py-coards
SUBDIR += py-dftbplus
+ SUBDIR += py-dftd4
SUBDIR += py-dimod
SUBDIR += py-dipy
SUBDIR += py-dlib
diff --git a/science/py-dftd4/Makefile b/science/py-dftd4/Makefile
new file mode 100644
index 000000000000..6f6a6e65e03d
--- /dev/null
+++ b/science/py-dftd4/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= dftd4
+DISTVERSION= 3.5.0
+CATEGORIES= science python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python API of the DFT-D4 project
+WWW= https://www.chemie.uni-bonn.de/pctc/mulliken-center/software/dftd4
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}meson-python>0:devel/meson-python@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+LIB_DEPENDS= libdftd4.so:science/dftd4
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYNUMPY}
+
+USES= pkgconfig python
+USE_PYTHON= pep517 autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/dftd4/_libdftd4${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/science/py-dftd4/distinfo b/science/py-dftd4/distinfo
new file mode 100644
index 000000000000..ac76ad4f6c70
--- /dev/null
+++ b/science/py-dftd4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691044768
+SHA256 (dftd4-3.5.0.tar.gz) = 4f4cd5c611da558756095b34675cb038192baaae44fd7537e22676742f2f79dd
+SIZE (dftd4-3.5.0.tar.gz) = 495370
diff --git a/science/py-dftd4/pkg-descr b/science/py-dftd4/pkg-descr
new file mode 100644
index 000000000000..834ce786d6db
--- /dev/null
+++ b/science/py-dftd4/pkg-descr
@@ -0,0 +1,4 @@
+py-dftd4 is a python binding for dftd4 (D4).
+
+D4 is a generally applicable atomic-charge dependent london dispersion
+correction calculator.