aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 19:44:20 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 19:44:20 +0000
commit6ea42400ddfa7a7ddd4140497728469aade890fe (patch)
tree5192724b895a1d7315d5d7b6a8cb0fe7f7565bc4
parent5bb0a4a8f2a6fa49ca022a127b48a04e17f3a49b (diff)
downloadports-6ea42400ddfa7a7ddd4140497728469aade890fe.tar.gz
ports-6ea42400ddfa7a7ddd4140497728469aade890fe.zip
devel/py-awscrt: Update to 0.16.26
-rw-r--r--devel/py-awscrt/Makefile2
-rw-r--r--devel/py-awscrt/distinfo6
-rw-r--r--devel/py-awscrt/files/patch-setup.py41
3 files changed, 41 insertions, 8 deletions
diff --git a/devel/py-awscrt/Makefile b/devel/py-awscrt/Makefile
index d1a93fc29734..a51fd2d1a42a 100644
--- a/devel/py-awscrt/Makefile
+++ b/devel/py-awscrt/Makefile
@@ -1,5 +1,5 @@
PORTNAME= awscrt
-PORTVERSION= 0.16.19
+PORTVERSION= 0.16.26
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-awscrt/distinfo b/devel/py-awscrt/distinfo
index 9935e9f7b124..3711d994dfda 100644
--- a/devel/py-awscrt/distinfo
+++ b/devel/py-awscrt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685792224
-SHA256 (awscrt-0.16.19.tar.gz) = f514febfd9cc2b7afa3d3906cf786189a34837e321cd1fb719fbef00a78f2d65
-SIZE (awscrt-0.16.19.tar.gz) = 28488666
+TIMESTAMP = 1692211613
+SHA256 (awscrt-0.16.26.tar.gz) = 1cc8cfa42cd16cb54d8b75417fec0fb038f7318c490209290bdb6c42ad3c2dff
+SIZE (awscrt-0.16.26.tar.gz) = 31262472
diff --git a/devel/py-awscrt/files/patch-setup.py b/devel/py-awscrt/files/patch-setup.py
index 9a9dd25ebe72..765189d8e768 100644
--- a/devel/py-awscrt/files/patch-setup.py
+++ b/devel/py-awscrt/files/patch-setup.py
@@ -1,11 +1,44 @@
---- setup.py.orig 2022-11-09 18:39:08 UTC
+--- setup.py.orig 2023-07-19 00:27:11 UTC
+++ setup.py
-@@ -320,7 +320,7 @@ def awscrt_ext():
+@@ -14,7 +14,6 @@ import shutil
+ import subprocess
+ import sys
+ import sysconfig
+-from wheel.bdist_wheel import bdist_wheel
+
+
+ def is_64bit():
+@@ -283,16 +282,6 @@ class awscrt_build_ext(setuptools.command.build_ext.bu
+ super().run()
+
+
+-class bdist_wheel_abi3(bdist_wheel):
+- def get_tag(self):
+- python, abi, plat = super().get_tag()
+- if python.startswith("cp") and sys.version_info >= (3, 11):
+- # on CPython, our wheels are abi3 and compatible back to 3.11
+- return "cp311", "abi3", plat
+-
+- return python, abi, plat
+-
+-
+ def awscrt_ext():
+ # fetch the CFLAGS/LDFLAGS from env
+ extra_compile_args = os.environ.get('CFLAGS', '').split()
+@@ -360,7 +349,7 @@ def awscrt_ext():
# a proper MacOS Universal2 binary. The linker warns us about this,
# but WHATEVER. Building everything twice (x86_64 and arm64) takes too long.
if not is_macos_universal2():
- extra_link_args += ['-Wl,-fatal_warnings']
+ extra_link_args += ['-Wl,-fatal-warnings']
- return setuptools.Extension(
- '_awscrt',
+ if sys.version_info >= (3, 11):
+ define_macros.append(('Py_LIMITED_API', '0x030B0000'))
+@@ -410,6 +399,6 @@ setuptools.setup(
+ ],
+ python_requires='>=3.7',
+ ext_modules=[awscrt_ext()],
+- cmdclass={'build_ext': awscrt_build_ext, "bdist_wheel": bdist_wheel_abi3},
++ cmdclass={'build_ext': awscrt_build_ext},
+ test_suite='test',
+ )