aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-02-04 23:05:48 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-02-05 00:09:53 +0000
commit6f26e08fc9b753a86b46d827e3bb3618304cce39 (patch)
treebb0b2e1c58fca82cc66ebff56fab1a3e9709ef6f
parentdd4b8a6c2444f98bbd28fc9257034bf67d06fd2c (diff)
downloadports-6f26e08fc9b753a86b46d827e3bb3618304cce39.tar.gz
ports-6f26e08fc9b753a86b46d827e3bb3618304cce39.zip
www/libnghttp2: Update to 1.59.0
* Use CMake for consistency and faster builds * Fixes CVE-2023-44487 Changelog: https://github.com/nghttp2/nghttp2/releases/tag/v1.59.0 PR: 274402 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--www/libnghttp2/Makefile26
-rw-r--r--www/libnghttp2/distinfo6
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt11
-rw-r--r--www/libnghttp2/files/patch-Makefile.in16
-rw-r--r--www/libnghttp2/pkg-plist2
5 files changed, 33 insertions, 28 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 1b713cb71894..98257399a7c2 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.58.0
+DISTVERSION= 1.59.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,12 +12,22 @@ WWW= https://nghttp2.org/ \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-
-CONFIGURE_ARGS= --enable-lib-only
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++14
+USES= cmake cpe pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
+CMAKE_OFF= ENABLE_DOC \
+ ENABLE_FAILMALLOC \
+ ENABLE_HTTP3
+CMAKE_ON= ENABLE_LIB_ONLY \
+ ENABLE_STATIC_LIB \
+ CMAKE_DISABLE_FIND_PACKAGE_Jansson \
+ CMAKE_DISABLE_FIND_PACKAGE_Jemalloc \
+ CMAKE_DISABLE_FIND_PACKAGE_Libcares \
+ CMAKE_DISABLE_FIND_PACKAGE_Libev \
+ CMAKE_DISABLE_FIND_PACKAGE_Libevent \
+ CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2_crypto_openssl \
+ CMAKE_DISABLE_FIND_PACKAGE_LibXml2
+
.include <bsd.port.mk>
diff --git a/www/libnghttp2/distinfo b/www/libnghttp2/distinfo
index 50491ed33c0c..027be1ecc1a6 100644
--- a/www/libnghttp2/distinfo
+++ b/www/libnghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698848712
-SHA256 (nghttp2-1.58.0.tar.xz) = 4a68a3040da92fd9872c056d0f6b0cd60de8410de10b578f8ade9ecc14d297e0
-SIZE (nghttp2-1.58.0.tar.xz) = 1546332
+TIMESTAMP = 1705867821
+SHA256 (nghttp2-1.59.0.tar.xz) = fdc9bd71f5cf8d3fdfb63066b89364c10eb2fdeab55f3c6755cd7917b2ec4ffb
+SIZE (nghttp2-1.59.0.tar.xz) = 1546956
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7d11bf640cd7
--- /dev/null
+++ b/www/libnghttp2/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2023-09-15 17:17:34 UTC
++++ CMakeLists.txt
+@@ -483,7 +483,7 @@ if(ENABLE_DOC)
+ add_subdirectory(doc)
+ endif()
+ add_subdirectory(contrib)
+-add_subdirectory(script)
++#add_subdirectory(script)
+ add_subdirectory(bpf)
+
+
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
deleted file mode 100644
index d4174dca7bda..000000000000
--- a/www/libnghttp2/files/patch-Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.in.orig 2023-02-13 12:02:52 UTC
-+++ Makefile.in
-@@ -448,11 +448,10 @@ top_srcdir = @top_srcdir@
- # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
- # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
--SUBDIRS = lib third-party src bpf examples tests integration-tests \
-- doc contrib script
-+SUBDIRS = lib
-
- ACLOCAL_AMFLAGS = -I m4
--dist_doc_DATA = README.rst
-+dist_doc_DATA =
- EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
- Dockerfile.android \
- cmakeconfig.h.in \
diff --git a/www/libnghttp2/pkg-plist b/www/libnghttp2/pkg-plist
index 11a346002fe9..265bfb64c957 100644
--- a/www/libnghttp2/pkg-plist
+++ b/www/libnghttp2/pkg-plist
@@ -3,5 +3,5 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.14
-lib/libnghttp2.so.14.25.1
+lib/libnghttp2.so.14.26.0
libdata/pkgconfig/libnghttp2.pc