aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 09:59:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 10:21:22 +0000
commit6f76f5265aee2ad5cdf75b9e7d5559194f682f7d (patch)
treef32532992fce19ae7fcc82f5c08d51474be5f875
parent045bd05313355e00fb04e05e7da87560ff9df344 (diff)
devel/py-taskgroup: Add py-taskgroup 0.0.0a4
taskgroup provides backport of asyncio.TaskGroup, asyncio.Runner and asyncio.timeout.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-taskgroup/Makefile23
-rw-r--r--devel/py-taskgroup/distinfo3
-rw-r--r--devel/py-taskgroup/pkg-descr2
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f11190f414b..9744a5996f9c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5796,6 +5796,7 @@
SUBDIR += py-tartiflette
SUBDIR += py-tartiflette-aiohttp
SUBDIR += py-taskflow
+ SUBDIR += py-taskgroup
SUBDIR += py-tasklib
SUBDIR += py-tblib
SUBDIR += py-tdworkflow
diff --git a/devel/py-taskgroup/Makefile b/devel/py-taskgroup/Makefile
new file mode 100644
index 000000000000..adf8cc902508
--- /dev/null
+++ b/devel/py-taskgroup/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= taskgroup
+PORTVERSION= 0.0.0a4
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Backport of asyncio.TaskGroup, asyncio.Runner and asyncio.timeout
+WWW= https://github.com/graingert/taskgroup
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.2<4:devel/py-flit-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}exceptiongroup>=0:devel/py-exceptiongroup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.8<5:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-taskgroup/distinfo b/devel/py-taskgroup/distinfo
new file mode 100644
index 000000000000..e341d71f28d5
--- /dev/null
+++ b/devel/py-taskgroup/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1716448630
+SHA256 (taskgroup-0.0.0a4.tar.gz) = eb08902d221e27661950f2a0320ddf3f939f579279996f81fe30779bca3a159c
+SIZE (taskgroup-0.0.0a4.tar.gz) = 8553
diff --git a/devel/py-taskgroup/pkg-descr b/devel/py-taskgroup/pkg-descr
new file mode 100644
index 000000000000..78b4f2bd7b3d
--- /dev/null
+++ b/devel/py-taskgroup/pkg-descr
@@ -0,0 +1,2 @@
+taskgroup provides backport of asyncio.TaskGroup, asyncio.Runner and
+asyncio.timeout.