aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2021-06-11 15:03:43 +0000
committerBruce A. Mah <bmah@FreeBSD.org>2021-06-11 15:06:14 +0000
commit6f86d9470517968d72b71a829e1c6fe4e6192773 (patch)
tree50c74f2a6d5aa321fd12ebd8911918f5b7b7b4c7
parentf2ef77c8ce9e5b4bf09024624d0716b124b07a10 (diff)
downloadports-6f86d9470517968d72b71a829e1c6fe4e6192773.tar.gz
ports-6f86d9470517968d72b71a829e1c6fe4e6192773.zip
benchmarks/iperf3: Make static library optional.
While here, do some minor changes to Makefile to follow the Porter's Handbook more closely. PR: 256495
-rw-r--r--benchmarks/iperf3/Makefile10
-rw-r--r--benchmarks/iperf3/pkg-plist2
2 files changed, 8 insertions, 4 deletions
diff --git a/benchmarks/iperf3/Makefile b/benchmarks/iperf3/Makefile
index 03d9f3dc732f..4f49a10628e5 100644
--- a/benchmarks/iperf3/Makefile
+++ b/benchmarks/iperf3/Makefile
@@ -1,7 +1,8 @@
# Created by: Bruce A. Mah <bmah@FreeBSD.org>
PORTNAME= iperf
-PORTVERSION= 3.10.1
+DISTVERSION= 3.10.1
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= https://downloads.es.net/pub/iperf/
PKGNAMESUFFIX= 3
@@ -12,8 +13,8 @@ COMMENT= Improved tool to measure TCP and UDP bandwidth
LICENSE= BSD3CLAUSE MIT
LICENSE_COMB= multi
-GNU_CONFIGURE= yes
USES= libtool ssl
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PORTDOCS= README.md RELNOTES.md
@@ -21,7 +22,10 @@ PORTDOCS= README.md RELNOTES.md
# Set ${DOCSDIR} to avoid conflict with benchmarks/iperf ${DOCSDIR}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS STATIC
+OPTIONS_SUB= yes
+
+STATIC_CONFIGURE_ENABLE= static
post-patch:
# Don't build stuff that we're not going to install. Among other
diff --git a/benchmarks/iperf3/pkg-plist b/benchmarks/iperf3/pkg-plist
index ad244993e85c..96004fb1efb1 100644
--- a/benchmarks/iperf3/pkg-plist
+++ b/benchmarks/iperf3/pkg-plist
@@ -1,6 +1,6 @@
bin/iperf3
include/iperf_api.h
-lib/libiperf.a
+%%STATIC%%lib/libiperf.a
lib/libiperf.so
lib/libiperf.so.0
lib/libiperf.so.0.0.0