aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-12-03 20:00:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-12-03 20:20:21 +0000
commit70aa9c66be33b415b141d1a67e37543fd36471ba (patch)
tree99569c149f8bc8bef05267eb36ddeb693d49eb2f
parent534baafe6bce81562f135baad045fb739db53864 (diff)
downloadports-70aa9c66be33b415b141d1a67e37543fd36471ba.tar.gz
ports-70aa9c66be33b415b141d1a67e37543fd36471ba.zip
x11/plasma6-plasma-workspace: unbreak Wayland similar to f06a1b44e85b
-rw-r--r--x11/plasma6-plasma-workspace/Makefile5
-rw-r--r--x11/plasma6-plasma-workspace/files/patch-setup_xdg_environment11
2 files changed, 16 insertions, 0 deletions
diff --git a/x11/plasma6-plasma-workspace/Makefile b/x11/plasma6-plasma-workspace/Makefile
index b92d3f17947c..1872ec3569cd 100644
--- a/x11/plasma6-plasma-workspace/Makefile
+++ b/x11/plasma6-plasma-workspace/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-workspace
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
COMMENT= KDE Plasma Workspace
@@ -39,4 +40,8 @@ USE_KDE= activities activities-stats archive attica5 auth baloo5 \
USE_QT= 5compat base declarative phonon4 svg wayland
USE_XORG= ice sm x11 xau xcb xcursor xext xfixes xft xi xrender xtst
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${PATCH_WRKSRC}/startkde/startplasma.cpp
+
.include <bsd.port.mk>
diff --git a/x11/plasma6-plasma-workspace/files/patch-setup_xdg_environment b/x11/plasma6-plasma-workspace/files/patch-setup_xdg_environment
new file mode 100644
index 000000000000..b6aba665507f
--- /dev/null
+++ b/x11/plasma6-plasma-workspace/files/patch-setup_xdg_environment
@@ -0,0 +1,11 @@
+--- startkde/startplasma.cpp.orig 2023-11-29 10:44:01 UTC
++++ startkde/startplasma.cpp
+@@ -341,7 +341,7 @@ void setupPlasmaEnvironment()
+ // Add kdedefaults dir to allow config defaults overriding from a writable location
+ QByteArray currentConfigDirs = qgetenv("XDG_CONFIG_DIRS");
+ if (currentConfigDirs.isEmpty()) {
+- currentConfigDirs = "/etc/xdg";
++ currentConfigDirs = "%%LOCALBASE%%/etc/xdg:/etc/xdg";
+ }
+ const QString extraConfigDir = QStandardPaths::writableLocation(QStandardPaths::GenericConfigLocation) + QLatin1String("/kdedefaults");
+ QDir().mkpath(extraConfigDir);