aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-04-19 14:49:03 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-04-19 14:53:15 +0000
commit70c2c6806ca3e891bc6ea1c4c710f14c34df63c2 (patch)
treed4ac47a3870fbb82b543114c30b8c5cc93e7e4de
parente837be8809539572c7bdb020dbeadc6269a6382d (diff)
downloadports-70c2c6806ca3e891bc6ea1c4c710f14c34df63c2.tar.gz
ports-70c2c6806ca3e891bc6ea1c4c710f14c34df63c2.zip
textproc/ibus-typing-booster: Adjust *_DEPENDS for Python 3.8+
* Since Python 3.8.7 (and also 3.9.2), .so files get an extension, e.g. ".cpython-38.so" if built with Python 3.8. Thus check for the presence of the Python packages instead of the actual .so files. PR: 253815 Approved by: thierry (maintainer, via e-mail)
-rw-r--r--textproc/ibus-typing-booster/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/textproc/ibus-typing-booster/Makefile b/textproc/ibus-typing-booster/Makefile
index b9d44d089691..c0b985501756 100644
--- a/textproc/ibus-typing-booster/Makefile
+++ b/textproc/ibus-typing-booster/Makefile
@@ -10,16 +10,16 @@ COMMENT= Faster typing by context sensitive completion
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/Menu.py:devel/py-xdg@${PY_FLAVOR} \
- ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
LIB_DEPENDS= libibus-1.0.so:textproc/ibus \
libm17n.so:devel/m17n-lib
RUN_DEPENDS= CLDR>0:textproc/CLDR \
- ${PYTHON_SITELIBDIR}/xdg/Menu.py:devel/py-xdg@${PY_FLAVOR} \
- ${PYTHON_SITELIBDIR}/dbus/bus.py:devel/py-dbus@${PY_FLAVOR} \
- ${PYTHON_SITELIBDIR}/hunspell.so:textproc/py-hunspell@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hunspell>0:textproc/py-hunspell@${PY_FLAVOR} \
${LOCALBASE}/share/unicode/ucd/Index.txt:textproc/UCD \
- ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
TEST_DEPENDS= ${LOCALBASE}/share/hunspell/cs_CZ.dic:textproc/cs-hunspell \
${LOCALBASE}/share/hunspell/de_DE.dic:german/hunspell \
${LOCALBASE}/share/hunspell/en_US.aff:textproc/en-hunspell \
@@ -29,7 +29,7 @@ TEST_DEPENDS= ${LOCALBASE}/share/hunspell/cs_CZ.dic:textproc/cs-hunspell \
${LOCALBASE}/share/hunspell/sv_SE.dic:textproc/sv-hunspell \
${LOCALBASE}/libexec/ibus-engine-m17n:textproc/ibus-m17n \
${LOCALBASE}/share/m17n/hi-inscript2.mim:devel/m17n-inscript2 \
- ${PYTHON_SITELIBDIR}/mock/mock.py:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
gmake:devel/gmake
USE_GITHUB= yes