aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2021-04-14 16:13:30 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2021-04-14 16:13:30 +0000
commit71117cddc9fc29c1e83c14e94c4b04179c0158d3 (patch)
treeeb4fc7fd9fda8faeca6be621c4126043003439e7
parentef24a782a2a4f9dce3b37ecbbb6aa1f798cc96b3 (diff)
downloadports-71117cddc9fc29c1e83c14e94c4b04179c0158d3.tar.gz
ports-71117cddc9fc29c1e83c14e94c4b04179c0158d3.zip
graphics/opencv: Fix JAVA option and correct Apache Ant usage
JAVA option did not work because the actual build knob was wrong. Especially, on a system where devel/apache-ant was installed, ant and java binaries were automatically detected and enabled even if the JAVA option was disabled. While I am here, fix Apache Ant usage by setteing JAVACMD variable. Without it, it may pick up java binary from JRE via javavm(1) from java/javavmwrapper. If ant script is used with java from JRE, build fails because it cannot find jar. Approved by: tcberner (maintainer)
-rw-r--r--graphics/opencv/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 54fd430557f7..a2b19d061238 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -71,8 +71,11 @@ OPTIONS_SUB= yes
HARDENING_CMAKE_BOOL= ENABLE_BUILD_HARDENING
HARDENING_DESC= Enable hardening of the resulting binaries
-JAVA_CMAKE_BOOL= BUILD_openv_java
+JAVA_CMAKE_BOOL= BUILD_JAVA
JAVA_BUILD_DEPENDS= ant:devel/apache-ant
+JAVA_MAKE_ENV= JAVACMD=${JAVA}
+JAVA_USE= JAVA=yes
+JAVA_VARS= JAVA_BUILD=yes
PYTHON_BUILD_DEPENDS= ${PYNUMPY}
PYTHON_RUN_DEPENDS= ${PYNUMPY}