aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2021-07-23 02:49:20 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2021-07-23 02:49:20 +0000
commit7128dc7e1901a55d0d68df709cae497b372be66a (patch)
treed0dee63b1dee697922df15132fe3f343b395016f
parentc61016d798b521f188e74dde9a2b831537777468 (diff)
downloadports-7128dc7e1901a55d0d68df709cae497b372be66a.tar.gz
ports-7128dc7e1901a55d0d68df709cae497b372be66a.zip
devel/spdlog: update to 1.9.0.
-rw-r--r--devel/spdlog/Makefile8
-rw-r--r--devel/spdlog/distinfo10
-rw-r--r--devel/spdlog/files/patch-include_spdlog_common-inl.h11
-rw-r--r--devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h11
-rw-r--r--devel/spdlog/pkg-plist4
5 files changed, 9 insertions, 35 deletions
diff --git a/devel/spdlog/Makefile b/devel/spdlog/Makefile
index ce94fa02f02d..f4d736c43ee7 100644
--- a/devel/spdlog/Makefile
+++ b/devel/spdlog/Makefile
@@ -2,14 +2,10 @@
PORTNAME= spdlog
DISTVERSIONPREFIX= v
-DISTVERSION= 1.8.5
-PORTREVISION= 2
+DISTVERSION= 1.9.0
+PORTREVISION= 0
CATEGORIES= devel
-PATCH_SITES= https://github.com/gabime/spdlog/commit/
-PATCHFILES= 7b14a65b2b8cbdca3c6bd1d36fe5b271389c1d07.patch:-p1 \
- 68111122086187761cca36c24e6d8c8daa96656d.patch:-p1
-
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Super fast C++ logging library
diff --git a/devel/spdlog/distinfo b/devel/spdlog/distinfo
index e0dbb0d02aad..e1bfc6ea28ab 100644
--- a/devel/spdlog/distinfo
+++ b/devel/spdlog/distinfo
@@ -1,7 +1,3 @@
-TIMESTAMP = 1624574846
-SHA256 (gabime-spdlog-v1.8.5_GH0.tar.gz) = 944d0bd7c763ac721398dca2bb0f3b5ed16f67cef36810ede5061f35a543b4b8
-SIZE (gabime-spdlog-v1.8.5_GH0.tar.gz) = 321229
-SHA256 (7b14a65b2b8cbdca3c6bd1d36fe5b271389c1d07.patch) = 5efa9e3b8d4dc4de351dc0e1d2516b2a6e141854e055ae420446785df85d9574
-SIZE (7b14a65b2b8cbdca3c6bd1d36fe5b271389c1d07.patch) = 6523
-SHA256 (68111122086187761cca36c24e6d8c8daa96656d.patch) = a491f1734429203bc298658c1cdc49d1b30b17f8fad6f342511ad1f8692ae666
-SIZE (68111122086187761cca36c24e6d8c8daa96656d.patch) = 753
+TIMESTAMP = 1626865003
+SHA256 (gabime-spdlog-v1.9.0_GH0.tar.gz) = 9ad181d75aaedbf47c8881e7b947a47cac3d306997e39de24dba60db633e70a7
+SIZE (gabime-spdlog-v1.9.0_GH0.tar.gz) = 327592
diff --git a/devel/spdlog/files/patch-include_spdlog_common-inl.h b/devel/spdlog/files/patch-include_spdlog_common-inl.h
deleted file mode 100644
index 0a219ab8ea41..000000000000
--- a/devel/spdlog/files/patch-include_spdlog_common-inl.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/spdlog/common-inl.h.orig 2021-06-24 13:59:17 UTC
-+++ include/spdlog/common-inl.h
-@@ -60,7 +60,7 @@ SPDLOG_INLINE spdlog_ex::spdlog_ex(std::string msg)
- SPDLOG_INLINE spdlog_ex::spdlog_ex(const std::string &msg, int last_errno)
- {
- memory_buf_t outbuf;
-- fmt::format_system_error(outbuf, last_errno, msg);
-+ fmt::format_system_error(outbuf, last_errno, msg.c_str());
- msg_ = fmt::to_string(outbuf);
- }
-
diff --git a/devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h b/devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h
deleted file mode 100644
index 26f9761a4058..000000000000
--- a/devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/spdlog/fmt/bin_to_hex.h.orig 2021-06-24 14:01:22 UTC
-+++ include/spdlog/fmt/bin_to_hex.h
-@@ -209,7 +209,7 @@ struct formatter<spdlog::details::dump_info<T>>
-
- if (put_positions)
- {
-- fmt::format_to(inserter, "{:<04X}: ", pos);
-+ fmt::format_to(inserter, "{:04X}: ", pos);
- }
- }
- };
diff --git a/devel/spdlog/pkg-plist b/devel/spdlog/pkg-plist
index f8893c7be615..239285a83b63 100644
--- a/devel/spdlog/pkg-plist
+++ b/devel/spdlog/pkg-plist
@@ -34,8 +34,10 @@ include/spdlog/details/thread_pool.h
include/spdlog/details/windows_include.h
include/spdlog/fmt/bin_to_hex.h
include/spdlog/fmt/chrono.h
+include/spdlog/fmt/compile.h
include/spdlog/fmt/fmt.h
include/spdlog/fmt/ostr.h
+include/spdlog/fmt/xchar.h
include/spdlog/formatter.h
include/spdlog/fwd.h
include/spdlog/logger-inl.h
@@ -53,9 +55,11 @@ include/spdlog/sinks/daily_file_sink.h
include/spdlog/sinks/dist_sink.h
include/spdlog/sinks/dup_filter_sink.h
include/spdlog/sinks/hourly_file_sink.h
+include/spdlog/sinks/mongo_sink.h
include/spdlog/sinks/msvc_sink.h
include/spdlog/sinks/null_sink.h
include/spdlog/sinks/ostream_sink.h
+include/spdlog/sinks/qt_sinks.h
include/spdlog/sinks/ringbuffer_sink.h
include/spdlog/sinks/rotating_file_sink-inl.h
include/spdlog/sinks/rotating_file_sink.h