aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-07-15 20:51:39 +0000
committerStefan Eßer <se@FreeBSD.org>2022-07-15 20:52:32 +0000
commit724d28fecef60a3b322612f25aaf9afb38f7a8e0 (patch)
tree5d8a8b772f89a1a1c09dc3e41cf56b38db1da913
parentfceb6cc42b69bfa0c156ff39501c784a81080c0f (diff)
downloadports-724d28fecef60a3b322612f25aaf9afb38f7a8e0.tar.gz
ports-724d28fecef60a3b322612f25aaf9afb38f7a8e0.zip
devel/hare: update to upstream commit bd1c1c4a
-rw-r--r--devel/hare/Makefile7
-rw-r--r--devel/hare/distinfo6
-rw-r--r--devel/hare/files/config.mk17
-rw-r--r--devel/hare/pkg-plist41
4 files changed, 64 insertions, 7 deletions
diff --git a/devel/hare/Makefile b/devel/hare/Makefile
index 7f212dfd5a57..3048594d3013 100644
--- a/devel/hare/Makefile
+++ b/devel/hare/Makefile
@@ -1,9 +1,9 @@
PORTNAME= hare
-PORTVERSION= g20220430
+PORTVERSION= g20220709
CATEGORIES= devel
MASTER_SITES= https://git.sr.ht/~sircmpwn/${PORTNAME}/archive/
PKGNAMESUFFIX= -lang
-DISTNAME= 51884435
+DISTNAME= bd1c1c4a
DIST_SUBDIR= hare
MAINTAINER= se@FreeBSD.org
@@ -18,8 +18,7 @@ ONLY_FOR_ARCHS= amd64 # aarch64 riscv64
BUILD_DEPENDS= harec:lang/harec \
qbe:devel/qbe \
scdoc:textproc/scdoc
-RUN_DEPENDS= harec:lang/harec \
- qbe:devel/qbe
+RUN_DEPENDS= harec:lang/harec
MAKE_ARGS= DESTDIR=${STAGEDIR}
diff --git a/devel/hare/distinfo b/devel/hare/distinfo
index 8345c93a65ec..e1231d409940 100644
--- a/devel/hare/distinfo
+++ b/devel/hare/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1651341990
-SHA256 (hare/51884435.tar.gz) = 79325c1c30d2a63212590e254769409c06732e4f8224ac54c2a93875ea26170e
-SIZE (hare/51884435.tar.gz) = 616472
+TIMESTAMP = 1657318428
+SHA256 (hare/bd1c1c4a.tar.gz) = 7ec81b40ddab566583952d639112db1b17b29c05eafb6f9c6de398082dc57cd6
+SIZE (hare/bd1c1c4a.tar.gz) = 679174
diff --git a/devel/hare/files/config.mk b/devel/hare/files/config.mk
index 660ece9f715e..82390a5df19e 100644
--- a/devel/hare/files/config.mk
+++ b/devel/hare/files/config.mk
@@ -30,3 +30,20 @@ SCDOC = scdoc
# Where to store build artifacts
HARECACHE = .cache
+BINOUT = .bin
+
+# Cross-compiler toolchains
+AARCH64_AS=aarch64-as
+AARCH64_AR=aarch64-ar
+AARCH64_CC=aarch64-cc
+AARCH64_LD=aarch64-ld
+
+RISCV64_AS=riscv64-as
+RISCV64_AR=riscv64-ar
+RISCV64_CC=riscv64-cc
+RISCV64_LD=riscv64-ld
+
+X86_64_AS=as
+X86_64_AR=ar
+X86_64_CC=cc
+X86_64_LD=ld
diff --git a/devel/hare/pkg-plist b/devel/hare/pkg-plist
index 65b6d4be1cd2..9b84222ae301 100644
--- a/devel/hare/pkg-plist
+++ b/devel/hare/pkg-plist
@@ -24,6 +24,7 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/bytes/zero.ha
%%DATADIR%%/stdlib/crypto/+test/authenc.ha
%%DATADIR%%/stdlib/crypto/README
+%%DATADIR%%/stdlib/crypto/aes/+test/gcm.ha
%%DATADIR%%/stdlib/crypto/aes/+test/ni+x86_64.ha
%%DATADIR%%/stdlib/crypto/aes/+x86_64/ni.ha
%%DATADIR%%/stdlib/crypto/aes/+x86_64/ni_native.s
@@ -44,6 +45,7 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/crypto/bcrypt/base64.ha
%%DATADIR%%/stdlib/crypto/bcrypt/bcrypt.ha
%%DATADIR%%/stdlib/crypto/blake2b/+test.ha
+%%DATADIR%%/stdlib/crypto/blake2b/README
%%DATADIR%%/stdlib/crypto/blake2b/blake2b.ha
%%DATADIR%%/stdlib/crypto/blake2b/vectors+test.ha
%%DATADIR%%/stdlib/crypto/blowfish/+test.ha
@@ -58,14 +60,20 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/crypto/cipher/cbc.ha
%%DATADIR%%/stdlib/crypto/cipher/cipher.ha
%%DATADIR%%/stdlib/crypto/cipher/ctr.ha
+%%DATADIR%%/stdlib/crypto/cipher/gcm.ha
+%%DATADIR%%/stdlib/crypto/cipher/ghash.ha
%%DATADIR%%/stdlib/crypto/cipher/stream.ha
%%DATADIR%%/stdlib/crypto/conventions.txt
%%DATADIR%%/stdlib/crypto/curve25519/+test.ha
%%DATADIR%%/stdlib/crypto/curve25519/README
%%DATADIR%%/stdlib/crypto/curve25519/curve25519.ha
%%DATADIR%%/stdlib/crypto/ed25519/+test.ha
+%%DATADIR%%/stdlib/crypto/ed25519/README
%%DATADIR%%/stdlib/crypto/ed25519/ed25519.ha
%%DATADIR%%/stdlib/crypto/ed25519/edwards25519.ha
+%%DATADIR%%/stdlib/crypto/hkdf/+test.ha
+%%DATADIR%%/stdlib/crypto/hkdf/README
+%%DATADIR%%/stdlib/crypto/hkdf/hkdf.ha
%%DATADIR%%/stdlib/crypto/hmac/+test.ha
%%DATADIR%%/stdlib/crypto/hmac/README
%%DATADIR%%/stdlib/crypto/hmac/hmac.ha
@@ -78,6 +86,7 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/crypto/mac/README
%%DATADIR%%/stdlib/crypto/mac/mac.ha
%%DATADIR%%/stdlib/crypto/math/README
+%%DATADIR%%/stdlib/crypto/math/arithm.ha
%%DATADIR%%/stdlib/crypto/math/bits.ha
%%DATADIR%%/stdlib/crypto/poly1305/+test.ha
%%DATADIR%%/stdlib/crypto/poly1305/README
@@ -96,6 +105,9 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/crypto/sha512/+test.ha
%%DATADIR%%/stdlib/crypto/sha512/README
%%DATADIR%%/stdlib/crypto/sha512/sha512.ha
+%%DATADIR%%/stdlib/crypto/x25519/+test.ha
+%%DATADIR%%/stdlib/crypto/x25519/README
+%%DATADIR%%/stdlib/crypto/x25519/x25519.ha
%%DATADIR%%/stdlib/datetime/README
%%DATADIR%%/stdlib/datetime/arithmetic.ha
%%DATADIR%%/stdlib/datetime/chronology.ha
@@ -112,7 +124,20 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/encoding/base32/base32.ha
%%DATADIR%%/stdlib/encoding/base64/README
%%DATADIR%%/stdlib/encoding/base64/base64.ha
+%%DATADIR%%/stdlib/encoding/hex/README
%%DATADIR%%/stdlib/encoding/hex/hex.ha
+%%DATADIR%%/stdlib/encoding/json/+test/lexer.ha
+%%DATADIR%%/stdlib/encoding/json/+test/load.ha
+%%DATADIR%%/stdlib/encoding/json/+test/value.ha
+%%DATADIR%%/stdlib/encoding/json/README
+%%DATADIR%%/stdlib/encoding/json/dump.ha
+%%DATADIR%%/stdlib/encoding/json/lex.ha
+%%DATADIR%%/stdlib/encoding/json/load.ha
+%%DATADIR%%/stdlib/encoding/json/types.ha
+%%DATADIR%%/stdlib/encoding/json/value.ha
+%%DATADIR%%/stdlib/encoding/pem/+test.ha
+%%DATADIR%%/stdlib/encoding/pem/README
+%%DATADIR%%/stdlib/encoding/pem/pem.ha
%%DATADIR%%/stdlib/encoding/utf8/README
%%DATADIR%%/stdlib/encoding/utf8/decode.ha
%%DATADIR%%/stdlib/encoding/utf8/encode.ha
@@ -147,6 +172,9 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/format/ini/README
%%DATADIR%%/stdlib/format/ini/scan.ha
%%DATADIR%%/stdlib/format/ini/types.ha
+%%DATADIR%%/stdlib/format/tar/README
+%%DATADIR%%/stdlib/format/tar/reader.ha
+%%DATADIR%%/stdlib/format/tar/types.ha
%%DATADIR%%/stdlib/fs/README
%%DATADIR%%/stdlib/fs/fs.ha
%%DATADIR%%/stdlib/fs/types.ha
@@ -221,9 +249,15 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/hash/crc32/crc32.ha
%%DATADIR%%/stdlib/hash/crc64/README
%%DATADIR%%/stdlib/hash/crc64/crc64.ha
+%%DATADIR%%/stdlib/hash/fnv/+aarch64.ha
+%%DATADIR%%/stdlib/hash/fnv/+riscv64.ha
+%%DATADIR%%/stdlib/hash/fnv/+x86_64.ha
%%DATADIR%%/stdlib/hash/fnv/README
%%DATADIR%%/stdlib/hash/fnv/fnv.ha
%%DATADIR%%/stdlib/hash/hash.ha
+%%DATADIR%%/stdlib/hash/siphash/+test.ha
+%%DATADIR%%/stdlib/hash/siphash/README
+%%DATADIR%%/stdlib/hash/siphash/siphash.ha
%%DATADIR%%/stdlib/io/+freebsd/file.ha
%%DATADIR%%/stdlib/io/+freebsd/mmap.ha
%%DATADIR%%/stdlib/io/+freebsd/vector.ha
@@ -245,6 +279,7 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/io/tee.ha
%%DATADIR%%/stdlib/io/types.ha
%%DATADIR%%/stdlib/io/util.ha
+%%DATADIR%%/stdlib/io/zero.ha
%%DATADIR%%/stdlib/linux/README
%%DATADIR%%/stdlib/linux/env.ha
%%DATADIR%%/stdlib/linux/keyctl/README
@@ -260,6 +295,8 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/log/global.ha
%%DATADIR%%/stdlib/log/logger.ha
%%DATADIR%%/stdlib/math/README
+%%DATADIR%%/stdlib/math/complex/+test.ha
+%%DATADIR%%/stdlib/math/complex/complex.ha
%%DATADIR%%/stdlib/math/data+test.ha
%%DATADIR%%/stdlib/math/fenv+aarch64.ha
%%DATADIR%%/stdlib/math/fenv+riscv64.ha
@@ -480,6 +517,7 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/strings/iter.ha
%%DATADIR%%/stdlib/strings/pad.ha
%%DATADIR%%/stdlib/strings/replace.ha
+%%DATADIR%%/stdlib/strings/runes.ha
%%DATADIR%%/stdlib/strings/sub.ha
%%DATADIR%%/stdlib/strings/suffix.ha
%%DATADIR%%/stdlib/strings/tokenize.ha
@@ -541,12 +579,15 @@ man/man1/haredoc.1.gz
%%DATADIR%%/stdlib/unix/signal/types.ha
%%DATADIR%%/stdlib/unix/tty/+freebsd/isatty.ha
%%DATADIR%%/stdlib/unix/tty/+freebsd/open.ha
+%%DATADIR%%/stdlib/unix/tty/+freebsd/pty.ha
%%DATADIR%%/stdlib/unix/tty/+freebsd/termios.ha
%%DATADIR%%/stdlib/unix/tty/+freebsd/winsize.ha
%%DATADIR%%/stdlib/unix/tty/+linux/isatty.ha
%%DATADIR%%/stdlib/unix/tty/+linux/open.ha
+%%DATADIR%%/stdlib/unix/tty/+linux/pty.ha
%%DATADIR%%/stdlib/unix/tty/+linux/termios.ha
%%DATADIR%%/stdlib/unix/tty/+linux/winsize.ha
+%%DATADIR%%/stdlib/unix/tty/pty.ha
%%DATADIR%%/stdlib/unix/tty/types.ha
%%DATADIR%%/stdlib/uuid/README
%%DATADIR%%/stdlib/uuid/uuid.ha