aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:49 +0000
commit72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63 (patch)
tree5a38291fea0ecf3734c8329b934dc334c8a9feb8
parent915dbfaa562e20c8402d3873f8bfbf07899f9f8a (diff)
downloadports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.tar.gz
ports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.zip
*/*mythes: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
-rw-r--r--french/mythes/Makefile8
-rw-r--r--french/mythes/Makefile 37
-rw-r--r--hungarian/mythes/Makefile4
-rw-r--r--hungarian/mythes/Makefile 26
-rw-r--r--polish/mythes/Makefile4
-rw-r--r--polish/mythes/Makefile 26
-rw-r--r--portuguese/mythes/Makefile8
-rw-r--r--portuguese/mythes/Makefile 30
-rw-r--r--russian/mythes/Makefile8
-rw-r--r--russian/mythes/Makefile 30
-rw-r--r--textproc/bg-mythes/Makefile4
-rw-r--r--textproc/bg-mythes/Makefile 30
-rw-r--r--textproc/cs-mythes/Makefile4
-rw-r--r--textproc/cs-mythes/Makefile 27
-rw-r--r--textproc/en-mythes/Makefile8
-rw-r--r--textproc/en-mythes/Makefile 38
-rw-r--r--textproc/es-mythes/Makefile8
-rw-r--r--textproc/es-mythes/Makefile 39
-rw-r--r--textproc/it-mythes/Makefile4
-rw-r--r--textproc/it-mythes/Makefile 27
-rw-r--r--textproc/nl-mythes/Makefile8
-rw-r--r--textproc/nl-mythes/Makefile 37
-rw-r--r--textproc/ro-mythes/Makefile4
-rw-r--r--textproc/ro-mythes/Makefile 27
-rw-r--r--textproc/sk-mythes/Makefile4
-rw-r--r--textproc/sk-mythes/Makefile 27
-rw-r--r--textproc/sl-mythes/Makefile4
-rw-r--r--textproc/sl-mythes/Makefile 26
-rw-r--r--textproc/sv-mythes/Makefile8
-rw-r--r--textproc/sv-mythes/Makefile 31
-rw-r--r--ukrainian/mythes/Makefile4
-rw-r--r--ukrainian/mythes/Makefile 28
32 files changed, 532 insertions, 46 deletions
diff --git a/french/mythes/Makefile b/french/mythes/Makefile
index 7d32204305d5..db1a8b5a53d6 100644
--- a/french/mythes/Makefile
+++ b/french/mythes/Makefile
@@ -16,13 +16,13 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_fr_FR_v2.dat \
- %%DATADIR%%/th_fr_FR_v2.idx
+PLIST_FILES= ${DATADIR}/th_fr_FR_v2.dat \
+ ${DATADIR}/th_fr_FR_v2.idx
FRALIASES= fr_BE fr_CA fr_CH fr_LU
.for ALIAS in ${FRALIASES}
-PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
- %%DATADIR%%/th_${ALIAS}_v2.idx
+PLIST_FILES+= ${DATADIR}/th_${ALIAS}_v2.dat \
+ ${DATADIR}/th_${ALIAS}_v2.idx
.endfor
do-install:
diff --git a/french/mythes/Makefile b/french/mythes/Makefile
new file mode 100644
index 000000000000..7d32204305d5
--- /dev/null
+++ b/french/mythes/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= mythes
+PORTVERSION= 2.3
+CATEGORIES= french textproc
+MASTER_SITES= http://www.dicollecte.org/download/fr/ \
+ LOCAL/sunpoet/${PORTNAME}
+DISTNAME= thesaurus-v${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= French thesaurus
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_fr_FR_v2.dat \
+ %%DATADIR%%/th_fr_FR_v2.idx
+
+FRALIASES= fr_BE fr_CA fr_CH fr_LU
+.for ALIAS in ${FRALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.dat ${STAGEDIR}${DATADIR}/th_fr_FR_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.idx ${STAGEDIR}${DATADIR}/th_fr_FR_v2.idx
+.for ALIAS in ${FRALIASES}
+ ${LN} -s th_fr_FR_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_fr_FR_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>
diff --git a/hungarian/mythes/Makefile b/hungarian/mythes/Makefile
index e984891ec2ae..22aef6972122 100644
--- a/hungarian/mythes/Makefile
+++ b/hungarian/mythes/Makefile
@@ -16,8 +16,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_hu_HU.dat \
- %%DATADIR%%/th_hu_HU.idx
+PLIST_FILES= ${DATADIR}/th_hu_HU.dat \
+ ${DATADIR}/th_hu_HU.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/hungarian/mythes/Makefile b/hungarian/mythes/Makefile
new file mode 100644
index 000000000000..e984891ec2ae
--- /dev/null
+++ b/hungarian/mythes/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= mythes
+PORTVERSION= 2003.09.29
+PORTREVISION= 1
+CATEGORIES= hungarian textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+DISTNAME= thes_hu_HU-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Hungarian thesaurus
+
+LICENSE= GPLv2
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_hu_HU.dat \
+ %%DATADIR%%/th_hu_HU.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_hu_HU.dat ${WRKSRC}/th_hu_HU.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/polish/mythes/Makefile b/polish/mythes/Makefile
index 32ee0b745495..f57ce48b7ca2 100644
--- a/polish/mythes/Makefile
+++ b/polish/mythes/Makefile
@@ -16,8 +16,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_pl_PL_v2.dat \
- %%DATADIR%%/th_pl_PL_v2.idx
+PLIST_FILES= ${DATADIR}/th_pl_PL_v2.dat \
+ ${DATADIR}/th_pl_PL_v2.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/polish/mythes/Makefile b/polish/mythes/Makefile
new file mode 100644
index 000000000000..32ee0b745495
--- /dev/null
+++ b/polish/mythes/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= mythes
+PORTVERSION= 1.5
+PORTREVISION= 1
+CATEGORIES= polish textproc
+MASTER_SITES= SF/synonimy/synonimy/${PORTVERSION}/
+DISTNAME= OOo2-Thesaurus-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Polish thesaurus
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_pl_PL_v2.dat \
+ %%DATADIR%%/th_pl_PL_v2.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_pl_PL_v2.dat ${WRKSRC}/th_pl_PL_v2.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/portuguese/mythes/Makefile b/portuguese/mythes/Makefile
index cd7c042751a8..461795cfafa0 100644
--- a/portuguese/mythes/Makefile
+++ b/portuguese/mythes/Makefile
@@ -16,10 +16,10 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_pt_BR_v2.dat \
- %%DATADIR%%/th_pt_BR_v2.idx \
- %%DATADIR%%/th_pt_PT_v2.dat \
- %%DATADIR%%/th_pt_PT_v2.idx
+PLIST_FILES= ${DATADIR}/th_pt_BR_v2.dat \
+ ${DATADIR}/th_pt_BR_v2.idx \
+ ${DATADIR}/th_pt_PT_v2.dat \
+ ${DATADIR}/th_pt_PT_v2.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/portuguese/mythes/Makefile b/portuguese/mythes/Makefile
new file mode 100644
index 000000000000..cd7c042751a8
--- /dev/null
+++ b/portuguese/mythes/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= mythes
+PORTVERSION= 2006.08.17
+PORTREVISION= 1
+CATEGORIES= portuguese textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+DISTNAME= thes_pt_PT_v2-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Portuguese thesaurus
+
+LICENSE= GPLv2
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_pt_BR_v2.dat \
+ %%DATADIR%%/th_pt_BR_v2.idx \
+ %%DATADIR%%/th_pt_PT_v2.dat \
+ %%DATADIR%%/th_pt_PT_v2.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_pt_PT_v2.dat ${WRKSRC}/th_pt_PT_v2.idx ${STAGEDIR}${DATADIR}/
+ ${LN} -s th_pt_PT_v2.dat ${STAGEDIR}${DATADIR}/th_pt_BR_v2.dat
+ ${LN} -s th_pt_PT_v2.idx ${STAGEDIR}${DATADIR}/th_pt_BR_v2.idx
+
+.include <bsd.port.mk>
diff --git a/russian/mythes/Makefile b/russian/mythes/Makefile
index 4d8ee44d97d3..c7aa6439b4f2 100644
--- a/russian/mythes/Makefile
+++ b/russian/mythes/Makefile
@@ -16,10 +16,10 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_ru_RU_v2.dat \
- %%DATADIR%%/th_ru_RU_v2.idx \
- %%DATADIR%%/th_ru_UA_v2.dat \
- %%DATADIR%%/th_ru_UA_v2.idx
+PLIST_FILES= ${DATADIR}/th_ru_RU_v2.dat \
+ ${DATADIR}/th_ru_RU_v2.idx \
+ ${DATADIR}/th_ru_UA_v2.dat \
+ ${DATADIR}/th_ru_UA_v2.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/russian/mythes/Makefile b/russian/mythes/Makefile
new file mode 100644
index 000000000000..4d8ee44d97d3
--- /dev/null
+++ b/russian/mythes/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= mythes
+PORTVERSION= 2007.06.13
+PORTREVISION= 1
+CATEGORIES= russian textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+DISTNAME= thes_ru_RU_v2-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Russian thesaurus
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_ru_RU_v2.dat \
+ %%DATADIR%%/th_ru_RU_v2.idx \
+ %%DATADIR%%/th_ru_UA_v2.dat \
+ %%DATADIR%%/th_ru_UA_v2.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_ru_RU_v2.dat ${WRKSRC}/th_ru_RU_v2.idx ${STAGEDIR}${DATADIR}/
+ ${LN} -s th_ru_RU_v2.dat ${STAGEDIR}${DATADIR}/th_ru_UA_v2.dat
+ ${LN} -s th_ru_RU_v2.idx ${STAGEDIR}${DATADIR}/th_ru_UA_v2.idx
+
+.include <bsd.port.mk>
diff --git a/textproc/bg-mythes/Makefile b/textproc/bg-mythes/Makefile
index 1351cb7e6172..b72ca68d8503 100644
--- a/textproc/bg-mythes/Makefile
+++ b/textproc/bg-mythes/Makefile
@@ -20,8 +20,8 @@ USES= zip
NO_ARCH= yes
NO_BUILD= yes
-PLIST_FILES= %%DATADIR%%/th_bg_BG.dat \
- %%DATADIR%%/th_bg_BG.idx
+PLIST_FILES= ${DATADIR}/th_bg_BG.dat \
+ ${DATADIR}/th_bg_BG.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/bg-mythes/Makefile b/textproc/bg-mythes/Makefile
new file mode 100644
index 000000000000..1351cb7e6172
--- /dev/null
+++ b/textproc/bg-mythes/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= mythes
+PORTVERSION= 4.3
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= SF/bgoffice/OpenOffice.org%20Thesaurus%20BG/${PORTVERSION}/
+PKGNAMEPREFIX= bg-
+DISTNAME= OOo-thes-bg-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Bulgarian thesaurus
+
+LICENSE= GPLv2 LGPL21 MPL11
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2= ${WRKSRC}/GPL-2.0.txt
+LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL-2.1.txt
+LICENSE_FILE_MPL11= ${WRKSRC}/MPL-1.1.txt
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= %%DATADIR%%/th_bg_BG.dat \
+ %%DATADIR%%/th_bg_BG.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_bg_BG.dat ${WRKSRC}/th_bg_BG.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/cs-mythes/Makefile b/textproc/cs-mythes/Makefile
index 1857c8c48d3d..f7637bae4fb2 100644
--- a/textproc/cs-mythes/Makefile
+++ b/textproc/cs-mythes/Makefile
@@ -17,8 +17,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_cs_CZ_v2.dat \
- %%DATADIR%%/th_cs_CZ_v2.idx
+PLIST_FILES= ${DATADIR}/th_cs_CZ_v2.dat \
+ ${DATADIR}/th_cs_CZ_v2.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/cs-mythes/Makefile b/textproc/cs-mythes/Makefile
new file mode 100644
index 000000000000..1857c8c48d3d
--- /dev/null
+++ b/textproc/cs-mythes/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= mythes
+PORTVERSION= 2007.09.26
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= cs-
+DISTNAME= thes_cs_CZ_v2-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Czech thesaurus
+
+LICENSE= MIT
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_cs_CZ_v2.dat \
+ %%DATADIR%%/th_cs_CZ_v2.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_cs_CZ_v2.dat ${WRKSRC}/th_cs_CZ_v2.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/en-mythes/Makefile b/textproc/en-mythes/Makefile
index c1dfad83ad1c..fa592d246251 100644
--- a/textproc/en-mythes/Makefile
+++ b/textproc/en-mythes/Makefile
@@ -17,14 +17,14 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_en_US_v2.dat \
- %%DATADIR%%/th_en_US_v2.idx
+PLIST_FILES= ${DATADIR}/th_en_US_v2.dat \
+ ${DATADIR}/th_en_US_v2.idx
USALIASES= en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_IE \
en_IN en_JM en_NA en_NG en_NZ en_PH en_SG en_TT en_ZA en_ZW
.for ALIAS in ${USALIASES}
-PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
- %%DATADIR%%/th_${ALIAS}_v2.idx
+PLIST_FILES+= ${DATADIR}/th_${ALIAS}_v2.dat \
+ ${DATADIR}/th_${ALIAS}_v2.idx
.endfor
do-install:
diff --git a/textproc/en-mythes/Makefile b/textproc/en-mythes/Makefile
new file mode 100644
index 000000000000..c1dfad83ad1c
--- /dev/null
+++ b/textproc/en-mythes/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= mythes
+PORTVERSION= 2006.12.08
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= en-
+DISTNAME= thes_en_US_v2-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= English thesaurus
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_en_US_v2.dat \
+ %%DATADIR%%/th_en_US_v2.idx
+
+USALIASES= en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_IE \
+ en_IN en_JM en_NA en_NG en_NZ en_PH en_SG en_TT en_ZA en_ZW
+.for ALIAS in ${USALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_en_US_v2.dat ${WRKSRC}/th_en_US_v2.idx ${STAGEDIR}${DATADIR}/
+.for ALIAS in ${USALIASES}
+ ${LN} -s th_en_US_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_en_US_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/es-mythes/Makefile b/textproc/es-mythes/Makefile
index 1e1384f47301..fb7401b61af0 100644
--- a/textproc/es-mythes/Makefile
+++ b/textproc/es-mythes/Makefile
@@ -18,14 +18,14 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
USES= tar:bzip2
-PLIST_FILES= %%DATADIR%%/th_es_ES_v2.dat \
- %%DATADIR%%/th_es_ES_v2.idx
+PLIST_FILES= ${DATADIR}/th_es_ES_v2.dat \
+ ${DATADIR}/th_es_ES_v2.idx
ESALIASES= es_AR es_BO es_CL es_CO es_CR es_CU es_DO es_EC es_GT es_HN \
es_MX es_NI es_PA es_PE es_PR es_PY es_SV es_US es_UY es_VE
.for ALIAS in ${ESALIASES}
-PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
- %%DATADIR%%/th_${ALIAS}_v2.idx
+PLIST_FILES+= ${DATADIR}/th_${ALIAS}_v2.dat \
+ ${DATADIR}/th_${ALIAS}_v2.idx
.endfor
do-install:
diff --git a/textproc/es-mythes/Makefile b/textproc/es-mythes/Makefile
new file mode 100644
index 000000000000..1e1384f47301
--- /dev/null
+++ b/textproc/es-mythes/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= mythes
+PORTVERSION= 20140516
+CATEGORIES= textproc spanish
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= es-
+DISTNAME= OOo2-thes_es_ES-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Spanish thesaurus
+
+LICENSE= LGPL21
+
+PORTSCOUT= skipv:20140531
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USES= tar:bzip2
+
+PLIST_FILES= %%DATADIR%%/th_es_ES_v2.dat \
+ %%DATADIR%%/th_es_ES_v2.idx
+
+ESALIASES= es_AR es_BO es_CL es_CO es_CR es_CU es_DO es_EC es_GT es_HN \
+ es_MX es_NI es_PA es_PE es_PR es_PY es_SV es_US es_UY es_VE
+.for ALIAS in ${ESALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_es_ES_v2.dat ${WRKSRC}/th_es_ES_v2.idx ${STAGEDIR}${DATADIR}/
+.for ALIAS in ${ESALIASES}
+ ${LN} -s th_es_ES_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_es_ES_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/it-mythes/Makefile b/textproc/it-mythes/Makefile
index fef59f2addb0..36429eea9808 100644
--- a/textproc/it-mythes/Makefile
+++ b/textproc/it-mythes/Makefile
@@ -17,8 +17,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_it_IT.dat \
- %%DATADIR%%/th_it_IT.idx
+PLIST_FILES= ${DATADIR}/th_it_IT.dat \
+ ${DATADIR}/th_it_IT.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/it-mythes/Makefile b/textproc/it-mythes/Makefile
new file mode 100644
index 000000000000..fef59f2addb0
--- /dev/null
+++ b/textproc/it-mythes/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= mythes
+DISTVERSION= 02_09_l
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= SF/linguistico/Thesaurus%20OOo%202.x.x/${DISTVERSION}_2008_11_29/
+PKGNAMEPREFIX= it-
+DISTNAME= thesaurus2_it_${DISTVERSION}_2008_11_29
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Italian thesaurus
+
+LICENSE= AGPLv3
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_it_IT.dat \
+ %%DATADIR%%/th_it_IT.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_it_IT.dat ${WRKSRC}/th_it_IT.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/nl-mythes/Makefile b/textproc/nl-mythes/Makefile
index 50f463d5ce2e..50ade4cfb96c 100644
--- a/textproc/nl-mythes/Makefile
+++ b/textproc/nl-mythes/Makefile
@@ -16,13 +16,13 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_nl_NL_v2.dat \
- %%DATADIR%%/th_nl_NL_v2.idx
+PLIST_FILES= ${DATADIR}/th_nl_NL_v2.dat \
+ ${DATADIR}/th_nl_NL_v2.idx
NLALIASES= nl_AW nl_BE
.for ALIAS in ${NLALIASES}
-PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
- %%DATADIR%%/th_${ALIAS}_v2.idx
+PLIST_FILES+= ${DATADIR}/th_${ALIAS}_v2.dat \
+ ${DATADIR}/th_${ALIAS}_v2.idx
.endfor
do-install:
diff --git a/textproc/nl-mythes/Makefile b/textproc/nl-mythes/Makefile
new file mode 100644
index 000000000000..50f463d5ce2e
--- /dev/null
+++ b/textproc/nl-mythes/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= mythes
+PORTVERSION= 2015.12.10
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= nl-
+DISTNAME= thes_nl-${PORTVERSION:C/\.//g}
+EXTRACT_SUFX= .oxt
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Dutch thesaurus
+
+LICENSE= BSD3CLAUSE
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_nl_NL_v2.dat \
+ %%DATADIR%%/th_nl_NL_v2.idx
+
+NLALIASES= nl_AW nl_BE
+.for ALIAS in ${NLALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${STAGEDIR}${DATADIR}/th_nl_NL_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${STAGEDIR}${DATADIR}/th_nl_NL_v2.idx
+.for ALIAS in ${NLALIASES}
+ ${LN} -s th_nl_NL_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_nl_NL_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/ro-mythes/Makefile b/textproc/ro-mythes/Makefile
index d7ffd080c3d6..8b2dda755ca4 100644
--- a/textproc/ro-mythes/Makefile
+++ b/textproc/ro-mythes/Makefile
@@ -17,8 +17,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_ro_RO.dat \
- %%DATADIR%%/th_ro_RO.idx
+PLIST_FILES= ${DATADIR}/th_ro_RO.dat \
+ ${DATADIR}/th_ro_RO.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/ro-mythes/Makefile b/textproc/ro-mythes/Makefile
new file mode 100644
index 000000000000..d7ffd080c3d6
--- /dev/null
+++ b/textproc/ro-mythes/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= mythes
+PORTVERSION= 3.3
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= SF/rospell/Romanian%20dictionaries/dict-${PORTVERSION}/
+PKGNAMEPREFIX= ro-
+DISTNAME= th_ro_RO.${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Romanian thesaurus
+
+LICENSE= GPLv2
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_ro_RO.dat \
+ %%DATADIR%%/th_ro_RO.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_ro_RO.dat ${WRKSRC}/th_ro_RO.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/sk-mythes/Makefile b/textproc/sk-mythes/Makefile
index ceba9540f81c..22469b85f904 100644
--- a/textproc/sk-mythes/Makefile
+++ b/textproc/sk-mythes/Makefile
@@ -17,8 +17,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_sk_SK_v2.dat \
- %%DATADIR%%/th_sk_SK_v2.idx
+PLIST_FILES= ${DATADIR}/th_sk_SK_v2.dat \
+ ${DATADIR}/th_sk_SK_v2.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/sk-mythes/Makefile b/textproc/sk-mythes/Makefile
new file mode 100644
index 000000000000..ceba9540f81c
--- /dev/null
+++ b/textproc/sk-mythes/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= mythes
+PORTVERSION= 2020.08.30
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}
+PKGNAMEPREFIX= sk-
+DISTNAME= OOo-Thesaurus2-sk_SK-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Slovak thesaurus
+
+LICENSE= MIT
+
+USES= zip
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_sk_SK_v2.dat \
+ %%DATADIR%%/th_sk_SK_v2.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_sk_SK_v2.dat ${WRKSRC}/th_sk_SK_v2.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/sl-mythes/Makefile b/textproc/sl-mythes/Makefile
index 42807e47a8cd..e1eed72f06a9 100644
--- a/textproc/sl-mythes/Makefile
+++ b/textproc/sl-mythes/Makefile
@@ -16,8 +16,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_sl_SI_v2.dat \
- %%DATADIR%%/th_sl_SI_v2.idx
+PLIST_FILES= ${DATADIR}/th_sl_SI_v2.dat \
+ ${DATADIR}/th_sl_SI_v2.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/sl-mythes/Makefile b/textproc/sl-mythes/Makefile
new file mode 100644
index 000000000000..42807e47a8cd
--- /dev/null
+++ b/textproc/sl-mythes/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= mythes
+PORTVERSION= 2016.06.30
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= sl-
+DISTNAME= thes_sl_SI_v2-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Slovenian thesaurus
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_sl_SI_v2.dat \
+ %%DATADIR%%/th_sl_SI_v2.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_sl_SI_v2.dat ${WRKSRC}/th_sl_SI_v2.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/textproc/sv-mythes/Makefile b/textproc/sv-mythes/Makefile
index adbdfc7e56b7..21a76fd4a037 100644
--- a/textproc/sv-mythes/Makefile
+++ b/textproc/sv-mythes/Makefile
@@ -17,10 +17,10 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_sv_SE.dat \
- %%DATADIR%%/th_sv_SE.idx \
- %%DATADIR%%/th_sv_FI.dat \
- %%DATADIR%%/th_sv_FI.idx
+PLIST_FILES= ${DATADIR}/th_sv_SE.dat \
+ ${DATADIR}/th_sv_SE.idx \
+ ${DATADIR}/th_sv_FI.dat \
+ ${DATADIR}/th_sv_FI.idx
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/sv-mythes/Makefile b/textproc/sv-mythes/Makefile
new file mode 100644
index 000000000000..adbdfc7e56b7
--- /dev/null
+++ b/textproc/sv-mythes/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= mythes
+PORTVERSION= 2008.06.10
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= sv-
+DISTNAME= thes_sv_SE_v2-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Swedish thesaurus
+
+LICENSE= MIT
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_sv_SE.dat \
+ %%DATADIR%%/th_sv_SE.idx \
+ %%DATADIR%%/th_sv_FI.dat \
+ %%DATADIR%%/th_sv_FI.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_sv_SE.dat ${WRKSRC}/th_sv_SE.idx ${STAGEDIR}${DATADIR}/
+ ${LN} -s th_sv_SE.dat ${STAGEDIR}${DATADIR}/th_sv_FI.dat
+ ${LN} -s th_sv_SE.idx ${STAGEDIR}${DATADIR}/th_sv_FI.idx
+
+.include <bsd.port.mk>
diff --git a/ukrainian/mythes/Makefile b/ukrainian/mythes/Makefile
index 41d354055646..8f717bafd6c2 100644
--- a/ukrainian/mythes/Makefile
+++ b/ukrainian/mythes/Makefile
@@ -15,8 +15,8 @@ NO_ARCH= yes
USES= perl5 tar:tgz
USE_PERL5= build
-PLIST_FILES= %%DATADIR%%/th_uk_UA.dat \
- %%DATADIR%%/th_uk_UA.idx
+PLIST_FILES= ${DATADIR}/th_uk_UA.dat \
+ ${DATADIR}/th_uk_UA.idx
do-build:
@${PERL} ${WRKSRC}/bin/th_gen_idx.pl < ${WRKSRC}/src/thesaurus/th_uk_UA.dat > ${WRKSRC}/src/thesaurus/th_uk_UA.idx
diff --git a/ukrainian/mythes/Makefile b/ukrainian/mythes/Makefile
new file mode 100644
index 000000000000..41d354055646
--- /dev/null
+++ b/ukrainian/mythes/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= mythes
+PORTVERSION= 1.8.0
+CATEGORIES= ukrainian textproc
+MASTER_SITES= SF/ispell-uk/spell-uk/${PORTVERSION}
+DISTNAME= spell-uk-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Ukrainian thesaurus
+
+LICENSE= LGPL21 GPLv2
+LICENSE_COMB= dual
+
+NO_ARCH= yes
+USES= perl5 tar:tgz
+USE_PERL5= build
+
+PLIST_FILES= %%DATADIR%%/th_uk_UA.dat \
+ %%DATADIR%%/th_uk_UA.idx
+
+do-build:
+ @${PERL} ${WRKSRC}/bin/th_gen_idx.pl < ${WRKSRC}/src/thesaurus/th_uk_UA.dat > ${WRKSRC}/src/thesaurus/th_uk_UA.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/src/thesaurus/th_uk_UA.dat ${WRKSRC}/src/thesaurus/th_uk_UA.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>