aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-05-18 20:01:14 +0000
committerCy Schubert <cy@FreeBSD.org>2021-05-18 20:07:09 +0000
commit72d1eb161b86e663242d192171078d6babc1afdf (patch)
tree95c3177b86babcad697b09a2d42a3851ffc5c218
parentb5e116597406bb53111afa5a41baa5733842c259 (diff)
downloadports-72d1eb161b86.tar.gz
ports-72d1eb161b86.zip
security/sudo: update to 1.9.7
Among other changes this release fixes -fcommon errors. A complete list of changes can be found at https://www.sudo.ws/stable.html/ PR: 255812 Submitted by: Yasuhiro Kimura <yasu@utahime.org> (mostly) Reported by: Yasuhiro Kimura <yasu@utahime.org> Tested by: cy Approved by: garga (maintainer) MFH: 2021Q2
-rw-r--r--security/sudo/Makefile2
-rw-r--r--security/sudo/distinfo6
-rw-r--r--security/sudo/files/patch-lib_iolog_hostcheck.c25
-rw-r--r--security/sudo/files/patch-scripts_install-sh (renamed from security/sudo/files/patch-install-sh)4
4 files changed, 31 insertions, 6 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index d8e795dab66c..968ce85c5c68 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -1,7 +1,7 @@
# Created by: erich@rrnet.com
PORTNAME= sudo
-PORTVERSION= 1.9.6p1
+PORTVERSION= 1.9.7
CATEGORIES= security
MASTER_SITES= SUDO
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 2ae066f1cc71..9f5c0b2f1986 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1615925605
-SHA256 (sudo-1.9.6p1.tar.gz) = a9e9cdc058fafeb9cd3ebfb864c81755e524d98aa022152763f25bce8ca3ca90
-SIZE (sudo-1.9.6p1.tar.gz) = 4119888
+TIMESTAMP = 1620827684
+SHA256 (sudo-1.9.7.tar.gz) = 2bbe7c2d6699b84d950ef9a43f09d4d967b8bc244b73bc095c4202068ddbe549
+SIZE (sudo-1.9.7.tar.gz) = 4194242
diff --git a/security/sudo/files/patch-lib_iolog_hostcheck.c b/security/sudo/files/patch-lib_iolog_hostcheck.c
new file mode 100644
index 000000000000..c65b642063f5
--- /dev/null
+++ b/security/sudo/files/patch-lib_iolog_hostcheck.c
@@ -0,0 +1,25 @@
+From 96fb72e7cbac29086e51c57e5b629ac5a739e0e2 Mon Sep 17 00:00:00 2001
+From: "Todd C. Miller" <Todd.Miller@sudo.ws>
+Date: Wed, 12 May 2021 07:27:09 -0600
+Subject: [PATCH] Explicitly include netinet/in.h for struct sockaddr_in and
+ sockaddr+_in6. Fixes a compilation problem on FreeBSD.
+
+---
+ lib/iolog/hostcheck.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git lib/iolog/hostcheck.c lib/iolog/hostcheck.c
+index 0dee14b79..3eeabd262 100644
+--- lib/iolog/hostcheck.c
++++ lib/iolog/hostcheck.c
+@@ -24,6 +24,7 @@
+ #if defined(HAVE_OPENSSL)
+ # include <sys/types.h>
+ # include <sys/socket.h>
++# include <netinet/in.h>
+ # include <arpa/inet.h>
+ # include <stdlib.h>
+ # include <string.h>
+--
+2.31.1
+
diff --git a/security/sudo/files/patch-install-sh b/security/sudo/files/patch-scripts_install-sh
index 99ae7ec2b5bc..3bbf0a411340 100644
--- a/security/sudo/files/patch-install-sh
+++ b/security/sudo/files/patch-scripts_install-sh
@@ -1,5 +1,5 @@
---- install-sh.orig 2017-01-14 04:30:15 UTC
-+++ install-sh
+--- scripts/install-sh.orig 2017-01-14 04:30:15 UTC
++++ scripts/install-sh
@@ -171,12 +171,6 @@ if ${DIRMODE} ; then
if [ ! -d "${DEST}" ] ; then
${MKDIR} "${DEST}" || exit 1