aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2021-05-06 23:50:05 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2021-05-06 23:50:05 +0000
commit73059f063ec124bb34540a609f7b6306045e9bd0 (patch)
tree5fb3f2309c15a193c3f15342da46242f68a3a21d
parentf043e2bdfd2063a32f59a9100cfc80bd3a580f7a (diff)
downloadports-73059f063ec124bb34540a609f7b6306045e9bd0.tar.gz
ports-73059f063ec124bb34540a609f7b6306045e9bd0.zip
net/pacemaker1: fix DBUS config option, and its REINPLACE_ARGS
- 'post-patch-common' never used was DBUS_VARS_OFF really set; - REPLACE_ARGS renamed to REPLACE_CMD_ARGS; - REPLACE_ARGS_OCF and REPLACE_ARGS_DBUS append into REPLACE_ARGS. while here, * mark port as broken if OSVERSION>=1300000 PR: 254653 Reported by: masamory7 % gmail.com
-rw-r--r--net/pacemaker1/Makefile5
-rw-r--r--net/pacemaker1/Makefile.common10
2 files changed, 10 insertions, 5 deletions
diff --git a/net/pacemaker1/Makefile b/net/pacemaker1/Makefile
index 81bbb8ce86b8..da2a3734e572 100644
--- a/net/pacemaker1/Makefile
+++ b/net/pacemaker1/Makefile
@@ -1,6 +1,7 @@
# Created by: David Shane Holden <dpejesh@yahoo.com>
PORTVERSION= 1.1.24
+PORTREVISION= 1
PKGNAMESUFFIX= 1
.include "${.CURDIR}/Makefile.common"
@@ -23,6 +24,10 @@ REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 1300000
+BROKEN= "includes <sys/timeb.h> which is deprecated"
+.endif
+
.if ${PYTHON_SUFFIX} > 36
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-cts_remote.py \
${PATCHDIR}/extra-patch-cts_watcher.py
diff --git a/net/pacemaker1/Makefile.common b/net/pacemaker1/Makefile.common
index a49355190113..ca702b94b28e 100644
--- a/net/pacemaker1/Makefile.common
+++ b/net/pacemaker1/Makefile.common
@@ -56,15 +56,12 @@ sh_OLD_CMD= ${SH}
sh_CMD= ${LOCALBASE}/bin/bash
SHEBANG_FILES= extra/resources/*
-REPLACE_ARGS_OCF= -e 's,/usr/lib/ocf,${PREFIX}/lib/ocf,'
-
OPTIONS_DEFINE= DBUS DOCS MANPAGES SNMP
-
OPTIONS_DEFAULT= MANPAGES
OPTIONS_SUB= yes
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
-DBUS_VARS_OFF= REPLACE_ARGS+="-e 's/HAVE_dbus=1/HAVE_dbus=0/'"
+DBUS_VARS_OFF= REPLACE_ARGS_DBUS="-e 's/HAVE_dbus=1/HAVE_dbus=0/'"
DOCS_BUILD_DEPENDS= asciidoc:textproc/asciidoc
@@ -76,6 +73,9 @@ SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_CONFIGURE_WITH= snmp
SNMP_USES= ssl
+REPLACE_CMD_ARGS= -e 's,/usr/lib/ocf,${PREFIX}/lib/ocf,' \
+ ${REPLACE_ARGS_DBUS}
+
# python default version must be set to 2.7 to generate a
# correct pkg-plist
maintainer-plist: stage
@@ -89,4 +89,4 @@ maintainer-plist: stage
> pkg-plist
post-patch-common:
- @${REINPLACE_CMD} ${REPLACE_ARGS_OCF} ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} ${REPLACE_CMD_ARGS} ${WRKSRC}/configure.ac