aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-08 23:43:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-09 00:19:53 +0000
commit734f94bb1164915fa5b49766e2abca64d325285f (patch)
tree0a292217714ab899f4dfd06eb45af7fa5fd0eb41
parentc374177f76c4cda1694935d3046c4719d7455675 (diff)
downloadports-734f94bb1164915fa5b49766e2abca64d325285f.tar.gz
ports-734f94bb1164915fa5b49766e2abca64d325285f.zip
misc/py-fastscapelib: New port: Library of efficient algorithms for topographic data
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-fastscapelib/Makefile32
-rw-r--r--misc/py-fastscapelib/distinfo3
-rw-r--r--misc/py-fastscapelib/pkg-descr2
4 files changed, 38 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d354675c9496..d6994ccfd1c4 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -399,6 +399,7 @@
SUBDIR += py-emoji
SUBDIR += py-ezc3d
SUBDIR += py-fast-histogram
+ SUBDIR += py-fastscapelib
SUBDIR += py-fleep
SUBDIR += py-fuzzy
SUBDIR += py-gluoncv
diff --git a/misc/py-fastscapelib/Makefile b/misc/py-fastscapelib/Makefile
new file mode 100644
index 000000000000..e01d46082ca3
--- /dev/null
+++ b/misc/py-fastscapelib/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= fastscapelib
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.3-53
+DISTVERSIONSUFFIX= -g5698347
+CATEGORIES= misc
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library of efficient algorithms for topographic data
+WWW= https://fastscapelib.readthedocs.io/en/latest/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+BUILD_DEPENDS= cmake:devel/cmake-core \
+ pybind11>0:devel/pybind11 \
+ xtensor>0:math/xtensor \
+ xtensor-python>0:math/xtensor-python \
+ ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= fastscape-lem
+
+WRKSRC_SUBDIR= python
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/py-fastscapelib/distinfo b/misc/py-fastscapelib/distinfo
new file mode 100644
index 000000000000..cfde1fb9f4f9
--- /dev/null
+++ b/misc/py-fastscapelib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673219854
+SHA256 (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 57c3e83041ba7b2e7e8bc789711d20fefc68b223c5e689e5801b23d18bc89c3c
+SIZE (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 107177
diff --git a/misc/py-fastscapelib/pkg-descr b/misc/py-fastscapelib/pkg-descr
new file mode 100644
index 000000000000..5e2149806b01
--- /dev/null
+++ b/misc/py-fastscapelib/pkg-descr
@@ -0,0 +1,2 @@
+py-fastscapelib is a python binding of fastscapelib, a C++ library of efficient
+algorithms for processing topographic data and landscape evolution modeling.