aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2025-02-05 05:11:54 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2025-02-06 05:01:53 +0000
commit73895aa5f1c5a657c8073828f7a548054716d2cc (patch)
treeb153ea7ca589aeb8ace51ae71605f7c8ab34be27
parent88122c70b358d384c2f680cab5e4a81aa7bef8e3 (diff)
*/*: Update ports so they use SAMBA_*_PORT variables in LIB_DEPENDS
* Update ports that work with Samba and depend on either of talloc, tdb and tevent so they use SAMBA_*_PORT variables in LIB_DEPENDS. * Bump PORTREVISION. * While here, update WINBIND_CONFIGURE_ON in net/freeradius3/Makefile so it uses SAMBA_INCLUDEDIR and SAMBA_LIBDIR. Reviewed by: 0mp, kiwi Differential Revision: https://reviews.freebsd.org/D48859
-rw-r--r--net/freeradius3/Makefile15
-rw-r--r--security/sssd2/Makefile8
-rw-r--r--www/squid/Makefile4
3 files changed, 16 insertions, 11 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index dab52cd8b438..af32efd4d73b 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -1,6 +1,6 @@
PORTNAME= freeradius
DISTVERSION= 3.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= https://github.com/FreeRADIUS/freeradius-server/releases/download/release_${DISTVERSION:S/./_/g}/ \
https://freeradius.org/ftp/pub/radius/%SUBDIR%/ \
@@ -21,7 +21,7 @@ BROKEN_SSL_REASON_libressl= LibreSSL is no longer supported
BROKEN_SSL_REASON_libressl-devel= ${BROKEN_SSL_REASON_libressl}
LIB_DEPENDS= libgdbm.so:databases/gdbm \
- libtalloc.so:devel/talloc
+ libtalloc.so:${SAMBA_TALLOC_PORT}
FLAVORS= default ldap mysql pgsql sqlite3
FLAVOR?= ${FLAVORS:[1]}
@@ -151,9 +151,8 @@ UNBOUND_CONFIGURE_WITH= rlm_unbound
UNBOUND_LIB_DEPENDS= libunbound.so:dns/unbound
UNIXODBC_CONFIGURE_WITH= rlm_sql_unixodbc
UNIXODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
-WINBIND_USES= samba:build,lib
-WINBIND_CONFIGURE_ON= --with-winbind-include-dir=${LOCALBASE}/include/samba4 \
- --with-winbind-lib-dir=${LOCALBASE}/lib/samba4
+WINBIND_CONFIGURE_ON= --with-winbind-include-dir=${SAMBA_INCLUDEDIR} \
+ --with-winbind-lib-dir=${SAMBA_LIBDIR}
JSON_CONFIGURE_WITH= rlm_json
JSON_CONFIGURE_ON= --with-jsonc-lib-dir=${LOCALBASE}/lib \
--with-jsonc-include-dir=${LOCALBASE}/include
@@ -167,6 +166,12 @@ SUB_LIST+= RUN_AS_USER="yes"
SUB_LIST+= RUN_AS_USER="no"
.endif
+.if ${PORT_OPTIONS:MWINBIND}
+USES+= samba:build,lib
+.else
+USES+= samba:env
+.endif
+
# User and group to use if USER option is chosen
RADIUS_USER= freeradius
RADIUS_GROUP= freeradius
diff --git a/security/sssd2/Makefile b/security/sssd2/Makefile
index b0fc081d536a..d0fbbca0cb92 100644
--- a/security/sssd2/Makefile
+++ b/security/sssd2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sssd
PORTVERSION= 2.9.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
PKGNAMESUFFIX= 2
@@ -41,9 +41,9 @@ LIB_DEPENDS= libcares.so:dns/c-ares \
libsamba-util.so:${SAMBA_PORT} \
libsasl2.so:security/cyrus-sasl2 \
libsmbclient.so:${SAMBA_PORT} \
- libtalloc.so:devel/talloc \
- libtdb.so:databases/tdb \
- libtevent.so:devel/tevent \
+ libtalloc.so:${SAMBA_TALLOC_PORT} \
+ libtdb.so:${SAMBA_TDB_PORT} \
+ libtevent.so:${SAMBA_TEVENT_PORT} \
libunistring.so:devel/libunistring \
libuuid.so:misc/e2fsprogs-libuuid
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 4d20dfeb86b2..33b326d4413a 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -194,8 +194,8 @@ STACKTRACES_CFLAGS= -g
STACKTRACES_LDFLAGS= -lunwind
STACKTRACES_EXTRA_PATCHES= ${FILESDIR}/extra-patch-gen-stacktrace
STACKTRACES_VARS= STRIP=""
-TDB_LIB_DEPENDS= libtdb.so:databases/tdb
-TDB_USES= pkgconfig:build
+TDB_LIB_DEPENDS= libtdb.so:${SAMBA_TDB_PORT}
+TDB_USES= pkgconfig:build samba:env
TDB_CONFIGURE_WITH= tdb
TDB_VARS= EXTERNAL_ACL+="time_quota session"
TP_IPFW_CONFIGURE_ENABLE= ipfw-transparent